locked
Cannot verify user information at this time. RRS feed

  • Question

  • Hi All

    I get the following message when trying to open a RMS power point. 


    Then followed up with the message 


    I am on Windows 7 and using Office 2010. Any help would be greatly appreciated.

    Cheers

    Vinod

    Sunday, February 26, 2012 11:32 PM

Answers

All replies

  • Hi,

    Start by checking the error's suggestions :

    1# Make sure that Internet Explorer is not configured to work offline.

    2# Verify your your proxy does not prevent the connection.

    3# Make sure that there is no network issue.

    If all points are ok, so there is a hotfix to solve this problem if your Windows 7 is not SP1 http://support.microsoft.com/kb/2255746 (this hotfix is for W2008R2 and W7)  


    Bechir Gharbi | http://myitforum.com/myitforumwp/community/members/bgharbi/ | Time zone : GMT+1

    Tuesday, February 28, 2012 10:22 AM
  • Hi Bechir

    Thanks for the reply, unfortunately I am on Windows 7 SP1. The hotfix did not install and issue persists.

    Regards

    Vinod

    Thursday, March 1, 2012 11:19 PM
  • Vinod,

    Are you able to open any RMS protected documents?  Word, Excel?  Are you able to RMS protect new documents?

    Regards,

    Kevin


    Thanks, Kevin

    Friday, March 2, 2012 10:16 PM
  • Hi Kevin

    I get the same message even when I try to protect a new document as well. The document I am trying is RMS protected. 

    Thanks and Regards

    Vinod


    Saturday, March 3, 2012 1:07 PM
  • Vinod,

    Is this only happening on one computer in your environment, or all of them?  Please run IRMCheck on the Windows 7 system and let me know what errors it shows.

    http://www.ipcgodz.com/tools/irmcheck.zip


    Thanks, Kevin

    Sunday, March 4, 2012 4:17 AM
  • Vinod,

    Make sure that you have the hotfix for http://support.microsoft.com/kb/2596996 installed as it fixes known issues with Office 2010 and RMS.


    Thanks, Kevin

    Sunday, March 4, 2012 4:35 AM
  • Hi Kevin

    Installed the hotfix and unfortunately did not resolve the issue. Here is the IRMcheck results.

    1. Office System SUCCESS Microsoft Office System (build 14.0.6114.5000) is installed
    2. Operating system SUCCESS Windows 7 Home Premium (build 6.1.7601.win7sp1_gdr.110622-1506) is installed. ( 64-bit OS )
    3. RM client SUCCESS Microsoft Rights Management client (build 6.1.7601.17514) is installed [ Production_Hierarchy ]
    4. Kernel Debugger SUCCESS The kernel debugger is not present
    5. Registry overrides ERROR Some registry key overrides listed below do not point to the correct RM servers
    6. Service URLs SUCCESS The Enterprise RM service is not detected
    7. IRM manifests SUCCESS IRM application manifests are correct
    8. Machine activation SUCCESS The machine is activated correctly: 6.1.7601.17514 (RMS Client v3.0 Desktop Security Processor), file:///rmactivate.exe, 3/3/2012 9:54:00 PM [UTC]
    9. User certificates WARNING No user certificates found
    10. System clock SUCCESS The system clock is correct
    11. Pending Reboot SUCCESS No pending reboot detected
    12. Product SKU SUCCESS  
    13. Network Connectivity SUCCESS The computer is online
    14. Domain Membership WARNING Member of WORKGROUP workgroup. You will be unable to acquire permanent Enterprise credentials or use "Everyone" permissions without being a member of a domain
    15. Temporary Directory SUCCESS Temporary directory set to C:\Users\XXXX\AppData\Local\Temp\
    16. Incompatible applications SUCCESS No known incompatible applications found.
    17. User Email in AD ERROR The mail attribute for the logged on user is not set in the AD

    Certificates
    Type Valid Account Account Type SID Issued On Duration Service URLs
    Machine Y 3/3/2012 Always Issued By:file:///rmactivate.exe

    Registry Information
    Office Activation Service registry entry absent
    Office Enterprise Certification Service https://inforights.wxxxx.com/_wmcs/Certification
    Office Enterprise Client Enrollment Service https://inforights.wxxxx.com/_wmcs/licensing
    Office Cloud Certification Service registry entry absent
    Office Cloud Client Enrollment Service https://licensing.drm.microsoft.com/licensing
    Office RM Client Setup URL registry entry absent
    Office IRM Disable registry entry absent
    Office IRM DisablePassportCertification 1
    Office IRM DisableCertificateValidation registry entry absent
    Office IRM Permission Policy Path C:\Program Files\Settings
    Office Cached Enterprise Client Enrollment Service registry entry absent
    RMA Activation Service registry entry absent
    RMA Enterprise Certification Service registry entry absent
    RMA Cloud Certification Service registry entry absent
    RM Activation Service registry entry absent
    RM Enterprise Client Enrollment Service registry entry absent
    RM Cloud Client Enrollment Service registry entry absent
    Use Proxy Server 0
    Proxy Server registry entry absent
    Don't use proxy server for *.local
    Use proxy autoconfig script from registry entry absent
    IE Enhanced Security registry entry absent
    AppInit_DLLs C:\Windows\SysWOW64\nvinit.dll
    The Enterprise Service Discovery results:
    RM Activation Service E_DRM_SERVICE_NOT_FOUND (0x8004cf48)
    RM Certification Service E_DRM_SERVICE_NOT_FOUND (0x8004cf48)
    RM Online Publishing Service E_DRM_SERVICE_NOT_FOUND (0x8004cf48)
    RM Client Enrollment Service E_DRM_SERVICE_NOT_FOUND (0x8004cf48)
    User Shell Folders registry entry present: Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    Thanks again for your help.

    Regards

    Vinod


    Sunday, March 4, 2012 10:36 PM
  • Vinod,

    First, verify that you can access the following sites from the system (I assume you changed the domain name).

    https://inforights.wxxxx.com/_wmcs/Certification

    https://inforights.wxxxx.com/_wmcs/Licensing

    If you connot, look at the DNS resolution for the AD RMS server.  You may need to add the server to the hosts file. If you can get to them, continue with the following steps.

    You are missing registry overrides for the RM Activation and Certification Services.  You need to go into regedit and create the following keys.

    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\MSDRM\ServiceLocation\Activation

    REG_SZ: default

    Value: https://inforights.wxxxx.com/_wmcs/Certification

    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\MSDRM\ServiceLocation\EnterprisePublishing

    REG_SZ: default

    Value: https://inforights.wxxxx.com/_wmcs/Licensing

    This is assuming that https://inforights.wxxxx.com is your ADRMS server.

    More information about these overrides.

    http://technet.microsoft.com/en-us/library/dd772753(WS.10).aspx

    As for the other error, AD RMS must have an email address in AD for users to license and consume content.  Since this is not a domain joined system, you can either join it to the domain and log on with a user that has a valid email account in AD, or you can use Windows Live ID for external sharing of content.  You will only be able to consume content with the WLID, not protect it.  The links below provide additional information for setting that up in your environment.

    http://technet.microsoft.com/en-us/library/dd996640(WS.10).aspx

    http://technet.microsoft.com/en-us/library/cc753056(WS.10).aspx

    Let me know if this resolves your issue.


    Thanks, Kevin


    Monday, March 5, 2012 4:59 AM
  • Hi Kevin

    I was able to reach both the sites (Yes I have changed the domain name purposefully).  Since I did not find the MSDRM Keys (\MSDRM\ServiceLocation\Activation and \MSDRM\ServiceLocation\EnterprisePublishing), I created them in the regedit. 

    This also did not resolve the issue. Wonder something's missing since I did not even find the MSDRM key itself ..!!

    Thanks and Regards

    Vinod 

    Tuesday, March 6, 2012 11:04 PM
  • Vinod,

    The MSDRM key is not there by default.  You must create it and the subkeys for the registry overrides if you are not on a domain or do not have an SCP set.  If you can reach the licensing and certification links, use them to issue a license to the system. 

    https://inforights.wxxxx.com/_wmcs/Certification/certification.asmx

    https://inforights.wxxxx.com/_wmcs/Licensing/license.asmx

    If it fails, post the failure code here.  Also, if you can reach the server then you can check the logging on the ADRMS server and create a report of the failures in the past 24 hours.  If you drill down into the reports it can lead you to the cause.  Let me know what you find.  If none of that works, I would like to see a new irmcheck.


    Thanks, Kevin



    Wednesday, March 7, 2012 1:40 AM
  • Hi Kevin,

    One of our user is also facing similar problem.

    OS: Windows 7 SP1

    Office :2010

    Issue: User is able to read RMS protected mails from OWA but not from Outlook.

    Verified publishing, certification, activation URLs. Able to browse them. Proxy Exceptions are made, but still problem persists.

    Machine is activated and EUL file is also available in DRM folder.

    Made manual entry for MSDRM key in registry. Still problem persists. Need advice/help.

    Encountering below errors

    Regards,

    Uma Yellapragada


    Regards, Uma Yellapragada

    Wednesday, April 10, 2013 7:15 AM
  • Monday, April 22, 2013 2:41 PM