Delay with outbound calls RRS feed

  • Question

  • I have a strange issue with outgoing calls.  When a call is placed out from the Lync server the user hears a number of beeps (anywhere from 3 to 7) before the call starts ringing at the remote end .  This happens regardless of which gateway the calls go out.  I have (2) Mediant 1000 gateways and an asterisk gateway and the issue happens with all three.  Does anyone have an idea as to what could be causing this issue?
    Friday, February 4, 2011 2:40 PM


  • Update:  I was able to resolve the outbound delay by removing the edge server from the topology.  Turns out that it was a networking issue that was causing a delay reaching the edge server on calls.  Once the networking issue was resolved the edge server was added back in without causing a delay.
    • Marked as answer by jyoungjr Wednesday, August 10, 2011 1:56 PM
    Wednesday, August 10, 2011 1:56 PM

All replies

  • You can follow the complete flow of call setup easily by using logging tool (SIPStack, S4 both all flags, full level). Lync Resource kit tool must be installed to decode logging - then you will see SIP messages starting with INVITE from client. Follow this call (there is a right-click option) and you will see who consumes too much time. Firewall?
    Johann Deutinger | MCTS Exchange 2007/2010 / OCS 2007 | ucblog.deutinger.de
    Saturday, February 5, 2011 7:26 PM
  • I am having the same issue and it is something that started in the last month or so.  I have done a trace, and it looks like I get at least a three-five second delay on the Mediation Server:

    This entry occured at 18:30:23.716

    TL_INFO(TF_PROTOCOL) [0]0B04.0FE4::03/16/2011-18:30:23.716.0003eace (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(125))$$begin_record
    Trace-Correlation-Id: 1549530126
    Instance-Id: 00026439
    Direction: outgoing
    Message-Type: response
    Start-Line: SIP/2.0 200 OK
    From: <sip:myname@mydomain.com>;tag=beb6a3cc9a;epid=19697b7f6c
    To: <sip:+17143147451@mydomain.com;user=phone>;tag=726729a9e1;epid=9B726051AE
    CSeq: 2 PRACK
    Call-ID: 1b2a2ead767ed0c7c1091a9e6d3ca392
    Authentication-Info: TLS-DSK qop="auth", opaque="8928731D", srand="670A6C01", snum="429", rspauth="0cdb20c31c843d20821c26329753635445f653b6", targetname="LYNC-VM-FRONT.MYDOMAIN.COM", realm="SIP Communications Service", version=4
    Via: SIP/2.0/TLS;ms-received-port=50576;ms-received-cid=900
    SUPPORTED: ms-dialog-route-set-update
    SERVER: RTCC/ MediationServer
    Message-Body: –

    Then the next entry occurs at 18:30:26.422 - almost a full 3 seconds later

    TL_INFO(TF_PROTOCOL) [0]0A50.0AE0::03/16/2011-18:30:26.422.000417a6 (S4,SipMessage.DataLoggingHelper:sipmessage.cs(613))[1820813433]
    >>>>>>>>>>>>Outgoing SipMessage c=[<SipTlsConnection_107244D>],>
    SIP/2.0 183 Session Progress
    FROM: "My Name"<sip:myname@mydomain.com>;tag=beb6a3cc9a;epid=19697b7f6c
    TO: <sip:+17143147451@mydomain.com;user=phone>;tag=726729a9e1;epid=9B726051AE
    CALL-ID: 1b2a2ead767ed0c7c1091a9e6d3ca392
    VIA: SIP/2.0/TLS;branch=z9hG4bK6696401E.30D8060DAE8D771E;branched=FALSE,SIP/2.0/TLS;ms-received-port=50576;ms-received-cid=900
    RECORD-ROUTE: <sip:LYNC-VM-FRONT.MYDOMAIN.COM:5061;transport=tls;opaque=state:T;lr>;tag=500097C207FD18FDD6F4AD9767A108F7
    CONTACT: <sip:lync-vm-front.mydomain.com@studentvoice.com;gruu;opaque=srvr:MediationServer:BUhn8mwrz1CrqXcVCrORzgAA>;isGateway
    SUPPORTED: replaces
    SUPPORTED: ms-safe-transfer
    SUPPORTED: ms-bypass
    SUPPORTED: gruu-10
    SERVER: RTCC/ MediationServer
    ms-endpoint-location-data: NetworkScope;ms-media-location-type=intranet
    Ms-Accepted-Content-ID: <041d5a5868c50fa6a4e2a2102d43aa69@mydomain.com>
    ------------EndOfOutgoing SipMessage

    There are 3 of those Session Progress messages before I finally get to a SIP/2.0 180 Ringing message at 18:30:28.079, five and a half seconds after the initial INVITE.

    My mediation server is connected directly to my media gateway (Dialogic).  The only network change that I am aware of is the creation of a static VPN on our firewall to a branch office and a new AD Site and Subnet.

    (I will also add that we have a delay when calls our answered by our Response Groups, so I am hoping that problem is related)

    Any help is appreciated,

    Wednesday, March 16, 2011 7:09 PM
  • Just wanted to bump this thread as I have a similar issue.

    I have just deployed a VX1200 in the middle of a CS1K and a Lync server. When outbound calls from the Lync phones are made there is the a delay of up to 3 - 7 blips. At one stage we had calls connecting straight away and ringback was given imediatly. But now there is a delay. Does it really take that long for the SIP signalling to establish the call?


    Monday, May 30, 2011 12:13 AM
  • bump again.

    Same issue, Dialogic 4060 mediation server. When calling Lync to Lync i hear the tone once.

    When calls go through the Dialogic 3-7 beeps before ring.

    Probably is delay through the mediation. Any way to speed that up or at the very least disable the tone.


    Thursday, June 9, 2011 5:29 PM
  • We solved this by changing the IP address in Topology Builder for our A/V Server to be the internally NAT'ed address, not the externall public address.  Even though we are NAT'ing our public to private addresses, we could not get things to work right selecting to Enable NAT under the Edge pool General properties and then using the external IP addresses for each of the External Settings (SIP, Web Conf, and A/V).  For some reason we had 192.168.x.x addresses in for SIP and Web.Conf, but didn't change A/V Service.  Once we set the A/V service to 192.168.x.x, the problem/delay cleared up.

    Hope this helps.


    Thursday, June 9, 2011 5:34 PM
  • Update:  I was able to resolve the outbound delay by removing the edge server from the topology.  Turns out that it was a networking issue that was causing a delay reaching the edge server on calls.  Once the networking issue was resolved the edge server was added back in without causing a delay.
    • Marked as answer by jyoungjr Wednesday, August 10, 2011 1:56 PM
    Wednesday, August 10, 2011 1:56 PM
  • What was the networking issue you found? We're having the same problem; just removed the Edge server from the topology and initially this seems to have worsened the problem... Consistently getting 6 beeps according to users.
    Shawn Welker, MCSE/MCITP Internetwerx, Inc.
    Wednesday, August 10, 2011 8:50 PM
  • This is from Dialogic support, although this was already set on our network so it didn't fix the problem.

    The Lync side should immediately play its local ringback until the real ringback is passed from the network - that being said, you should make sure the DMG is configured to pass the network ringback to the Lync user as soon as possible. This is done via the web interface of the DMG --> VOIP --> MEDIA --> RFC 3960 Early Media Support --> Set to ALWAYS. This will ensure the DMG always send the audio from the network once it becomes available. 

    Shawn Welker, MCSE/MCITP Internetwerx, Inc.
    Thursday, August 11, 2011 1:45 PM
  • Grrrrr....Windows Updates got applied last night....server reboot and now this probelm is back.  Absolutely no network changes.  Anyone else effected by latest batch of updates?
    Thursday, August 11, 2011 11:49 PM
  • Hi, can you tell what your networking issue was? I am having the same issue; however, it is only affecting users that have an IP Phone, not people with Lync Clients on the PCs.
    Monday, February 27, 2012 2:38 PM
  • After reviewing the logs I see where the issue was and how to correct it.

    Even though the call is being made to go out the PSTN it still is negotiating and trying to establish an ICE session with the Edge over its internal interface. UDP Port 3478 and TCP port 443 from the Mediation Servers to the Internal interface of the Edge needed to be allowed on the firewall. The 8 Beeps that were heard were it basically the call attempting to establish the session and eventually giving up.

    Since LYNC Clients require UDP 3478 and TCP 443 for A/V, we went ahead and added in a rule to allow the IP Phone Devices to also connect.

    In the end Call Delay was cut in half. We now get 4 beeps on a phone vs the 8 beeps we were getting. 

    The Lync desktop client on has two Lync rings to call the same external number, so now I will investigate that difference.

    • Proposed as answer by Jeffy-g Tuesday, February 28, 2012 6:40 PM
    Tuesday, February 28, 2012 6:40 PM
  • I'm trying to get a view on what the Lync2010 product is capable of from a performance perspective with regards call setup (time from dialling number to recipients phone ringing) and call connection (time from recipient picking up phone to two way audio established). We're sufferring long delays we are currently experiencing:-

    1. Incoming call setup times of: 8-10s

    2. Incoming call connection times of: 5-7s

    3. Outbound call call setup times of: 10-14s

    4. Outbound call connection times of 1-2s

    We're being led to believe this is normal for Lync which I struggle to accept given I can establish call setup & connection using skype across the public internet in 1-2s.

    Microsoft don't seem (or I havent seen any) published performance figures for Lync outside of Netmos scores which are more quality based once setup and connection are established.

    Can anyone shed some light on this??

    Thursday, March 15, 2012 2:52 PM
  • If others are having issues with ticks during outbound calls instead of hearing ringback this worked for me on a dialogic gateway.  I disabled "Require Reliable Provisional Responses".  Not sure if this is supported in Lync and I am hoping someone could sheld some light on it.   The issue we were seeing was that external users would hear ringback from lync instead of ticks.  If you timed the tics and the ringback they were equally around 5 secs.  The users using lync client externally did not complain since the lync ringback tone gives the illustion of making a call.  The internal users would hear the tics with media bypass enabled.  Not sure why lync does not play ringback in this situation.  Once I disabled "Require Reliable Provisional Responses" on the dialogic gateway I get one somtimes two ticks and get ringback.  This seems normal and acceptable. Hearing 5 or more ticks before hearing ringback was not normal.


    Tuesday, April 3, 2012 2:08 PM
  • What Jeffy-g has said is correct, port 443 (STUN) or optional (3478) need to be open from every Lync Client in the internal network to  internal interface of the edge server.  Please check that this port is open. The beeps are caused when the lync client checks to see if it can communicated to the Edge server (even in you have CAC disabled) and times out (gives up) , hence the 4 or 5 beeps.

    For trouble shooting as jyoungjr suggested, don't delete the Edge server from the topology, that is a bit drastic, just untick the "association edge pool (for media components)" under the FE pool properties and then republish. For settings to take effect straight away, sign out of both Lync Phone and client and sign back in again.

    Tuesday, May 15, 2012 4:37 AM
  • If anyone is still looking for some help with this exact same issue check the link below.


    Wednesday, August 15, 2012 2:14 PM