none
Turn on System Restore (Not how to enable it) via group policy for Windows10

    Question

  • It seems on a clean install of Windows 10 that System restore is turned off by default.  It is enabled, but turned off.  Enabled meaning that I can configure it however I want but Turned Off as in it is not actually creating any restore points.

    I have found many group policy forum postings that document how to enable System restore, but I cannot find anything that actually tells you how to turn it on with that the system so that it actually starts creating system restore point on system changes.

    Any suggestions?

    Thursday, April 21, 2016 5:34 PM

Answers

All replies

  • Hello,

    From your description, I can conclude that your system is not creating restore points automatically, correct me if I am wrong. Try these steps and see if they helps:

    http://www.kapilarya.com/fix-automatic-system-restore-point-creation-disabled-in-windows-8-1

    Hope this helps, Good luck :)

    Windows Troubleshooting & How to guides - http://www.kapilarya.com

    Friday, April 22, 2016 2:08 AM
  • Hi,

    We could try to deploy a task schedule to enable this feature with the following command(.ps1).
    enable-computerrestore -drive "c:\"
    vssadmin resize shadowstorage /on=c: /for=c: /maxsize=5%

    Enable-ComputerRestore

    https://technet.microsoft.com/en-us/library/hh849785.aspx

    How to Enable and Disable System Restore

    https://support.microsoft.com/en-us/kb/264887

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 22, 2016 3:30 AM
    Moderator
  • Thank you.

    After troubleshooting I found the "Enable-ComputerRestore" powershell command and added it to a startup script.   

    Seems strange that this cannot be controlled via  a group policy.

    Friday, April 22, 2016 2:26 PM
  • Hello,

    From your description, I can conclude that your system is not creating restore points automatically, correct me if I am wrong. Try these steps and see if they helps:

    http://www.kapilarya.com/fix-automatic-system-restore-point-creation-disabled-in-windows-8-1

    Hope this helps, Good luck :)

    Windows Troubleshooting & How to guides - http://www.kapilarya.com

    Thank you for the link.  Great information.

    Friday, April 22, 2016 2:28 PM
  • The scheduled task is not present so I cannot follow that procedure.

    Monday, April 25, 2016 4:41 PM
  • Hi,

    Do you mean that the SR task is not present in your environment?

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 26, 2016 9:12 AM
    Moderator
  • Correct. Your highlighted job is not present in my SystemRestore section.

    Wednesday, April 27, 2016 2:12 PM
  • Hi,

    Please open Command Prompt, type “schtasks /query” and press Enter. Is your task listed?

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 28, 2016 2:26 AM
    Moderator
  • Hi,

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 02, 2016 5:27 AM
    Moderator