none
Latest PowerQuery issues with data load to data models built with older version + issue when query is changed RRS feed

  • Question

  • We have a tool built in excel + Powerquery version 2.18.3874.242 - 32 Bit (No PowerPivot) using data load to data model (not to workbook). There are data filters linked to excel cells, inserted in OData query before data is pulled.

    The Excel tool uses organisational credentials to authenticate.

    System config: Win 8.1, Office 2013 (32 bit)

    The tool runs for all users as long as they do not upgrade to PowerQuery_2.20.3945.242 (32-bit).

    Once upgraded users can no longer get the data to load to the Model. Data still loads to the Workbook but the model breaks down. Resetting load to data model erases all measures.

    Here are the exact errors users get:

    1. [DataSource.Error] Cannot parse OData response result. Error: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

    2. The Data Model table could not be refreshed: There isn't enough memory to complete this action. Try using less data or closing other applications. To increase memory available, consider ......

    Thursday, April 2, 2015 1:30 PM

Answers

  • Hi,

    Regarding the OData service in the connection, can you tell if:

    - The version is V4 or V3?

    - Can you capture a fiddler trace of the failed request with HTTPS enabled and attach it?

    - If you are using WebApi, which version are you using?

    Thanks,

    Hadeel

    Monday, April 6, 2015 5:30 PM

All replies

  • Hi,

    Regarding the OData service in the connection, can you tell if:

    - The version is V4 or V3?

    - Can you capture a fiddler trace of the failed request with HTTPS enabled and attach it?

    - If you are using WebApi, which version are you using?

    Thanks,

    Hadeel

    Monday, April 6, 2015 5:30 PM
  • Hi Nitin,

    Is this still an issue? If so, can you kindly provide the details that Hadeel has asked for?


    Regards,

    Michael Amadi

    Please use the 'Mark as answer' link to mark a post that answers your question. If you find a reply helpful, please remember to vote it as helpful :)

    Website: http://www.nimblelearn.com, Twitter: @nimblelearn

    Tuesday, April 21, 2015 10:52 AM
    Moderator
  • I am also having this issue. When refreshing the data this message pops up:

    [DataSource.Error] Cannot parse OData response result. Error: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

    Is this a known error?

    Friday, June 19, 2015 3:16 PM