locked
Error 25109: could not create the configuration data store RRS feed

  • General discussion

  • Ok folks, I know you have seen fixes to this question before but for those of you for whom those have not worked (including me) here goes:

    I have a 4.51 environment in the process of being upgraded to 4.52 (October 2009 binaries).
    We have (2) Management servers going to the same database (which may be different from your installs).
    The database is 2005 64bit running on 64bit Windows 2008.
    The AppV servers are running IIS7 on 64bith Windows 2008.
    All of the servers are physical, the database is separate from the (2) AppV servers.

    Here is what we did to resolve the issue:

    0. Make a database backup of your AppVirt database (better yet, schedule a task for this)
    1. Make sure the management (AppV) services are shut down on any machine other than the one you are upgrading.
    2. Make sure the server group "Default Server Group" is there - does not have to have any servers but it HAS TO BE THERE
    3. Go through the upgrade one server at a time restarting the services on the server to be upgraded, keeping them down on any other server that has been or will later be upgraded.
    4. Any issues, restore your database and start over again at #1

    What we found is that regardless of database permissions, the install group used, using a Domain Admin user account, using an account with or without extended characters, etc. the "Default Server Group" MUST appear in your management console.

    Best of luck,
    gp
    • Edited by gbp3 Thursday, March 4, 2010 2:43 PM Added infrastructure description
    Thursday, March 4, 2010 2:12 PM