locked
Linux Management pack installation RRS feed

  • Question

  • Hi everyone,

    i'm trying to install MP for Linux on SCOM 2012 R2, but i run into this error when importing "Linux Operating System Library" :

    Linux Operating System Library could not be imported.

    If any management packs in the Import list are dependent on this management pack, the installation of the dependent management packs will fail.

    Verification failed with 1 errors:

    -------------------------------------------------------

    Error 1:

    Found error in 1|Microsoft.Linux.Library/31bf3856ad364e35|1.0.0.0

    |Microsoft.Linux.SSH.Discovery.Task/Enumerate|| with message:

    The configuration specified for Module Enumerate is not valid.

    : Schema validation failed.

    The element 'Configuration' has invalid child element 'IgnoreElevation'.

    -------------------------------------------------------


    the package that i'm trying to install is this one: System Center 2012 R2 Management Packs for UNIX and Linux

    https://www.microsoft.com/en-us/download/details.aspx?id=29696

    are there some prerequisites that i'm missing?



    • Edited by Luffy Wallis Wednesday, October 26, 2016 12:59 PM
    Wednesday, October 26, 2016 12:57 PM

Answers

  • Try import MCS Unix Library first before importing Linux Library. It is already imported but just import to update it.

    Works in my case

    Monday, November 14, 2016 6:57 AM

All replies

  • Hi,

    it actually does not have any prerequisites. There are system requirements, but this error is not related to them. 

    Strange behavior found in the comment section of:

    OM12 R2 UR#11 Released

    "Oh, really...


    Linux Operating System Library could not be imported.

    If any management packs in the Import list are dependent on this management pack, the installation of the dependent management packs will fail.

    Verification failed with 1 errors:
    -------------------------------------------------------
    Error 1:
    Found error in 1|Microsoft.Linux.Library/31bf3856ad364e35|1.0.0.0|Microsoft.Linux.SSH.Discovery.Task/Enumerate|| with message:
    The configuration specified for Module Enumerate is not valid.
    : Schema validation failed.
    The element 'Configuration' has invalid child element 'IgnoreElevation'.
    -------------------------------------------------------

    But after second try it`s ok"

    Tommy Gun, the comment afterwards confirms:

    "Same here, worked at 2nd try luckily"

    This might sound a bit lame, but "have you tried a importing it just once" :)

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!)


    Wednesday, October 26, 2016 1:09 PM
  • Yes, i already found this post, but even when trying multiple times to install it, it didn't work...

    I also tried to install an old pack (the one for scom 2007), it was installed but i was unable to discover and install agent on Centos machine...

    Wednesday, October 26, 2016 1:18 PM
  • :( Really hoped that you have missed that and that there is a chance it will work. Sorry, I don't have any more suggestions. Maybe someone, who has fought the issue can comment.

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!)

    Wednesday, October 26, 2016 2:22 PM
  • Try import MCS Unix Library first before importing Linux Library. It is already imported but just import to update it.

    Works in my case

    Monday, November 14, 2016 6:57 AM
  • it worked for me, thanks !
    Wednesday, December 21, 2016 2:36 PM