none
Windows Server 2016 hanging on "Windows Update" Task Sequence Action... RRS feed

  • Question

  • Every time I attempt to run my build and capture task sequence on Windows Server 2016 it just stops on "Downloading" when it hits the "Windows Update" portion of the sequence. Its sat like this for two days now (I've already successfully run build and capture for Windows 10, Windows 7, Server 2012 R2 & Server 2008 R2, so I know it works for all my other OSes). My Build share is not tied to a WSUS so I pull these updates directly from Microsoft Update. Only Server 2016 seems to be affected. I've already re-run it 3x with the same result. Here's a screenshot showing were it hangs up:


    This is an odd one because I have already used this same MDT share to capture multiple Server 2016 images and I have made no recent changes to it so I'm confused as to why this behavior seems to have suddenly started happening. Maybe a bug with "ZTIWindowsUpdate.wsf" and some recent Update for Server 2016?

    Anyone else encountered this and (if so) is there a workaround?

    Thursday, September 28, 2017 2:34 PM

Answers

  • So (Ha Ha) the October round of patches came out last week and this issue has abruptly ceased. Using the exact same task sequence, MDT ran the update actions, the CUs installed in record time and my Build and Capture task sequence completed in under 45 mins. I guess I have to chalk this one up to an issue with the September updates. Frustrating, but at least the issue seems to have fixed itself. 
    • Marked as answer by ZeusABJ Thursday, October 19, 2017 1:58 PM
    • Edited by ZeusABJ Thursday, October 19, 2017 1:59 PM
    Thursday, October 19, 2017 1:58 PM

All replies

  • Weird. I have not seen any issues like this one in the wild. Could you post your ZTIWindowsUpdate and BDD log files? One workaround that comes to mind would be to include the cumulative update in your deployment share and install it as part of the DISM patching process - however, it is a hack and stooping to that kind of troubleshooting hack is beneath my dignity :-)

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".


    Thursday, September 28, 2017 8:45 PM
  • Actually tried including the CU as you suggested, it installed but then just hung up on another update. My ZTIWindowsUpdate.wsf is just the one that's built into MDT 8443  I'm thinking this may be a fluke with the September update. I was hoping someone else had experienced this. I take it the answer is no? Have you tried to capture a  Windows Server 2016 since patch Tuesday of this month?
    Thursday, September 28, 2017 9:10 PM
  • So (Ha Ha) the October round of patches came out last week and this issue has abruptly ceased. Using the exact same task sequence, MDT ran the update actions, the CUs installed in record time and my Build and Capture task sequence completed in under 45 mins. I guess I have to chalk this one up to an issue with the September updates. Frustrating, but at least the issue seems to have fixed itself. 
    • Marked as answer by ZeusABJ Thursday, October 19, 2017 1:58 PM
    • Edited by ZeusABJ Thursday, October 19, 2017 1:59 PM
    Thursday, October 19, 2017 1:58 PM