locked
Notepad is displaying white text on a white background in Windows 7 RRS feed

  • Question

  • I have a new computer (Dell Precision T3500) with Windows 7 Ultimate 64-bit.

    When I open (or create) a text file with Notepad, the text displays as white on white (i.e, it is effectively invisible).

    If I try to select what I typed in the text file, the text still does not display; however, if I open the same text file with another text editor (e.g., Notepad++), the text is visible.

    What is going on, and is there some setting that I should change in order to display text in text files?

    Sunday, November 28, 2010 12:41 AM

All replies

  • Type colors into the Start menu, then choose Change window colors and metrics from the list.

    In the Item box, choose 'Window', and then change the font color to another color.  Click Apply and check for any change in Notepad.  You can continue making adjustments, followed by Apply, to check for desired results.

     

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Sunday, November 28, 2010 2:02 AM
  • Doesn't seem to work: I have tried changing the color to red, and then to some other color, but the result (in Notepad) is the same: invisible text, while if I open the same file with another text editor, the text displays normally.

     

    I'm not really worried about Notepad being unusable (I don't use Notepad as a text editor, anyway), but rather that some setting is out of wack, and might give me some other undesired and unexpected problem.

     

    Tuesday, November 30, 2010 12:56 AM
  • Hmm I'm afraid I'm not sure what else to try. Notepad should be getting the text color value from that setting.  How long ago did you notice the problem, or do you know if it was working before?

    You might try switching to the Windows Classic theme and then back to an Aero theme to see if it makes a difference.

     

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Tuesday, November 30, 2010 1:43 PM
  • I noticed the problem just in the last couple of days, but I've not had occasion to use Notepad before, so who knows how long it has been like this.

    I tried switching to a Classic them, and the problem was still there. back to an Aero theme, and the problem is still there.

    I'm not really worried about not being able to use Notepad, but rather about the possibility that something else (and more serious) might be going wrong.

    One thing I noticed: if in Notepad I go to Format > Font, the "Sample" box doesn't display anything, no matter what font I choose.

    Thursday, December 2, 2010 7:16 AM
  • Try using the System File Checker to scan for missing or corrupt system files.

    http://support.microsoft.com/kb/929833 explains how

     

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Thursday, December 2, 2010 1:55 PM
  • Hi Shawn,

    Thank you for the suggestion, I didn't kno about that scan tool.

    I tried the scan, but the result is "Windows Resource Protection did not find any integrity violations", which I suppose it means that all the files that should be there are installed.

    The issue might in fact have been there from the start... this is a new computer, which I've been using for only a couple of weeks, so it is possible I never had to open a text file with Notepad before noticing the issue the other day.

    Thursday, December 2, 2010 4:36 PM