locked
SMS 2003 Not running .MSI files RRS feed

  • Question

  • I am testing the deployment of RMS.  I have created a package in SMS 2003. On the Program properties I click on the General Tab.  There is the Command Line: option.  I have browsed for my .MSI file and then added my switches after it.  Example:

    msdrmclient.msi /i ALLUSERS=2 REBOOT=R /QN L*V+! "c:\windows\logs\msdrmclient.log"  REINSTALLMODE=omus REINSTALL=ALL

    I deploy this to 1 or 2 test machines and in the Status Messages I see 10005 but it hangs there.  It says it has begun running it but it never will finish and I've waited well over 2 hours.

     

    So, on the Command Line: I've also tried this.

    msiexec.exe /i "\msdrmclient.msi" /i ALLUSERS=2 REBOOT=R /QN L*V+! "c:\windows\logs\msdrmclient.log" REINSTALLMODE=omus REINSTALL=ALL

    this is where I add MSIEXEC.EXE  to the Command Line: option.  This too fails.  It hangs on Status Message 1005 and it never runs the .MSI file.

    What am I doing wrong?


    mqh7
    Thursday, December 23, 2010 6:37 PM

Answers

All replies

  • What happens if you just manually run that same command line?

     

     


    John Marcum | http://myitforum.com/cs2/blogs/jmarcum/|
    Thursday, December 23, 2010 7:05 PM
  • If I run the command manually from the windows XP machine it works, everytime.  but it will not work when run from SMS.

     


    mqh7
    Thursday, December 23, 2010 8:55 PM
  • What happend when you run it using the local system account?

    http://verbalprocessor.com/2007/12/05/running-a-cmd-prompt-as-local-system/


    http://www.enhansoft.com/
    • Proposed as answer by Garth JonesMVP Monday, January 30, 2012 12:42 AM
    • Marked as answer by Garth JonesMVP Monday, December 22, 2014 2:50 AM
    Thursday, December 23, 2010 10:49 PM
  • That is what I'd check, as when you run from SMS, and if you use admin rights, we run under Local System. That's likely the issue. That or some message/dialog box is appearing when you run as a user, that is hidden as local system.
    Wally Mead
    Friday, February 18, 2011 2:13 AM