locked
Remote Desktop Connection Stopped working on my Windows 8 professional Please help me out. RRS feed

  • Question

  • I was connecting to my window server 2012 successfully from a Windows 7 PC. After I upgraded to windows 8 I can no longer connect.

    I have been getting "Remote Desktop Connection Stopped working" error.

    I have seen the same problem described in a post here and Mr Ziegler (@Andre.Ziegler) answered it.

    Following all the recommendations I removed all my printers they and restarted the machine but all effort to no avail.

    I have my dump file here

    http://sdrv.ms/116lsAL

    Can Mr Ziegler (@Andre.Ziegler) or other people help me?

    Thanks in anticipation.


    • Edited by Aphzol Monday, April 15, 2013 10:35 AM
    Monday, April 15, 2013 9:09 AM

All replies

  • Try to disable Bitdefender or add mstsc.exe to the exception list of Bitdefender.

    "A programmer is just a tool which converts caffeine into code"

    Monday, April 15, 2013 6:52 PM
    Answerer
  • I've tried the approach but didn't work still.

    here is a link to the new dump created.

    http://sdrv.ms/17hUsSa

    Thanks

    Tuesday, April 16, 2013 11:06 AM
  • The dump only shows AppVerifier related code.

    Run regedit.exe, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options and delete the key mstsc.exe

    Reboot and wait for a new crash. Upload this new dump.


    "A programmer is just a tool which converts caffeine into code"

    Tuesday, April 16, 2013 6:31 PM
    Answerer
  • I have deleted mtsc.exe entry from the registry as explained above

    here is the link to the new dump file

    http://sdrv.ms/10klbAw

    Thursday, April 18, 2013 12:58 PM
  • I can't see anything useful.

    You get a NX Bit issue:

    STACK_TEXT:  
    00000094`f1e3f718 000007fe`51a073cf : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x0
    00000094`f1e3f720 000007fe`519fe9bf : 00000094`f1590eb0 00000094`f1e3f848 00000094`f1591090 00000000`00000000 : mstscax!CRdpUdpLocalEndpoint::Send+0x10f
    00000094`f1e3f7e0 000007fe`519fe12f : 00000094`f1590eb0 00000094`f15b1030 00000094`f1590eb0 00000094`f15b5440 : mstscax!CRdpUdpTransport::CompleteNetworkWrite+0x2af
    00000094`f1e3f880 000007fe`51c494e7 : 00000094`f15b5440 00000094`f15b5440 00000094`f15b1030 00000000`00000000 : mstscax!CRdpUdpTransport::UdpWorkerThread+0x31f
    00000094`f1e3f940 000007fe`519caba9 : 00000094`ef63f098 00000000`00000000 000007fe`518c0000 00000000`00000000 : mstscax!CTSThread::TSStaticThreadEntry+0x33b
    00000094`f1e3f9d0 000007fe`6612167e : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : mstscax!PAL_System_Win32_ThreadProcWrapper+0x25
    00000094`f1e3fa00 000007fe`6627c3f1 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0x1a
    00000094`f1e3fa30 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x1d
    


    The only thing I see is that you still use the RTM version of the mstscax.dll which is part of Remote Desktop. The latest version is 6.2.9200.16547 which is part of the Windows 8 cumulative update: April 2013

    http://support.microsoft.com/kb/2822241

    Install this update and test it again.

    If you still get crashes, try this. I can also see that this DLL is loaded:

    
        Loaded symbol image file: MSOXMLMF.DLL
        Image path: C:\Program Files\Common Files\Microsoft Shared\OFFICE14\MSOXMLMF.DLL
        Image name: MSOXMLMF.DLL
        Timestamp:        Sun Jan 10 09:30:02 2010 (4B49900A)
        CheckSum:         0000FF8C
        ImageSize:        00011000
        File version:     14.0.4730.1010
        Product version:  14.0.4730.0
        File flags:       0 (Mask 3F)
        File OS:          40004 NT Win32
        File type:        2.0 Dll
        File date:        00000000.00000000
    
    unregister the dll with regsvr32.exe /u and see if this helps.

    "A programmer is just a tool which converts caffeine into code"

    • Marked as answer by Niki Han Thursday, April 25, 2013 5:22 AM
    • Unmarked as answer by Aphzol Saturday, April 27, 2013 6:20 AM
    Thursday, April 18, 2013 7:31 PM
    Answerer
  • Its been quite a while

    Mr Andre.Ziegler I tried the method above it didnt work for me.

    Also I was unable to unregister MSOXMLMF.DLL I got the following error: the module "C:\Program Files\Common Files\Microsoft Shared\OFFICE14\MSOXMLMF.DLL" was loaded but call to DllUnregisterServer failed with error code0x8000ffff

    URL to my new dump is  http://sdrv.ms/1839hLP.

    Thanks

    Saturday, April 27, 2013 6:56 AM
  • the dump doesn't show anything new. YOu still get a NX issue. You can try to exclude the mstsc.exe from DEP (Data Execution Prevention):

    http://maximumpcguides.com/windows-7/exclude-a-program-or-service-from-dep-protection-in-windows-7/

    Maybe this helps.


    "A programmer is just a tool which converts caffeine into code"

    Saturday, April 27, 2013 1:29 PM
    Answerer
  • I tried excluding mstsc.exe from DEP but I got the following error "Data Execution prevention is not allowed for X64 files"
    Saturday, April 27, 2013 6:15 PM
  • try it for the 32Bit version of  mstsc.exe ("C:\Windows\SysWOW64\mstsc.exe")  and use this 32Bit version.

    "A programmer is just a tool which converts caffeine into code"

    Sunday, April 28, 2013 7:30 AM
    Answerer