none
ConfigMgr 2012 Capture media does not run RRS feed

  • Question

  • I am experiencing an issue in more than one customer environments (so far) and in my own VM environment (which is now running the full release version of ConfigMgr 2012), capture media when ran within a functional OS doesn't give me a wizard.   I thought this might just have been an RC1 issue, but this is also now a problem for me with the full release.  I find the TSMBAutorun.log in the %temp% folder and notice it is saying the following;

    --

    TSMBAutoRun started

    Unknown system architecture 0

    failed to run TSMBootstrap

    --

    The running OS is a fully patched Windows 7 Enterprise SP1 32-bit, but have also tried capturing from a 64bit Windows 7 Enterprise SP1 as well. I have tried burning the capture iso to a cdrom and extracting to the root of a USB key. Also tried generating directly to a USB key and the result is the same.  I have tried adding a dummy SYSPREP folder onto C:.  I'm trying to run as regular and elevated user and as administrator.  I have tried regenerating the boot images and capture media iso file.  A fully automated build and capture task sequence works fine, but I prefer to perform a manual capture using capture media.

    I've done this many, many times before with ConfigMgr 2007 capture media so I'm no noob to this process.

    Any ideas? What is TSMBootstrap actually looking for and why does it not recognise the system architecture.

    Andy

    Thursday, April 26, 2012 6:18 PM

Answers

  • OK, I have a little more information now and I think I've figured it out.

    The capture media seems to work fine on Windows 7 installations where Autoplay is enabled and the media can launch TSMBAutorun.exe automatically.  However, if you have to launch TSMBAutorun.exe by navigating to the SMS\bin\i386 folder (for instance if autoplay isn't working or you extract create/extract to a USB key), then the wizard does not launch.  This seems to be because when you use explorer to run TSMBAutorun.exe the current working directory becomes SMS/bin/i386 and TSMBAutorun.exe expects to find TSMBootstrap.exe in <currentworkingdir>\sms\bin\x64 (or x86) - which would resolve, as John as found, to an invalid path of D:\SMS\BIN\i386\SMS\BIN\x64\TSMBootstrap.exe.

    On newly built systems using MDT2012, I think the Apply GPO Pack step applies a default Windows 7 SP1 local policy that disables autorun - therefore we encounter the issue trying to use the capture media.  Simply running gpedit.msc and cancelling the 'Turn off Autoplay' option in 'Computer Configuration/Administrative Templates/Windows Components/AutoPlay Policies' allows the Capture media wizard to run via autoplay.

    If you do leave Autoplay turned off, you can workaround the issue simply by opening a command prompt at the root of the capture media drive and running sms\bin\i386\tsmbautorun.exe.

    Needless to say, I've now disabled the MDT 2012 Task Sequence step for Applying GPO packs during build.

    Andy

    Friday, April 27, 2012 3:56 PM

All replies

  • can you please confirm that you are following all the steps listed below ?

    How can I capture an image using Capture Media in Configuration Manager 2012 ?
    Capturing an image using capture media [February 21st, 2012]



    Step by Step ConfigMgr 2007 Guides | Step by Step ConfigMgr 2012 Guides | I'm on Twitter > ncbrady

    Friday, April 27, 2012 6:39 AM
    Moderator
  • Similar results here Andy. I have created TS Capture Media, but when executed from a Windows 7 Ent SP1 Hyper-V virtual machine I get a just two lines in the TSMBAutorun.log:

    TSMBAutoRun started
    failed to run TSMBootstrap

    I've used procmon to monitor the process initiation. Procmon shows TSMBAutorun attempting to create a process for TSMBootstrap, but this process is being created from:

    D:\SMS\BIN\i386\SMS\BIN\x64\TSMBootstrap.exe

    This path does not exist of course. If I create this path and add the TSMBootstrap.exe file (either x64 or x86 version) TSMBootstrap is then invoked, but throws an exception.

    Something not quite right with this...

    Niall, I've checked the walkthrough you provided and can't see anything different with my setup. We've tried this on a few different environments now...


    Friday, April 27, 2012 8:12 AM
  • Niall, I can confirm my steps are the same as your steps - albeit up to the point I don't get the "Welcome to..." wizard.  I'm glad it is not just me.
    Friday, April 27, 2012 8:28 AM
  • guys I did this in a hyperV environment, what about you ? any errors in event viewer on your virtual machines ?


    Step by Step ConfigMgr 2007 Guides | Step by Step ConfigMgr 2012 Guides | I'm on Twitter > ncbrady

    Friday, April 27, 2012 2:31 PM
    Moderator
  • This sounds like a bug to me -- I remember seeing it during the RC but chalked it up to my virtual environment. You should open a case with CSS -- if it is confirmed to be a bug, there will be no charge for the call (to my knowledge).

    Jason | http://blog.configmgrftw.com | Twitter @JasonSandys

    Friday, April 27, 2012 3:04 PM
  • OK, I have a little more information now and I think I've figured it out.

    The capture media seems to work fine on Windows 7 installations where Autoplay is enabled and the media can launch TSMBAutorun.exe automatically.  However, if you have to launch TSMBAutorun.exe by navigating to the SMS\bin\i386 folder (for instance if autoplay isn't working or you extract create/extract to a USB key), then the wizard does not launch.  This seems to be because when you use explorer to run TSMBAutorun.exe the current working directory becomes SMS/bin/i386 and TSMBAutorun.exe expects to find TSMBootstrap.exe in <currentworkingdir>\sms\bin\x64 (or x86) - which would resolve, as John as found, to an invalid path of D:\SMS\BIN\i386\SMS\BIN\x64\TSMBootstrap.exe.

    On newly built systems using MDT2012, I think the Apply GPO Pack step applies a default Windows 7 SP1 local policy that disables autorun - therefore we encounter the issue trying to use the capture media.  Simply running gpedit.msc and cancelling the 'Turn off Autoplay' option in 'Computer Configuration/Administrative Templates/Windows Components/AutoPlay Policies' allows the Capture media wizard to run via autoplay.

    If you do leave Autoplay turned off, you can workaround the issue simply by opening a command prompt at the root of the capture media drive and running sms\bin\i386\tsmbautorun.exe.

    Needless to say, I've now disabled the MDT 2012 Task Sequence step for Applying GPO packs during build.

    Andy

    Friday, April 27, 2012 3:56 PM
  • good info Andrew, i'll update my blog to reflect this finding.

    cheers

    niall



    Step by Step ConfigMgr 2007 Guides | Step by Step ConfigMgr 2012 Guides | I'm on Twitter > ncbrady

    Friday, April 27, 2012 8:06 PM
    Moderator
  • Hello all. Or you can leave every thing in place in your task sequence and just modify the usb or ISO boot media (if you have daemon tools).

    Here are the steps:

    1 - Create Capture boot media in SCCM 2012 RTM

    2 - After boot media is created browse to this directory <working drive>\SMS\bin\i386

    3 - Create a directory called SMS

    4 - double click this directory and create a directory called "bin"

    5 - double click this directory and create a directory called x64. When you are done your path should look like this: <working drive>\SMS\bin\i386\SMS\bin\X64

    6 - Now navigate back to the <working drive>\SMS\bin\x64 directory and copy ALL of the contents to the \SMS\bin\i386\SMS\bin\X64 directory

    That's it!! Now you can run the TSMBAutorun.exe file from explorer, cmd, etc successfully.

    The reason this works is because now the windows environment has a defined path for the reasons explained above. Now you don't have to circumvent security features like "disabling the GPO Pack" task sequence step.

    I validated this fix after reading this post:  http://jackychuasce.blogspot.com/2012/05/why-click-on-tsmbautorunexe-cannot.html

    Thank you Jacky!!


    JV

    Wednesday, May 23, 2012 6:02 PM
  • Hello all. Or you can leave every thing in place in your task sequence and just modify the usb or ISO boot media (if you have daemon tools).

    Here are the steps:

    1 - Create Capture boot media in SCCM 2012 RTM

    2 - After boot media is created browse to this directory <working drive>\SMS\bin\i386

    3 - Create a directory called SMS

    4 - double click this directory and create a directory called "bin"

    5 - double click this directory and create a directory called x64. When you are done your path should look like this: <working drive>\SMS\bin\i386\SMS\bin\X64

    6 - Now navigate back to the <working drive>\SMS\bin\x64 directory and copy ALL of the contents to the \SMS\bin\i386\SMS\bin\X64 directory

    That's it!! Now you can run the TSMBAutorun.exe file from explorer, cmd, etc successfully.

    The reason this works is because now the windows environment has a defined path for the reasons explained above. Now you don't have to circumvent security features like "disabling the GPO Pack" task sequence step.

    I validated this fix after reading this post:  http://jackychuasce.blogspot.com/2012/05/why-click-on-tsmbautorunexe-cannot.html

    Thank you Jacky!!


    JV


    You know, as I was reading through here I thought the short-term fix or workaround was to just prepare the path to what it expects! At least until the fix arrives.
    Friday, November 2, 2012 1:20 PM
  • I figured out that if you run it from a Command line

    CMD.EXE

    C:\>D:

    D:\>\SMS\bin\i386\tsmbautorun.exe

    that will work

    Happy hunting

    Thursday, January 3, 2013 10:31 PM
  • Still doesn't work for me :(

    Been going on for a while now, keep getting the error unknown system architecture

    Thursday, April 24, 2014 4:01 AM
  • The Solution is so Simple :

    Just Install an ISO Mounter , Like : Power ISO,

    then Mount Your ISO File into a Virtual Drive, then Run TSMBAutorun .

    It Works.....

    Best Wishes,Ali Ghaderi.

    • Proposed as answer by AliGR Sunday, October 25, 2015 8:38 AM
    Sunday, October 25, 2015 8:36 AM
  • That was all!!!

    Thank's!

    Thursday, October 29, 2015 11:16 PM
  • Hi 

    We have the same problem and resolved by burn the ISO image to a CD and run the launch media from the CD.

    Thanks 

    Guru

    Friday, April 21, 2017 6:56 AM
  • The reason it works for some and not others most likely depends on OS being 32bit or 64bit.

    The working directory needs to be either SMS\bin\i386\ or SMS\bin\x64

    Here is the simplest solution of all.

    1. Open CMD as admin.

    2. For 64bit OS Change Directory to D:\SMS\bin\x64 (Where D: is capture media drive).

          2a. For 32bit OS Change Directory to D:\SMS\bin\i386 (Where D: is capture media drive).

    3. Now enter full path D:\SMS\bin\i386\TSMBAutoRun.exe and hit enter (for 32bit OS just type TSMBAutoRun.exe).

    Tuesday, September 5, 2017 11:05 PM