locked
Parser Error Message: Unrecognized configuration section 'system.webServer' RRS feed

  • Question

  • at the time of rum show Error 

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

    Parser Error Message: Unrecognized configuration section 'system.webServer'

    Source Error: 


    Line 34:     </httpModules>
    Line 35:   </system.web>
    Line 36:   <system.webServer>
    Line 37:     <validation validateIntegratedModeConfiguration="false"/>
    Line 38:     <modules>

    Source File: c:\inetpub\wwwroot\ACS-Driver\web.config    Line: 36 

    Version Information: Microsoft .NET Framework Version:1.1.4322.2379; ASP.NET Version:1.1.4322.2379


    • Edited by Vikram Das Monday, May 19, 2014 3:07 PM
    • Changed type Vikram Das Monday, May 19, 2014 3:12 PM
    • Changed type Vikram Das Monday, May 19, 2014 3:12 PM
    • Moved by Fred Bao Tuesday, May 27, 2014 8:34 AM
    Monday, May 19, 2014 3:06 PM

All replies

  • Please check out "Step 4: Add IgnoreSection Handler to v1.1 machine.config" in the following tutorial to find out how to get rid of this error: http://www.iis.net/learn/install/installing-iis-7/how-to-install-aspnet-11-with-iis-on-vista-and-windows-2008. You need to make some modifications to the machine.config file.

    • Marked as answer by Vikram Das Monday, May 19, 2014 3:59 PM
    • Unmarked as answer by Vikram Das Monday, May 19, 2014 7:04 PM
    Monday, May 19, 2014 3:43 PM
  • my server :

    os windown server 2003

    iis 6.0


    • Edited by Vikram Das Monday, May 19, 2014 3:58 PM
    Monday, May 19, 2014 3:55 PM
  •                                     

    If you are using IIS 6, you can remove the <system.webServer> node altogether. The modules should be configured in <system.web>-><httpModules>:

    <system.web>
        <httpModules>
          <add name="..." type="..." />
        </httpModules>
       </system.web>

    Please post the entire web.config for further help or, even better, post your questions regarding ASP.NET and IIS here: http://forums.asp.net.

    Monday, May 19, 2014 8:05 PM