none
MDT 2013 Update 1 - Bootstrap.ini keyboardlocale RRS feed

  • Question

  • I have a problem with my bootstrap.ini file not setting the keyboard locale correctly on LiteTouch deployments.  I have the following in my bootstrap.ini.  From looking at the logs the deployroot and keyboardlocale values are set based on the default gateway however the actual text input on the MDT share login screen is always US.

    [Settings]
    Priority=DefaultGateway,Default
    
    [DefaultGateway]
    10.0.10.1=SITEA
    10.0.50.1=SITEB
    10.0.100.1=SITEC
    
    [SITEA]
    DeployRoot=\\SERVER\deploymentshare$
    KeyboardLocale=0809:00000809
    
    [SITEA]
    DeployRoot=\\SERVER\deploymentshare$
    KeyboardLocale=0809:00000809
    
    [SITEC]
    DeployRoot=\\SERVER\deploymentshare$
    KeyboardLocale=0409:00000409
    
    [Default]
    SkipBDDWelcome=YES
    UserDomain=domainname

    I have done the following tests

    1. Removed keyboardlocale from SITEC = keyboard layout US

    2. Added UK keyboardlocale to Default = keyboard layout UK

    Is there a bug in this version where keyboardlocale only works in the Default section?

    Tuesday, December 22, 2015 2:50 PM

Answers

  • Do you want to change the beyboard language in Windows PE phase or for the installed Operating System?

    If the first one:
    Use KeyboardLocalePE

    If the latter one:
    Why are you doing this in bootstrap.ini instead of customsettings.ini?
    (According to the documentation both should work, but I would never place settings into bootstrap.ini which aren't actually required there - It causes you to update and reimport the boot image after any change)


    • Edited by oriooff Tuesday, December 22, 2015 4:12 PM
    • Proposed as answer by oriooff Tuesday, December 22, 2015 5:10 PM
    • Marked as answer by Ty GlanderModerator Tuesday, December 22, 2015 11:13 PM
    Tuesday, December 22, 2015 4:11 PM

All replies

  • Do you want to change the beyboard language in Windows PE phase or for the installed Operating System?

    If the first one:
    Use KeyboardLocalePE

    If the latter one:
    Why are you doing this in bootstrap.ini instead of customsettings.ini?
    (According to the documentation both should work, but I would never place settings into bootstrap.ini which aren't actually required there - It causes you to update and reimport the boot image after any change)


    • Edited by oriooff Tuesday, December 22, 2015 4:12 PM
    • Proposed as answer by oriooff Tuesday, December 22, 2015 5:10 PM
    • Marked as answer by Ty GlanderModerator Tuesday, December 22, 2015 11:13 PM
    Tuesday, December 22, 2015 4:11 PM
  • I have keyboardlocale in the customsettings.ini and that works just fine.  My issue is WinPE so i suspect KeyboardLocalePE would work so i will try that now

    Thanks

    Tuesday, December 22, 2015 5:07 PM