locked
Replication Link Analyzer - constantly queued messages, replication link failed RRS feed

  • Question

  • Good day, another problem to solve.

    I have Primary Site on one PC, SQL Cluster on other PC which contains DB of Primary Site, Secondary Site with SQL Express in one box.

    So for now, it is during for two days "Momitoring\Database Replication" is showing me "Link Failed". If i ran Replication Link Analyser it shows me "Replication Link Analyzer recommends resetting queued messages on SQL Cluster for Secondary Site". I am pressing reset queued messages for many times but the error still the same it is not disappears. If i look in xml report of link analyzer i could the the next messages

    Messages found in the transmission queue for target service ConfigMgrRCM_SiteT01 with enqueue time 02.08.2012 2:42:07 greater than 30 mins ago. Messages found in the transmission queue for target service ConfigMgrDRS_SiteT01 with enqueue time 02.08.2012 2:43:24 greater than 30 mins ago

    If i skip this rule, on the next screen i see:

    So tell me please how can i solve this problem?

    rmctrl.log show no errors it seems to me. sender.log also shows no errors.


    Moto

    Thursday, August 2, 2012 3:42 AM

All replies

  • and forget to say that distribution of packages to the secondary site is going normally, distribution status is "success"

    So i`ve cleaned up queued messages in SQL:

    DECLARE item_cursor CURSOR LOCAL FAST_FORWARD FOR
        SELECT conversation_handle FROM cm_p01.sys.transmission_queue
    OPEN item_cursor
    DECLARE @conversation UNIQUEIDENTIFIER
    FETCH NEXT FROM item_cursor INTO @conversation
    WHILE @@FETCH_STATUS = 0 
    BEGIN
     PRINT 'Closing conversation: ' + CAST(@conversation AS VARCHAR(50)) 
        END CONVERSATION @conversation WITH CLEANUP
        FETCH NEXT FROM item_cursor INTO @conversation
    END

    there is no more errors about queued messages for now, but i see the same error like on the screenshot again.

    Here is the text of xml file:

    - <RuleRemediationSteps>

    - <RuleRemediationStep Name="CallForFailedLinksIssues">

    <Parameter Index="0" Value="P01" />

    <Parameter Index="1" Value="T01" />

    <Parameter Index="2" Value="[global_proxy,P01,T01,Secondary_Site_Replication_Configuration], [global_proxy,P01,T01,Secondary Site Data], [global_proxy,T01,P01,Secondary_Site_Replication_Configuration], [global_proxy,T01,P01,Secondary Site Data]," />

    </RuleRemediationStep>

    </RuleRemediationSteps>


    Moto

    • Edited by aaamoto Thursday, August 2, 2012 4:15 AM
    Thursday, August 2, 2012 3:44 AM
  • These are the steps I would recommend you to follow ...

    More Details - http://blogs.msdn.com/b/minfangl/archive/2012/05/16/tips-for-troubleshooting-sc-2012-configuration-manager-data-replication-service-drs.aspx

    1. Use Replication Link Analyzer.
    2. Check out the Log files – rcmctrl.log, replmgr.log.
    3. Check SQL and Run script spDiagDRS to get more information.
    4. Troubleshoot the SQL Service Broker.
    5. Reinitiate the site data by sending subscription invalid message.


    Anoop C Nair - @anoopmannur :: MY Site:  www.AnoopCNair.com :: FaceBook:  ConfigMgr(SCCM) Page :: Linkedin:  Linkedin<

    Thursday, August 2, 2012 6:40 AM
  • Anoop, thank you for your answer.

    I`ve deleted the Secondary Site and reinstalled it. Everything works fine - Link Active.

    You troubleshooting link is very helpfull, thank you.


    Moto


    • Edited by aaamoto Thursday, August 9, 2012 11:22 AM
    Thursday, August 9, 2012 11:22 AM