locked
Outlook 2010: saving mails at a network location / remember last location RRS feed

  • Question

  • In Outlook 2003, after an email or attachment was saved to a location, the system will remember the last location, no matter local drive or network drive.

     

    But in Outlook 2010, this only works for local drive. Everytime after I saved a email to a location in network drive and tried to save another email again, it will go to Libraries\Documents instead of the last saved location.

     

    Anyone has any ideas?

    Monday, February 28, 2011 1:09 AM

Answers

  • I’m so happy because I finally found the solution for my user, one method much simpler to save his email on the same location and on the location that he want.

     

    Let me show you step by step:

     

    To select the several email(s) you want to save, hold down the <<Ctrl>> key, and then select them one by one, use <<Ctrl C>> to copy them.
     Then you can directly use <<Ctrl V>> to past (or save) them on the network location or on your local pc.
    Have a great day.
    • Marked as answer by Jennifer Zhan Friday, March 11, 2011 7:46 AM
    Monday, March 7, 2011 11:19 AM

All replies

  • Hi,

     

    We can change the default save as folder by the steps below:

     

    1.       In Windows XP, click Start, and click Run. In the Open box, type regedit, and then click OK.

    In Windows Vista/Windows 7, click Start, in the Search box, type regedit and press Enter.

    2.       Locate the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    3.       Double-click Personal in the right pane.

    4.       Change the value to the path you want. For example:
    C:\My Attachments, would set the location to the My Attachments folder.
    %USERPROFILE%\My Documents, would set it to the My Documents folder on a computer that had more than one user profile.

    5.       On the Registry menu, click Exit.

    6.       Restart Outlook.

      

    For more information, you can refer to this KB article:

    How to set the default attachment folder in Outlook

    http://support.microsoft.com/kb/252732

    Hope that helps.

    Tuesday, March 1, 2011 7:42 AM
  • Actuallly I don't want to change the default save as folder.

     

    When I have several emails about same issue and want to save them into same folder, for each email I need to browser to the same location from Libraries\Documents . It's very annoying.

     

    In old version of outlook when you saved one email and tried to save another it just jumped to the same folder just saved, it's very convenient.

    Wednesday, March 2, 2011 1:00 AM
  • Hi,

    I have a user who has the same problem as you.

    "I have to save very many e-mails in outlook. In the previous version, I klicked on “File” “Save as” and saved my e-mail. When I wanted to save the next e-mail, Outlook remembered where I saved last time and automatically opened the respective directory.

     

    The new Outlook doesn’t do this. I have to start right at the beginning every time. Is there a possibility to have it like in the older version?

     

    Thank you so much for your help!"

    Many thanks

    Wednesday, March 2, 2011 11:51 AM
  • I’m so happy because I finally found the solution for my user, one method much simpler to save his email on the same location and on the location that he want.

     

    Let me show you step by step:

     

    To select the several email(s) you want to save, hold down the <<Ctrl>> key, and then select them one by one, use <<Ctrl C>> to copy them.
     Then you can directly use <<Ctrl V>> to past (or save) them on the network location or on your local pc.
    Have a great day.
    • Marked as answer by Jennifer Zhan Friday, March 11, 2011 7:46 AM
    Monday, March 7, 2011 11:19 AM
  • I have made this change and cannot get Outlook/Office to operate the way I'd like.  If I have an Office file as an attachment to my email, I can right click on the attachment and select 'save as', and it will default to the network drive I have set.  However, when I open the office attachment, then attempt a 'save as', it will default to \Libaries\documents.

    I have modified the default save location for the various office applications to the same network location, and if I am working directly in those applications, the save/save as function works as it should, defaulting to that network location, it just won't direct to that location if I open the office file from an email. 

    I am running Windows 7 Enterprise with Office 2010.  We cannot seem to get this to work on any combination of OS/Office we run in our environment, which would be XP Pro/Windows 7 Enterprise, or Office 2007/2010. 

    I can get it to work if I modify a different key under the registry hive mentioned above, however this is not a desired configuration:

     HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    Local AppData 

    Thanks.

    Wednesday, March 23, 2011 8:23 PM
  • Any update on this issue ?

    Modify the default folder and save several e-mails at once is not the sollution.

    The convenient "Remember last folder used" option is just missing from Outlook 2010 ?

    I would like to give a final anwer for my users.

    Monday, April 25, 2011 1:02 PM
  • My peers are having the exact same issue and neither of the solutions presented are the correct answer. We need the "Remember Last Saved Folder", this made a certain duty that is done daily easy, but in the 2010 office it is painstaking.  Instead of saving email and navigating to a numbered saved account folder for thousands of shops clicking save then >shift+ left click to highlight all pictures and attachments of said email > right clicking and hitting save as, and it defaults to the last folder made or saved to.  Awesome.

     

    Now in 2010 it defaults back to a default path every time, this can take another minute to navigate to the folder again.  1 minute times 80 or so emails adds another 80 minutes of wasted work time.  This is counter productive for Office, things that are good should stay and the bad should be improved or discarded in a widely used program like Office. No? 

     

    Monday, June 20, 2011 9:12 PM
  • I agree, none of these answers are the solution.  This is a problem throughout Windows 7 and Office 2010.  I routinely save many files in the same (or similar) location during a given time period.  Having to start from the root directory each time and navigate down to the desired folder is a royal pain in the ass. 

    While setting the default path in the registry may be a work-around, manually editing the registry can't possibly a legitimate solution.  There is no way anyone with an IQ greater than rock would claim this was by design.  Yet, I've heard MS engineers on these blogs and lists make this very claim.

    WTF is wrong with Microsoft?!?! Did they fire all their Human/Computer interface designers?

    • Proposed as answer by mendely Sunday, December 1, 2013 11:17 AM
    Friday, July 1, 2011 2:02 PM
  • Neither of those "solutions" fix this problem. They are merely work arounds which probably wont work as this functionality existed in previous versions of outlook.

     

     

    I have also observed that this problem does not always occur. For instance, it does not occur on my personal outlook 2010. My outlook will usually remember the last folder which an item was saved to. However I have one user who occasionally, and i have witnessed it, saves a file, but then the next file, instead of going to the last saved locaiton, defaults back to the library folder.

     

    Havent found a solution yet. More buggy 2010 stuff id imagine, since sometimes this user can save things fine.

    Tuesday, July 5, 2011 11:30 PM
  • Best workaround I found (Win 7 only) : in the right-hand pane, underneath Favorites, is a link for Recent Places. Clicking into there should save some time, as its a collection of recently opened or "saved to" locations
    Thursday, February 9, 2012 7:40 PM
  • The workaround for WinXP is similar - add the location to the places bar.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Friday, February 10, 2012 12:24 AM
  • I completely agree with this--this is a nuisance throughout Win7/IE9/Office2010. I just recently switched to Windows 7 and file manipulation is significantly less efficient than it was in Windows XP. I cannot get Save As dialog boxes to retain the setting "list view" and subsequent saves do not remember the last used location. Seriously, what brain dead engineer decided on that set of features? The answer that "this is a better design" doesn't cut it when you have numerous power users across multiple message boards complaining about the same thing. These are not complaints becuase of change--these are complaints because this design introduces additional time into repetitive activities.
    Saturday, March 17, 2012 8:57 PM
  • I have a user with this problem too, it's weird because with my Outlook 2010 it remembers the last folder location even on networks folders, but not for him.

    Any of these workaround is useless for me, I need a real fix to this.

    Many thanks 

    Thursday, August 30, 2012 8:06 AM
  • Nothing in this debate so far is an answer to the problem. The functionality is there. I know, because it works for me. However, a client of mine has the exact problem above. It remembers the last drive if it was local, but not if it was on a network drive.

    Given that I do not use the same server as my client (and mine works fine) and his problem occurs only on network drives, surely this points to either a network issue or a server side issue?

    It would be nice for someone to post a solution to the problem rather than suggest a cheap workaround!

    Monday, September 17, 2012 3:41 PM
  • Same problem here using Outlook 2010 v14.0.6123.5001 32bit on Win7 Pro 64bit:

    • On computer A it doesn't matter if a save to a local or a network folder, the last folder is always offered if i open "save as" again.
    • On computer B the last folder is only remembered if it was a local folder. If it was a network folder I'll be redirected to the documents library.

    I already recreated the user profile and/or outlook profile but the problem is still there...

    Thanks

    Daniel

    Thursday, September 20, 2012 2:55 PM
  • Make sure your Office is completely updated. We had to install sp1 and run the office updates from microsoft's website. Took us 2 days to figure this out.
    Tuesday, February 12, 2013 6:20 PM
  • Make sure your Office is completely updated. We had to install sp1 and run the office updates from microsoft's website. Took us 2 days to figure this out.
    Tuesday, February 12, 2013 6:21 PM
  • I agree with everything said here about Microsoft.
    Along with this, I always try to find a practical solution, which is what I found:
    You can make a shortcut to your shared folder from the server, Fifth Level Folders tree, etc.
    Inside the default 'save as' \ Libaries \ documents.
    It is true that now you have two mouse clicks to get to, but hey, let's not be petty ...

    Ofer

    Sunday, December 1, 2013 1:02 PM