none
Microsoft Hosted Network Virtual Adapter Only Forwards The Fastest DNS Response Even If It's A "Refused." RRS feed

  • Question

  • My OS is Windows 8.1 Update 1. However, I find the problem exists since Windows 8 at least.

    My laptop computer has a WiFi card, which supports Microsoft Hosted Network Virtual Adapter, so it can act like a wireless access point (AP). These are the commands I used to start my "wireless AP, " myAp:
    netsh wlan set hostednetwork mode=allow ssid=myAp key=myPasswd
    netsh wlan start hostednetwork

    My laptop computer connects to the Internet through the ethernet interface, lan1. lan1 shares the Internet access with myAp through Windows Internet Connection Sharing (ICS), and then myAp has an IP 192.168.137.1. Finally, my Windows Phone, hTC 8X, connects to myAp for accessing the Internet.

    Everything worked well for the above settings until one day ... On one day, I found my Windows Phone couldn't open any websites. Later, I found it could connect to websites through IPs instead of DNS names. So the problem was reduced to the failure of the DNS query. I used Wireshark on my laptop computer to capture packets on lan1 and I found the problem:
    1. My phone sends a DNS query for a website to the DNS server/gateway, myAp.
    2. myAp forwards the query to lan1.
    3. lan1 sends multiple DNS queries simultaneously to multiple DNS servers.
    4. The fastest one DNS server answers a "query refused," however, the other slower DNS servers could answer the correct results.
    5. Even if those slower DNS servers answer correct results, myAp only forwarded the fastest result to my phone. So the DNS query result to my Windows Phone was "refused."

    Why do I know the query is refused? Because I used another laptop connected to myAp, and I used nslookup to test the DNS query. For example:
    nslookup ptt.cc 192.168.137.1
    where the IP 192.168.137.1 is of myAp. (myAp acts like a DNS server and a gateway for associated wireless user devices.)

    The DNS server refused lan1 has the IP 140.115.192.11. That DNS server had been public for some time, however, recently, it went to private and only served computers in the subnet 140.115.0.0/16. So it answers "refused" for computers out of the subnet.

    I think this is a bug that Microsoft Hosted Network Virtual Adapter only forwards the fastest DNS response. Please Microsoft fix this bug, because my Windows Phone 8 acquires the DNS servers through DHCP through myAp and can't manually change the DNS servers. If you use a Windows 8 laptop computer (connecting to myAp), you have a chance to manually change the DNS servers to specific and valid ones. But using Windows Phone 8 is impossible at this time.



    Thursday, April 10, 2014 4:07 AM

All replies

  • Actually, I have a workaround for this problem, however, I hope Microsoft still can solve this bug.

    The workaround is, for my example, set a firewall rule to block DNS packet to the invalid DNS server 140.115.192.11. However, this workaround doesn't solve the problem at its root. If, some day, another DNS server you use becomes invalid and you find your Windows Phone can't open a website again, then you have to analyze packets by Wireshark and set firewall rules again...

    Thursday, April 10, 2014 4:25 AM
  • I was also having the same problem and I tried many things. None worked. Ultimately, I manually entered DNS of my ISP in the client devices (Nokia N8 and ipod touch) and everything was back again. Hope this works for others also who are facing the same problem.

    Regards

    Ashok Trehan

    • Proposed as answer by Trehan1 Thursday, July 17, 2014 10:00 AM
    • Unproposed as answer by Meng-Yuan Huang Thursday, July 17, 2014 12:21 PM
    Thursday, July 17, 2014 9:59 AM
  • Trehan1,

    Sorry, I don't mark your reply as answer, because I have proposed "changing DNS in the client device" as a workaround in my first post.

    However, thank you for your post that you had met the same DNS problem.


    Thursday, July 17, 2014 12:21 PM
  • I do agree it is a work around only and Microsoft need to rectify this bug.

    In my case it was working perfectly well till I changed the pci slot of my wifi adapter. It all started happening after that. I again shifted the card to the original slot but to no avail.

    I must confess, however, that I am not a computer expert and I don't have an iota of technical know-how. At best, I can be called an advanced user.

    Please keep me in loop as and when a solution is found and Microsoft rectifies the bug.

    Regards

    Trehan

    Thursday, July 17, 2014 2:35 PM