none
User Profile Synchronization Service stuck on starting Sharepoint 2013 SP1 with SQL 2014

    Question

  • Hi All,

             We have installed our Sharepoint 2013 SP1 in our Windows server 2012 R2 and SQL 2014, Everything was installed successfully, While configured the User Profile Synchronization Service, we could not able to start it.

    We have also installed April CU update but still not start the service. Please help.


    Manikandan

    Friday, March 31, 2017 12:03 PM

All replies

  • The first place to start for this is always Spence Harbar's article on the User Profile Synchronization service.  I would particularly focus on checking the permissions in AD for the accounts used.

    http://www.harbar.net/articles/sp2010ups2.aspx

    Just ignore that it says 2010.  The issues are the same for 2013.


    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Friday, March 31, 2017 12:29 PM
  • Spence article should save your time, worth looking into it. Especially permissions for your user profile account, it needs "replicating directory changes" although you may not need to write back to AD.

    Did you use Powershell command or GUI to start your sync service? Remember Sync service needs credentials to trigger, so do not use powershell to start, do it from GUI/CA.

    You may alternatively use powershell to stop your service which is stuck at starting.

    Stop-SPServiceInstance -Identity  <GUID of UPS Sync Instance on that server>

    Friday, March 31, 2017 1:19 PM
  • If Spence's article doesn't help then start digging into the logs.  If you don't have it, get ULS Viewer and look for entries relating to the User Profile Service.

    Commonly, the service account is not a member of the local Administrators group at the time of provisioning the service: http://www.adventuresinsharepoint.co.uk/2014/07/02/user-profile-synchronization-service-stuck-on-starting/


    • Edited by Dai Webb Friday, March 31, 2017 3:50 PM
    Friday, March 31, 2017 3:48 PM
  • Hi All,

    Thanks for your reply. I already checked that the Farm account has replicating directory changes AD permissions. 

    I also tried to start the service by powershell but still it was not started.

    Service Account already member in the local administrator.


    Manikandan

    Friday, March 31, 2017 6:22 PM
  • What you need to do, is take a look at what exactly happens in the ULS logs while it is starting the service.

    You can download it, if not already done, from here.

    After that, use the category "User profiles" and post here the exception.


    //Vadim

    Friday, March 31, 2017 8:20 PM
  • This is a known issue in SharePoint 2013. One of the reasons I only use SP2016 nowadays. But probably the reason why it does not work is because of the Service accounts. Which accounts are you using for both of the UPS (fim) services in services.msc? What is the account for the UPS service and how are the permissions on the UPS service itself? In SP 2013 I used to make all above users the farm admin and usually that works.
    Saturday, April 01, 2017 6:35 AM
  • Oh and also, check which CU you have installed Just to be sure. SQL 2014 does need a minimal of March 2016 CU to work properly
    Saturday, April 01, 2017 6:37 AM
  • Did you get ULS viewer to check out the logs?

    Also, you may need to restart the server after adding the service account to the local administrators group.

    Wednesday, April 05, 2017 8:39 AM