none
Exchange 2007 The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.

    Question

  • Hello,

    I have a SBS 2007 SP3. Cannot get outlook anywhere to work. OWA works fine with the SSL cert I have from Godaddy.

    Exchange conenctivity test shows everything OK until the very end when the following message appears:

    The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.

    I have verified that the Exhange Server can ping and resolve both the internal FQDN as well as its NetBIOS name.

    I have checked that the both server's NETBIOS name and its Internal FQDN are in their proper registry settings for the RPC proxy set for ports 6001, 6002 and 6004

    I can telnet into 6001, 6002 and 6004 using NetBIOS or FQDN and reply is ncacn_http/1.0

    I have installed the latest rolups for SP3 as of 12/15/2011

    Any help is appreciated.


    Miguel Fra / Falcon IT Services
    Computer & Network Support, Miami, FL
    Visit our Knowledgebase and Support Sharepoint Site

    Monday, December 19, 2011 5:10 AM

Answers

  • Hi,

     

    From the problem description, I understand that you are unable to use the Outlook Anywhere with the following error message:

     

    The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process

     

    At first, please make sure that the following registry keys are correct:

     

      -- HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

      -- Type: REG_DWORD

      -- Name: Rpc/HTTP Port

      -- Value: 0x1771 (Decimal: 6001)

     

      -- HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

      -- Type: REG_DWORD

      -- Name: Rpc/HTTP NSPI Port

      -- Value: 0x1774 (Decimal: 6004)

     

      -- HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

      -- Type: REG_DWORD

      -- Name: HTTP Port

      -- Value: 0x1772 (Decimal: 6002)

     

    At the same time, we need to check the host files on the server are valid or not. Then if you have enabled the IPv6 on the NIC card, please disable the IPv6 to verify the issue still remained or not.

     

    Regards,

    James

    James Xiong

    TechNet Community Support

    Wednesday, December 21, 2011 9:14 AM
    Moderator

All replies

  • In your message you say SBS 2007 which doesn't exist, but in your subject you say Exchange 2007. Did you actually mean an SBS 2008 with Exchange 2007?

    Steve

    <Falcon IT Services> wrote in message news:bf8729c6-f4e0-4480-b9ec-5c7a142dada2@communitybridge.codeplex.com...

    Hello,

    I have a SBS 2007 SP3. Cannot get outlook anywhere to work. OWA works fine with the SSL cert I have from Godaddy.

    Exchange conenctivity test shows everything OK until the very end when the following message appears:

    The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.

    I have verified that the Exhange Server can ping and resolve both the internal FQDN as well as its NetBIOS name.

    I have checked that the both server's NETBIOS name and its Internal FQDN are in their proper registry settings for the RPC proxy set for ports 6001, 6002 and 6004

    I can telnet into 6001, 6002 and 6004 using NetBIOS or FQDN and reply is ncacn_http/1.0

    I have installed the latest rolups for SP3 as of 12/15/2011

    Any help is appreciated.


    Miguel Fra / Falcon IT Services <http://www.falconits.com/>
    Computer & Network Support, Miami, FL
    Visit our Knowledgebase and Support <http://www.falconitservices.com> Sharepoint Site

    Monday, December 19, 2011 3:41 PM
  • Yes, SBS 2008 with Exch Sp3

    Miguel Fra / Falcon IT Services
    Computer & Network Support, Miami, FL
    Visit our Knowledgebase and Support Sharepoint Site

    Monday, December 19, 2011 5:56 PM
  • Hi,

     

    From the problem description, I understand that you are unable to use the Outlook Anywhere with the following error message:

     

    The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process

     

    At first, please make sure that the following registry keys are correct:

     

      -- HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

      -- Type: REG_DWORD

      -- Name: Rpc/HTTP Port

      -- Value: 0x1771 (Decimal: 6001)

     

      -- HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

      -- Type: REG_DWORD

      -- Name: Rpc/HTTP NSPI Port

      -- Value: 0x1774 (Decimal: 6004)

     

      -- HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

      -- Type: REG_DWORD

      -- Name: HTTP Port

      -- Value: 0x1772 (Decimal: 6002)

     

    At the same time, we need to check the host files on the server are valid or not. Then if you have enabled the IPv6 on the NIC card, please disable the IPv6 to verify the issue still remained or not.

     

    Regards,

    James

    James Xiong

    TechNet Community Support

    Wednesday, December 21, 2011 9:14 AM
    Moderator
  • Hi James,

     

    Thanks for your reply. I will check these settings and get back to you.

     

    Cheers


    Miguel Fra / Falcon IT Services
    Computer & Network Support, Miami, FL
    Visit our Knowledgebase and Support Sharepoint Site

    Friday, December 23, 2011 3:53 AM
  • Hi,

    Any Update?

    James


    James Xiong

    TechNet Community Support

    Wednesday, December 28, 2011 9:03 AM
    Moderator
  • Hi. I have not gone back and tied it again. I have to wait until I get a green light. I think this weekend may be good. When I do this I have to switch to a Public cert and all the internal users get a cert error on outlook and although it's no big deal, I try to do things when nobody is around so so things are always the same..

     

    Thanks, I will keep you posted because it's something I definitely have to get running. I need outlook anywhere on this server for sure.


    Miguel Fra / Falcon IT Services
    Computer & Network Support, Miami, FL
    Visit our Knowledgebase and Support Sharepoint Site

    Wednesday, January 18, 2012 7:56 PM
  • Put the external rpc proxy server in
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy validports
    Saturday, March 31, 2012 12:21 AM
  • Put the external rpc proxy server in
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy validports
    This is what was needed in my case, I put in remote.domain.com for all 3 ports and it finally tested OK.  Thanks so much!
    Wednesday, March 09, 2016 8:23 PM
  • it worked!!!
    Thursday, March 09, 2017 6:43 PM