locked
Problem installing Win XP Virutal machine on Hyper-V on Win 8 Pro RRS feed

  • Question

  • I purchased Windows 8 Pro using a 64 bit setup. I want to install Win XP 32 bit as a virtual machine on Hyper-V.  I had no problem setting up the virtual machine in the Manager but when I  try to install XP this is what happensed: after I inserted the XP installation disk and hit the Connect command. The Virtual Machine desktop say "Connecting to XP Virtual Machine" (my virtual machine name) and just stuck there without showing the XP installation screen. Although in the Hyper-V Manager screen tells me that the virtual machine is running and a small thumbnail like image at the bottom of the Hyper-V Manager seems to show the XP installation screen. What is going on?
    Friday, May 31, 2013 12:10 AM

All replies

  • please post some pictures so that we can see your issue.

    "A programmer is just a tool which converts caffeine into code"

    Friday, May 31, 2013 4:52 AM
  • Do you have any kind of extra firewall running?  Try disabling that to see if it changes anything.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Friday, May 31, 2013 1:15 PM
  • Thanks Andre, I am having problem posting images. I have notified the administrator. Will post the picture ASAP.
    Tuesday, June 4, 2013 8:58 AM
  • Thanks Bob, I have window firewall disabled as default. I have also disabled my zonealarm firewall but the problem persist.
    Tuesday, June 4, 2013 8:59 AM
  • Hi Andre, below is the image of the virtual machine and Hyper-V manager:

    Wednesday, June 5, 2013 8:38 AM
  • Do you have IPv6 disabled on your host's NIC?
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Wednesday, June 5, 2013 1:41 PM
  • What happens if you open the Window first and select here to start the VM?

    "A programmer is just a tool which converts caffeine into code"

    Wednesday, June 5, 2013 6:03 PM
  • Sorry, not sure what you meant andre. Can you pls elaborate?
    Thursday, June 6, 2013 6:08 AM
  • so instead of running the VM first, open the Virtual Concection Manager first. Here you also have buttons to start the VM. I don't use Hyper-V (I prefer VMware) so I can't tell you how the buttons are named.

    "A programmer is just a tool which converts caffeine into code"

    Thursday, June 6, 2013 6:25 AM
  • Hi Bob,

    Attached are the properties of my ethernet and virtual switch connection. I believe IPv6 is enabled by default and I have not attempted to disabled it. I am using an External virtual switch and is using the Wifi rather than a LAN connection. I can't seem to get the wifi network properties.

    Thursday, June 6, 2013 9:49 AM
  • Hi Andre,

    I am not able to find the Virtual Connection Manager. The only way to connect is through Hyper-V manager.

    Thursday, June 6, 2013 9:51 AM
  • This is the network property for the network bridge:

    Thursday, June 6, 2013 10:05 AM
  • I wonder if it's anything to do with your wifi adapter, is it possible to try wired or another wifi adapter?
     
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Thursday, June 6, 2013 10:13 AM
  • Hi Bob, unfortunately my router is out of reach from my desktop to use a wired connection and I don't have another wifi adapter other than the Dell build in one. I have read somewhere that by selecting an "external" virtual switch can cause problem but I have tried switching to "internal" and the problem still persists. But I do not have the reported symptom of lost of internet connection reported.

    http://blog.siliconvalve.com

    I tried to follow the instructions provided in the above link but unlike what the author said about the vEthernet connection, as you can see in the diagram below, my vEthernet connection is fine so the blog does not exactly described my problem.


    I also noticed that the hyper-v manager is detecting no heartbeat but then why is it showing the xp installation screen in that small thumbnail at the bottom? It's all very bizzare.

    Btw I also try inserting a window 7 disk and the result is the same so it is not my copy of the XP installation file that is the problem. I think I am with you in thinking that the virtual switch is somehow not connecting. 

    Saturday, June 8, 2013 12:58 AM