none
Default file location in Excel 2013 issue RRS feed

  • Question

  • Environment:
     Users working on Windows RDS servers and working with Microsoft Excel 2013
    OS: Windows Server 2008 R2, With the latest patches
     Role: Remote Desktop Services
     Office: Office 2013, Dutch
    Issue:
     Recently our end-users complained about not being able to create an export from several applications to Microsoft Excel 2013. The error indicated that some Excel add-ons were not properly loaded.
     When the end-users creates an export from several applications, Excel will be started (in compability mode), but generates an error. As result, the export fails.
    Error message: We cannot find H:\hstbar.xla. Check if the item is removed, deleted or if the name is changed?

    Investigation:
     If we detached the Microsoft Office 2013 policy settings, the issue disappeared.
     After further investigation, our conclusion was that the issue had something to do with the default file location. If the default file location wasn’t redirected (default setting, located on the local drive, everything works). But if the file location is redirected to a mapped network drive the issue arises.

    The policy settings regarding this issue are
     AutoRecover Save Location: H:\
     Default File Location: H:\

    Workaround:
     As a temporary solution (doesn’t work always), we copied the .xla file (which is located on the terminal server: C:\Oracle\SmartView\bin\HsTbar.xla) to the default file location (H:\).
     This solution only works if the user doesn’t already have started Microsoft Excel. If Excel is already opened, then the export will fail, but without an error. The Excel worksheet will be empty.

    Redirecting back to the default file location is not a solution, because then the end-users are saving the documents then in their profile, instead on the file server.

    Support question:
     How can we fix the issue and get rid of the workaround, without changing the default file location back to the default file location (C:\Users\<username>\Documents)?
    Tuesday, March 8, 2016 10:13 AM

Answers