locked
Stop monitoring single database on a SQL server RRS feed

  • Question

  • Our SQL team has requested to stop monitoring a single database on a SQL server.

    I thought the best way to do this would be to disable the discovery of this particular database, then run Remove-SCOMDisabledClassInstance to remove the database from SCOM.

    Unfortunately after doing this, we are still receiving an alert for this database - MSSQL 2014: Workflow failed to connect to the target system. I can't override this rule for the database, because the database is no longer in SCOM! And since the rule is targeted to the DB engine, I'm not sure that overriding it for a database would work anyway.

    Am I going about this the right way? Is there another way to stop a single database from being monitored by SCOM? Any suggestions or advise would be welcome.

    Monday, April 25, 2016 10:32 PM

Answers

  • My workaround was to override the severity of 'MSSQL 2014: Workflow failed to connect to the target system' to Warning for the DB Engine. The DBA's notification subscription is configured for all critical alerts, so changing it to warning means they won't be notified, but the alert will still appear in the console.
    • Marked as answer by Lee-RS Monday, May 9, 2016 10:54 PM
    Monday, May 9, 2016 10:54 PM

All replies

  • Would you mins to provide the detail of the alert such aas which script is not working.

    Roger

    Tuesday, April 26, 2016 3:15 AM
  • Hi Roger,

    The database in question can go into a restoring state at any time, so the alert is genuine, we just don't want alerts for this database.

    Here's the alert detail (minus the server name etc.):

    Script: GetSQL2014DBFilesFreeSpace.vbs : Cannot login to database

    Tuesday, April 26, 2016 4:08 AM
  • Besides, you disable the discovery of particular database instance. You also disable the discovery of DB file and DB Log file for this particular database.

    Roger

    Tuesday, April 26, 2016 6:44 AM
  • Hi Sir,

    According to that alert , you may check which monitor/rule generated that alert .

    (Please click that alert then you may get the details from bottom side of SCOM console , it should point out which Rule/Monitor generated that alert .)

    If you only want to eliminate that alert , you may override that Rule/Monitor for particular DB .

    As you mentioned , you have overrided discovery , please remove that override then discover that DB again .

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .

    Tuesday, April 26, 2016 9:59 AM
  • not sure how you've tried to override, but the only way to not discover a DB is to put a DB in the excludelist of the override. Did you do this?

    The removed-disabledclassinstance cmdlet doesn't work for this, but the discovery itself should remove it.

    Else the only way i can think of is to disable the entire SQL discovery for this server, run the cmdlet, and enable it again after you've overriden the excludelist.

    Discover Databases for a Database Engine > override excludelist (for specific db's in an instance)

    Discover SQL Server 2012 Database Engines (Windows Server) > override exclude list (for SQL instances)

    SQL Server 2012 DB Installation Discovery Source > disable per server to stop SQL monitoring.


    Rob Korving
    http://jama00.wordpress.com/

    Tuesday, April 26, 2016 12:33 PM
  • Thanks everyone for your replies.

    Roger - the discoveries for DB File and DB Log File only have the option to override enabled - there's no exclude list like the database discovery. So I'd have to disable discovery for the whole server, which I don't want to do.

    Elton - yes that's a possibility. I'd have to discover the database again, then find all the rules/monitors for the database (not just the one that's alerting now) and override them all. I think I might have to go with this option.

    Rob - Yes I added the DB to the excludelist using an override - the database doesn't show up in discovered inventory anymore. It looks like this method worked to disable monitoring/alerting in previous versions of SQL, but the SQL 2014 MP has this new rule 'MSSQL 2014: Workflow failed to connect to the target system' which alerts even if the database is not discovered.

    • Proposed as answer by Elton_Ji Sunday, May 8, 2016 3:06 AM
    • Marked as answer by Elton_Ji Monday, May 9, 2016 9:39 AM
    • Unmarked as answer by Lee-RS Monday, May 9, 2016 10:52 PM
    Tuesday, April 26, 2016 9:00 PM
  • My workaround was to override the severity of 'MSSQL 2014: Workflow failed to connect to the target system' to Warning for the DB Engine. The DBA's notification subscription is configured for all critical alerts, so changing it to warning means they won't be notified, but the alert will still appear in the console.
    • Marked as answer by Lee-RS Monday, May 9, 2016 10:54 PM
    Monday, May 9, 2016 10:54 PM