none
Resource Usage spikes last day of task RRS feed

  • Question

  • I am trying to use Microsoft Project to track the usage of equipment on various projects. The equipment is non-consumable, and a fixed number of units are allocated for every day of the project. For examples, I may need 5000 Cables for a task, and those cables will be assigned to that task for the whole length of the task, then transferred to a new project afterwards.

    In order to do this, I set up the resource as a Work resource, set its working hours to 1 hour per day, then allowed it to be overallocated up to the maximum number of units available. I can then assign 5000 units to a project and see it assigned on my resource usage view.

    Everything looks great, except that for some reason on the last day of each task, resource usage spikes. If I have a 31 day long project using 10,000 units, every day of the project shows the use of 10,000 units until the last day when for some unknown reason, usage increases to 90,000. Can anyone tell me why that would be or how to fix it?

    Thursday, August 30, 2012 8:22 PM

Answers

  • Try this workaround:

    1. Goto File menu | Options| General tab. Change the Date format to Date and time format. Click Ok.

    2. Goto Resource Usage view.

    3. Click on View Tab | Select Details checkbox and then select Resource Form from the Details pane drop down.

    4. In the Resource form view at the bottom, right click on empty gray color area on the right and click Schedule from the menu.

    5. In the Scheduled Finish field, change the time from 5:00 pm to 9:00 am.

    Please let me know if this works.


    Thanks and Regards, Roopkumar Kamat (MCITP)

    Monday, September 3, 2012 7:33 AM

All replies

  • Which fields are you looking at for these numbers:
     
    1) Work
    2) Baseline Work
    3) Actual Work
     
    It sounds consistent with a more traditional work scenario where the work
    is not completed each day and the system just keeps pushing it towards the
    end of the task - until you end up with unrealistic work estimates towards
    the end of the task.  That being said, we would need some more info to identify
    the issue.
     
     

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky
    Friday, August 31, 2012 2:11 AM
    Moderator
  • Can you please provide more details steps so that I can try to reproduce the issue?


    Thanks and Regards, Roopkumar Kamat (MCITP)

    Friday, August 31, 2012 7:30 AM
  • OK, so I've created some resources. For this example, the resource is GSR Channels Rental B.

    I set the Working Week for that resource to 8 AM to 9 AM for every day of the week in order to ensure the resource is used at the rate of 1 hour per day per unit. I then set the max allocation to 6,626, which is the number of channels available. For each day of unit allocation for each channel, 1 hour of work should appear on the resource sheet.

    I then create a task and assign units of GSR Channels Rental B to that task:

    Now when I check the resource usage view, I see that usage spikes up on the last day of the task:

    I want to be able to look at the Work and see that I've used 10,000h for every day of the project. I want to be able to see that I've overallocated 3,374 units because I only had 6,626 available. If I use Peak Units, it shows the 10,000 units per day I'm using, which is good, but it doesn't then tell me the proper overallocation.

    Friday, August 31, 2012 2:50 PM
  • Hi,

    I could try to reproduce but that seems futile - you discuss Project's scheduling while you put the task to be manually scheduled. I'm sure you will see a more consistent image when you set the task to be autmatically scheduled.

    Greetings,

    Friday, August 31, 2012 4:03 PM
    Moderator
  • Automatic scheduling seems to change the dates for the task for me, though, whether I set it to Fixed duration, fixed units, or fixed work.
    Friday, August 31, 2012 4:21 PM
  • Hi,

    But the spike has gone insnt'it?

    Hadn't you introduced anywhere total work for the task? if you set that to 0 prior to connecting the resource and its units you will have your even spread.

    Greetings,

    Friday, August 31, 2012 5:33 PM
    Moderator
  • Try this workaround:

    1. Goto File menu | Options| General tab. Change the Date format to Date and time format. Click Ok.

    2. Goto Resource Usage view.

    3. Click on View Tab | Select Details checkbox and then select Resource Form from the Details pane drop down.

    4. In the Resource form view at the bottom, right click on empty gray color area on the right and click Schedule from the menu.

    5. In the Scheduled Finish field, change the time from 5:00 pm to 9:00 am.

    Please let me know if this works.


    Thanks and Regards, Roopkumar Kamat (MCITP)

    Monday, September 3, 2012 7:33 AM
  • Hi Reev308,

    Its an intelligent approach you have already taken my friend :) just to tweak it a bit - create a task calendar also that has to be same as resource's i.e. 1 hr 8 am-9am. NOTE - I assume that there are not many such tasks using these 'Cables resource' (if there are many; may be you can try Project Calendar), now apply task calendar to these tasks and it will recalculate everything. So with Manual option on, this will help you achieve same results as you expected. But when you change the mode to Auto a bit of tweaking may be required. Please make sure when you add task calendar "Duration" will tend to decrease make it same as before applying the calendar( here it seems 5 days). The results you are getting are due to manual option selected as Jan pointed and back loading of work as suggested by Andrew. 


    Sapna Shukla

    Tuesday, September 4, 2012 2:02 PM
    Moderator
  • Try this workaround:

    1. Goto File menu | Options| General tab. Change the Date format to Date and time format. Click Ok.

    2. Goto Resource Usage view.

    3. Click on View Tab | Select Details checkbox and then select Resource Form from the Details pane drop down.

    4. In the Resource form view at the bottom, right click on empty gray color area on the right and click Schedule from the menu.

    5. In the Scheduled Finish field, change the time from 5:00 pm to 9:00 am.

    Please let me know if this works.


    Thanks and Regards, Roopkumar Kamat (MCITP)

    Roopkumar, this seems to have done the trick. Is there a way to set the default value there to 9 AM, or is that something I'm going to have to do every time I make a new task?
    Tuesday, September 4, 2012 2:17 PM
  • Hi Reev308,

    Its an intelligent approach you have already taken my friend :) just to tweak it a bit - create a task calendar also that has to be same as resource's i.e. 1 hr 8 am-9am. NOTE - I assume that there are not many such tasks using these 'Cables resource' (if there are many; may be you can try Project Calendar), now apply task calendar to these tasks and it will recalculate everything. So with Manual option on, this will help you achieve same results as you expected. But when you change the mode to Auto a bit of tweaking may be required. Please make sure when you add task calendar "Duration" will tend to decrease make it same as before applying the calendar( here it seems 5 days). The results you are getting are due to manual option selected as Jan pointed and back loading of work as suggested by Andrew. 


    Sapna Shukla

    Thanks for the input, Sapna. I already had the Project Calendar set to 8AM-9AM 7 days a week. Basically I'm not managing human resources at all, but only equipment resources, the most prominent of which are the Cables, which we use on all our project tasks.
    Tuesday, September 4, 2012 2:19 PM
  • Its a default setting that you need to define in your File -> Options -> Schedule. There you can define Start n Finish time of day, hours/week for the project etc. I thought at this level of tracking you would have already set these options. Missed that.

    Sapna Shukla

    Tuesday, September 4, 2012 2:30 PM
    Moderator
  • Its a default setting that you need to define in your File -> Options -> Schedule. There you can define Start n Finish time of day, hours/week for the project etc. I thought at this level of tracking you would have already set these options. Missed that.

    Sapna Shukla

    Oh thanks! That actually helps a lot!
    Wednesday, September 5, 2012 2:12 PM