COM Surrogate stops working When printing in Internet Explorer 10

    General discussion

  • Some info about the setup
    • Virtual Server
    • WIndows server 2008 R2 Standard
    • Terminal server
    • 64 Bit
    • Internet Explorer 10.0.9200.16618

    Problem detail from Reliability Monitor

    The problem only occurs for some users, other users on the terminal server are able to print.
    Printing in Google Crome works just fine.

    I've tried to disable all "add-ons" in internet explorer
    I've disabled Data Execution Protection for "C:\Windows\SysWOW64\dllhost.exe"
    I've also tried to add "C:\Windows\System32\dllhost.exe" got an error about 64bit 

    Thursday, July 11, 2013 6:56 AM

All replies

  • Hi,

    did you every get a fix for this?,

    I am experiencing this on my citrix xenapp 6.5 servers


    Thursday, September 19, 2013 10:33 AM

    Problem: My Windows 7 x86 (32bit) Virtual Instance on Parallels was having issues with launching Internet Explorer 11, either after an upgrade from 10 or when I had accidentally uninstalled then reinstalled my Parallels Display Adapter from the Device Manager. And since one of my work websites rely and are only compatible with Internet Explorer, this was driving me NUTS. Every time I would launch Internet Explorer, I would get bombarded with a series of COM Surrogate errors that would never stop until I had end tasked everything via Task Manager and/or restarted the virtual machine.

    Diagnosis: After attempting all the available solutions on the internet..: Updating Windows 7/8 Codecs, Adding Data Execution Prevention (DEP) entries for both COM Surrogate and Windows Host Process for my x86 Windows 7, and attempting to find a way to downgrade Internet Explorer 11 (nearly impossible).

    HERE IS THE SOLUTION that worked for me:

    1. Hit Windows + R (Run) and launch "inetcpl.cpl" (Internet Explorer Settings)

    2. Go to the Advanced Tab, and Click "Reset..."

    3. Check "Delete Personal Settings" and click Reset

    Enjoy :)


    Sunday, December 22, 2013 2:47 AM