locked
Resize Visio drawing in Word document RRS feed

  • Question

  • Hello,

    I have an A3 drawing in Visio and I want to make it fit on an A4 page in Word. If I do 'select all' -> copy paste to Word from Visio, I need to resize it.. ok that works partially, because half of the drawing is not visible eventhough the I resized the Visio frame in Word to fit the page. It seems the frame is A4 size and does not fit the A3 sizing. How can I get that to work?

    Thursday, December 8, 2016 2:24 PM

Answers

  • Hi Niels,

    As per your query, I’d recommend you try resizing the shapes in Visio to fit A4 before copying and pasting to the Word document:

    1. Open the A3 drawing in Visio, go to Design > Size, select A4.
    2. Resize the shape size to fit the A4 page.
    3. Select All, copy and paste to the Word document.

    Additionally, to insert Visio drawings into Word, we could also try the steps below:

    1. Start Word, go to Insert > Object > Create from File, browse to the Visio file.
    2. Tick the option of Link to file so that the changes to the source file can be reflected in your document (Right click > Update link):
     
    3. Position the pointer at the edge of the drawing, drag the double-headed arrow to resize the picture.
     
    4. Or you could right click the drawing, click Picture, select the Size tab, make adjustments to resize.

    Hope the above information can be helpful.

    Best Regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Oekeloen Friday, December 9, 2016 2:20 PM
    Friday, December 9, 2016 11:12 AM

All replies

  • Hi Niels,

    As per your query, I’d recommend you try resizing the shapes in Visio to fit A4 before copying and pasting to the Word document:

    1. Open the A3 drawing in Visio, go to Design > Size, select A4.
    2. Resize the shape size to fit the A4 page.
    3. Select All, copy and paste to the Word document.

    Additionally, to insert Visio drawings into Word, we could also try the steps below:

    1. Start Word, go to Insert > Object > Create from File, browse to the Visio file.
    2. Tick the option of Link to file so that the changes to the source file can be reflected in your document (Right click > Update link):
     
    3. Position the pointer at the edge of the drawing, drag the double-headed arrow to resize the picture.
     
    4. Or you could right click the drawing, click Picture, select the Size tab, make adjustments to resize.

    Hope the above information can be helpful.

    Best Regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Oekeloen Friday, December 9, 2016 2:20 PM
    Friday, December 9, 2016 11:12 AM
  • Hi there, the first steps worked for me, although there were some arrows that were misformed after the resize. Also the font size was too large. I corrected the arrows, which was a hassle, and changed the font size with the 'down' (decrease font size) arrow in the Home -> Font tab. This worked for me. Thanks!
    Friday, December 9, 2016 2:22 PM
  • Hi Niels,

    Great to see that I can be of help. :)

    Regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 12, 2016 2:20 AM
  • Hello, I have a similar issue trying to insert a Visio Drawing into a Work document using Copy & Paste, Inserting an Object; the size of both documents is A3 and when inserting, I always lose the lower edges and sides.  I used to be able to insert using this method and do not know why it has stopped.
    Monday, March 11, 2019 11:41 AM