locked
How to turn off autologon? RRS feed

  • Question

  • I have a virtual Server 2008R2 Core, which I have joined to my virtual domain.  However, when I power this machine on, it automatically logs on as the local user under which I installed the O/S.

    How can I prevent this behaviour, and cause the server to start with the "Press Ctrl-Alt-Del" screen?

    At the moment, I issue the command:

    shutdown /l

    and then I get my logon screen.


    Grant Ward, a.k.a. Bigteddy

    What's new in Powershell 3.0 (Technet Wiki)

    Thursday, February 9, 2012 1:13 PM

Answers

  • Hi!

    I haven't tried this on server core, but it applies to every other Windows OS I know.

    You could check the registry settings for Autologon:

    Open registry editor on the core server by typing regedit. Expand HKEY_Local_Machine -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> WinLogon.

    If it's there, find the string named "AutoAdminLogon". If it's present and has the value "1", you can disable it by changing the value to "0".

    • Marked as answer by Bigteddy Friday, February 10, 2012 11:36 AM
    Friday, February 10, 2012 10:44 AM

All replies

  • Hi,

    Please disable the following policy:

    [Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Interactive logon: Do not require CTRL+ALT+DEL]

    If this policy is disabled, any user is required to press CTRL+ALT+DEL before logging on to Windows (unless they are using a smart card for Windows logon). For more information, please refer to:

    Interactive logon: Do not require CTRL+ALT+DEL
    http://technet.microsoft.com/en-us/library/cc780932(WS.10).aspx

    Hope it helps.

    Regards,

    Bruce
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, February 10, 2012 9:40 AM
  • I did that, but it made no difference:  I restarted the member server twice, in order that it read the new policy setting, but it still auto-logs on to the local administrator account.

    Grant Ward, a.k.a. Bigteddy

    What's new in Powershell 3.0 (Technet Wiki)

    Friday, February 10, 2012 9:55 AM
  • Hi!

    I haven't tried this on server core, but it applies to every other Windows OS I know.

    You could check the registry settings for Autologon:

    Open registry editor on the core server by typing regedit. Expand HKEY_Local_Machine -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> WinLogon.

    If it's there, find the string named "AutoAdminLogon". If it's present and has the value "1", you can disable it by changing the value to "0".

    • Marked as answer by Bigteddy Friday, February 10, 2012 11:36 AM
    Friday, February 10, 2012 10:44 AM
  • Thank you Mike!  That was it.

    Grant Ward, a.k.a. Bigteddy

    What's new in Powershell 3.0 (Technet Wiki)

    Friday, February 10, 2012 11:36 AM
  • Hi,

    Your answer is valuable as soon as the logged user has rights to edit the registery...

    In my case, I am administrator but cannot connect my session because of autologon... and there is no permission in logged session to edit the registry. what can I do then ?

    Wednesday, August 16, 2017 9:24 AM
  • Hi, me again :)

    Found this for my issue on another forum, it worked for me (any win version) :

    cheers guys

    Press Windows R. A command box should appear. Type control userpasswords2 and hit the enter key. This should display the User Accounts screen in Windows 7. Select the user account in the main table and uncheck the “Users must enter a user name and password to use this computer". A click on the Apply button will open the Automatically Log On window. Enter the password and confirm it to add the password to the system so that it does not need to be entered during logon.

    Wednesday, August 16, 2017 9:35 AM
  • Hi,

    you have press Shift + Logoff (in start menu), the computer stay in the screen Ctrl-Alt-Del for another user access.

    Wednesday, January 10, 2018 8:02 PM