locked
xlsx files are not opening in browser in sharepoint 2010 RRS feed

  • Question

  • I am not able the xlsx reports directly in the web browser .

    If i am giving the URL as /hosturl/myreport.xlsx its showing an alert again to open, save and save as.

    If the URL is given as 

    hosturl/_layouts/xlviewer.aspx?id= reportpath/myreport xslx&DefaultItemOpen=1  it gets opened in web browser .

    Please help ....

    Thanks in advance

    Thursday, October 24, 2013 12:00 PM

All replies

  • Let's look at the normal offender first.

    What is file handling set to on your web application? (More info in the TechNet Wiki)

    Additionally, have you made any changes to your serverfilesExcelServer.xml file?

    Thursday, October 24, 2013 1:51 PM
    Answerer
  • file handling is set to  permissive

    I have not made any changes ,below i am adding the total details 

    <?xml version="1.0" encoding="utf-8" ?>
    
    <!-- Copyright (c) Microsoft Corporation. All rights reserved. -->
    
    <ServerFiles>
    	 <Mapping FileExtension="xlsx" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/> 
    	<Mapping FileExtension="xlsb" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/>
    	<Mapping FileExtension="xlsm" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/>
    	<Mapping FileExtension="ods" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/CreateNewDocument.aspx?id=|0"/>
    </ServerFiles>
    





    Indresh

    Thursday, October 24, 2013 2:08 PM
  • You may also verify the "Opening Documents in the Browser " settings on the Document library containing that excel file.

    try selecting "Open in browser" option.



    Naveed.DG MCITP, MCTS -SharePoint 2010 Administrator "Vote As Helpful" If it helps!!

    Thursday, October 24, 2013 2:15 PM
  • I tried by selecting open in browser option , but still its not getting opened .

    Indresh

    Thursday, October 24, 2013 2:23 PM