none
Robocopy with Win 8.1 , guidance needed RRS feed

  • Question

  • In Win8.1Pro 64 bit used  the command line:

    Robocopy V: F: \ backup /MIR / R:0

    The copied directories now take most of the space on an external Lacie HD F: . All the files and directories seem to be hidden though, neither  command line DOS evel  nor Windows 8.1 sees anything on the Lacie.

    The background , V: is the project file server of an architecture office and F: is a USB external  HD rotated weekly and stored elsewhere for backup. I used to do this with SyncToy on Win XP Pro from 2007 onward but just switched to Win 8.1 and noticed that SyncToy  is not supported . Found Robocopy after some googling .  Took me some trial end error  to get the above command line running, had to figure out where to put empty spaces in the command line and where not to .  Would really appreciate if someone knowledgeable could help me write  a command line that mirrors the content of  V: to F:\backup  without hiding  it . Further , do I need a second  version of the command line to do subsequent runs in a way that only copies new and changed files  and folders  to F: ?  A full run takes in excess of seven hours.

    RolfV

    Saturday, April 5, 2014 2:50 PM

Answers

  • Robocopy is self-documenting. Open a Command Prompt (cmd.exe) then type this command:

    robocopy /? > robocopy.txt

    You now need to play with the various switches to become familiar with this tool. It's not a scripting (=programming) problem.

    Robocopy will sometimes hide the target folder(s). Open Windows Explorer, then change its settings so that hidden files become visible. Again this is not a scripting problem.

    Saturday, April 5, 2014 2:59 PM

All replies

  • Robocopy is self-documenting. Open a Command Prompt (cmd.exe) then type this command:

    robocopy /? > robocopy.txt

    You now need to play with the various switches to become familiar with this tool. It's not a scripting (=programming) problem.

    Robocopy will sometimes hide the target folder(s). Open Windows Explorer, then change its settings so that hidden files become visible. Again this is not a scripting problem.

    Saturday, April 5, 2014 2:59 PM
  • Hidden folders on NTFS are never hidden but when copied to an external Fat32 drive the hidden bit makes them hidden.  Set Robocopy to create the folder structure empty but without transferring attributes.  That will be very fast.  Next copy the files to the structure.  The folders will stay visible.

    ¯\_(ツ)_/¯

    Saturday, April 5, 2014 3:03 PM
  • Great , seems I owe an apology for being on a wrong forum , only had vague ideas of what scripting might be, anyhow thanks for the fast and educated answers. Wonder if the easiest way might be to start ower and first format the external Lacie HD to the NTFS format. Well I will check the documentation first as suggested by Forest,

    Thanks.

    RolfV

    Saturday, April 5, 2014 3:43 PM