none
MDT 2013 Update 1 USB media deployment RRS feed

  • Question

  • Hello,

    I am having an issue deploying a previously capture image, when using an offline USB memory stick. This is my scenario:

    1. Using Windows 10 ADK and MDT 2013 Update 1 I have successfully created a task sequence, which creates, syspreps and captures a Windows 10 Professional image. 
    2. I am creating another task sequence to deploy the captured image to the same PC.
    3. The captured image is deployed successfully to the PC, if deployed over the network, using a minimum USB boot image (from my DeploymentShare\Boot folder)

    I am now trying to create an USB image, to deploy the image offline. I have accomplished the following:

    a. Created a MEDIA001 image (updated deployment share and updated media content), using a selection profile containing the OS image and the task sequence used for deployment earlier.
    b. Created a USB bootable memory stick, which boots successfully and displays the wizard, letting me choose the correct task sequence.
    c. The task sequence runs and formats the drive. Task sequence progress is displayed correctly.
    d. When it comes to the "Install operating system" step, the following error is displayed: "ZTI ERROR - Unhandled error returned by LTIApply: "D:\Deploy\Tools\X64\DISM.exe"  /Apply-Image /ImageFile:"D:\Deploy\Operating Systems\2015-08-31c\2015-08-31c.wim" /Index:1 /ApplyDir:C: is not a valid Win32 application.
     (-2147024703  0x800700C1) Litetouch deployment failed, Return Code = -2147467259  0x80004005"

    Let me re-iterate, that the same task sequence deploys the image successfully, when run over the network. I have checked, that the dism tool and the wim file are at the specified locations. But I am unable to understand, what goes wrong with dism specifically?
    I cannot attach the BDD.log until my account has been verified.

    Any help is greatly appreciated. I would also like to hear, whether someone has succussfully deployed their image by using an offline USB medium?
    Tuesday, September 1, 2015 2:21 PM

All replies

  • Is your original WIM over 4 GB?

    Is the system UEFI?

    If so, then I would venture to say that the USB Stick needs to be FAT32 (For UEFI) and the Image would need to be split (*.swm).

    Check: http://blogs.technet.com/b/msdeployment/archive/2015/08/25/mdt-2013-update-1-release-notes-and-known-issues.aspx#pi47623=5

    Hope this helps

    Wednesday, September 2, 2015 11:27 AM
  • So I know this is an old thread but I had the same issue as you.  

    Took me four hours of my life to figure it out but what I nailed it down to was the USB stick I was using.

    The USB stick i was using was a usb 3.0 kingston, 32GB.  On my computer, it was plugged into a usb 3.0 port.  

    The dism.exe file was able to run on my workstation no problem.  If I moved dism.exe to the usb stick and tried to run it on my workstation, I got an error saying "dism.exe is not a valid Win32 application".  If I moved that file back to my computer's hard drive and tried to execute it, no error.  If I tried to run the same file on the usb stick when it was plugged into a usb 2.0 port, rather than a 3.0 port, it would run with no errors.  The hashes of the files in all instances were the exact same.  

    I tried to format the usb drive in both fat32 and ntfs and the same error would occur when plugged into the usb 3.0 port. 

    I experienced the same result on two other computers.  Windows 7, 8 has the same error.  I didn't have a windows 10 computer to test it with.

    When imaging a surface pro 3 or 4, the usb port is a usb 3.0 port.  So when mdt tried to access dism, it got an error as experienced on my workstation.  

    So my solution: plug the surface pro 4 I was imaging into a usb 2.0 hub and used the usb 3.0 stick.  Other solutions that probably would work would include using a usb 2.0 usb stick.  

    No idea what's going on with this version of dism.  This didn't occur with the older version of dism in the old Windows ADK.  



    Thursday, January 7, 2016 12:15 AM