locked
AppV 4.6 and JRE 1.7 issue RRS feed

  • Question

  • I was wondering if there was anything that needed to be done differently when sequencing JRE 1.7 compared to 1.5 or 1.6? I have multiple sequences with both versions and have no issues, but I have not been successful in getting a 1.7 sequence working. When launching the web app I am being prompted to download Java, even though it is in the sequence and it worked throughout the capture.

    Sequencer - WinXP sp3 with ApPV 4.6 Sp2 installed. System is up to date patch wise and I have nothing else installed

    Have tried multiple things: with and without spaces, short names, letting the install happen after going to the site, installing JRE by launching during the capture, etc.

    The biggest difference, and one i am going to test now, is that I am trying to use the deployment.config/.properties in c:\Windows\Sun\Java\Deployment instead of what is put under my user name. This worked fine during the sequence but not on the test PC's. I am going to try it without this step (edit:Nope, just did this and it didn't work). But just wanted to see if anyone has come across an issue with JRe 1.7?
    The below are the files that I moved to the deployment folder in the windows. I also tried changing the path to U\:\\Kronos63\\JRE7 as this is similar top one that worked with 1.6 installed.

    Deployment.Config
    Code: Select all
    deployment.system.config
    deployment.system.config.mandatory = true


    Deployment.Properties
    Code: Select all
    #deployment.properties
    #Thu Apr 11 14:21:07 EDT 2013
    deployment.modified.timestamp=1365704467725
    deployment.version=7.0
    deployment.security.level=LOW
    #Java Deployment jre's
    #Thu Apr 11 14:21:07 EDT 2013
    deployment.javaws.jre.0.registered=false
    deployment.javaws.jre.0.platform=1.7
    deployment.javaws.jre.0.osname=Windows
    deployment.javaws.jre.0.path=C\:\\Documents and Settings\\All Users\\Application Data\\Microsoft\\Application Virtualization Sequencer\\Package Root\\Kronos63\\JRE7\\bin\\javaw.exe
    deployment.javaws.jre.0.product=1.7.0_17
    Monday, May 6, 2013 4:55 PM

Answers

  • We use U: and it is physical.  With that said, I seem to have gotten it working.  Instead of installing to the U drive, I just let it install to the default location and it worked.  Opened a ticket with MS to be told to try this, little embarrassed I didn't try something as easy as that first....  No answer to why this behavior happened though, was a strange one.
    Thursday, May 23, 2013 1:42 PM

All replies

  • The last version of Java I sequenced was Java 7 Update 4. I did not experience any issues but I would guess there may been significant changes since that iteration

    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Monday, May 6, 2013 5:02 PM
  • It is typically to the recent jre versions. Oracle did some changes to the newer versions, if you use an old version you will be prompted to update. Maybe it can be disabled, I haven't tried it. 

    It has nothing to do with App-V. 

    Monday, May 6, 2013 7:06 PM
  • Wednesday, May 8, 2013 4:21 PM
  • Thanks for the answers and based on them I see I left something out in my original post.  I am prompted to install java as a result of java not being installed.  it worked flawlessly on my sequencer, but when I deploy to a test PC (using SCCM) it does not see java.  I have even gone to Javatester . org and it too doesn't see java inside the package.

    Update: If add in a /exe cmd.exe and then try to launch the java control panel applet I get an error.

    "The system cannot find the path specified"

    C:\documents and settings\all users\application data\microsoft\application virtualization sequencer\package root\kronoswfc6.3\jre17_21\bin\javacpl.exe"

    Not sure why it is looking in the sequencer folder as I never installed to that location.

    Monday, May 20, 2013 10:09 PM
  • Hello,

    Resequence the application, however when you setup your sequencer;

    1. Create a physical Q: drive

    2. Install sequencer

    3. Sequence application


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, May 21, 2013 6:44 AM
  • Will do it again, but this is essentially how I sequenced it.  And it is pretty much the same sequencer I have used all along.  Setup with VMware workstation.  Snapshot, sequence, verify, reset and sequence new app.  Rinse and repeat.

    Not sure why the path contains a link to the sequencer folder in appdata.  But looking in the package, in the virtual registry, many of the paths are pointing there.  Strange.

    Will do it again, and see what I get.

    Tuesday, May 21, 2013 2:08 PM
  • OK.  Ran through the sequence again and tripled checked my paths during the install and the same thing has happened.  But, I paid closer attention to paths in general and noticed the following:


    the Java Platform OSD file has the filename entry = to the path where I installed (excluding the drive letter)  But, the Java Web start launcher osd filename entry points to the All users AppData  - %CSIDL_COMMON_APPDATA%\Microsoft\Application Virtualization Sequencer\Package Root\KronosWFM6.3\JRE1.7u21\bin\javaws.exe"

    I opened up the registry after the sequence and many of the Java path entries point to this folder.


    I opened the Deployment.properties found in the user profile, and the path in here also points to the same folder.  I looked at the file in an older install and it points to the install path.

    Older (sequenced several years ago.)
    deployment.javapi.jre.1.5.0_16.path=U\:\\Advantge\\JRE

    New
    deployment.javaws.jre.0.path=C\:\\Documents and Settings\\All Users\\Application Data\\Microsoft\\Application Virtualization Sequencer\\Package Root\\KronosWFM6.3\\JRE1.7u21\\bin\\javaw.exe




    Tuesday, May 21, 2013 6:10 PM
  • Hello,

    Did you have a physical Q: drive?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, May 21, 2013 8:18 PM
  • We use U: and it is physical.  With that said, I seem to have gotten it working.  Instead of installing to the U drive, I just let it install to the default location and it worked.  Opened a ticket with MS to be told to try this, little embarrassed I didn't try something as easy as that first....  No answer to why this behavior happened though, was a strange one.
    Thursday, May 23, 2013 1:42 PM
  • Microsoft probably wouldn't tell you this but there's really no need to sequence yours apps to the U:\ anymore. The performance difference is minimal and by sequencing to C:\ you lessen the chance of issues like this popping up.


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Thursday, May 23, 2013 1:56 PM