locked
Mapping a network drive to Sharepoint 2007 authentication issues RRS feed

  • Question

  • First, setup.  multiple VPN's, all (most) computers on domain.

    Second, Problem: I'm attempting to set up a login script using Kixtart to automatically map to a sharepoint 2007 Document folder.  

    The problem that I'm having, and that I would like to alleviate is that when an end user logs on, and then goes to open said folder, it requires them to log in again (sometimes twice).  I would like to set it up so that secondary authentication does not happen.  

    The interesting thing about this is that if the person navigates to our sharepoint front-end website (which uses current login information to access)  and navigates to the folder, the authentication pop-up doesn't happen and they are able to access the drive just fine. 

    So I guess this is a 2 part question.

    1) Is this even possible (i.e. did microsoft in their all-knowingness not enable this feature)

    2) whats the best way to accomplish this.

    Also, would it be better to just do the upgrade and worry about it later? 

    Thanks in advance for your help!


    • Edited by Mike Walsh FIN Tuesday, August 2, 2011 6:06 PM SP 2010 comment removed. Irrelevant in any pre-SP 2010 forum. Here stick to SP 2007 (or earlier) questions (and preferably one per thread) Line feeds added to aid comprehension [edit your post if you have a line or two more; don't reply]
    • Moved by Mike Walsh FIN Tuesday, August 2, 2011 6:07 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Tuesday, August 2, 2011 4:13 PM

All replies

  • Hi,

    Instead of using scripts have you tried the same using my network devices?

    If yes then what is the result? Have you tried the same on any other computer to see if this issue is with your PC or not?

    If possible can you post your script here so that we can take a look on that.

     

    Thanks,

    Rahul Rashu

    Wednesday, August 3, 2011 4:03 AM
  • If I map the network drive, it still asks me for credentials.  Once I enter them, it connects and I can access it fine.  When I map it, I check the box for reconnect at login. When I log in and log off again, the drive is listed as not connected, and I have to re-enter my credentials to connect.

     

    my script is as follows

     

    IF INGROUP("HR PERMISSIONS") = 1
    
    	USE G: "\\***-FP01\HR"
    
    	USE W: "\\intranet.*company*.com\HR\Shared Documents "
    
    		? "Mapping Sharepoint W: Drive"
    
    	Sleep 10
    
    		IF INGROUP("PAYROLL PERMISSIONS")
    
    			USE P: "\\***-FP01\PAYROLL DATA"
    
    		ENDIF
    
    	USE T: "\\***-FP01\APPS"
    
    ENDIF
    
    
    
    IF INGROUP("HR Intranet")
    
    	USE W: "\\intranet.*company*.com\HR\Shared Documents"
    
    	? "Mapping Sharepoint W: Drive"
    
    ENDIF

     

    I and others who are having this problem definitely have the correct permissions, in case you were wondering =)  

     

    Thanks very much for your help!


    Information Systems Intern -living, learning, breathing computers... =D
    Thursday, August 4, 2011 8:56 PM
  • Hi,  I have the exact same problem. Did you find a solution that you could share?

    Thx.

    Thursday, July 5, 2012 8:49 PM
  • Hi All,

    Im not using Kixstart we use net use and GPOs or PowerShell; EXAMPLE net use g: "http://intranet.yourdomain.com/shared documents"

    However, please make sure you have  *.YourDomain.com address added to the local Intranet security settings in IE this will ensure that the locally loggedin username and password are used to authenticate...

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    Monday, July 9, 2012 5:04 AM
  • I found the solution to my problem.

    My site was already in the IE Trusted Sites and Trustes Sites were configured to forward Windows authentication. WebClient was installed as part of the Desktop Experience feature. However, this was not enough and even though I was able to map a drive to Sharepoint, I was often prompted twith an authentication window. Also, because of that, I was unable to map the drive using the GPP.

    What made it work was adding the following registry settings to automate the Windows authentication forwarding by the WebClient service.

    NAME: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters\AuthForwardServerList

    TYPE: REG_MULTI_SZ

    DATA: http://myportal.mydomain.com https://myportal.mydomain.com (of course, these should reflect your server addresse)

    Everything works great now! Thank you all for your help.

    Wednesday, July 11, 2012 3:37 PM