none
Express Installation Files - Download speed - Download Progress

    Question

  • Hi,

    Together with the release of the May 2017 updates, Windows 10 clients should be able to use the express files.
    I installed the latest version from ConfigMgr 1702 and enabled the express installation files in the client support.
    The express files are enabled, downloaded and pushed to the clients in our test deployment.

    I see that the clients are downloading the express installation files.
    This is confirmed by taking a look in the Deltadownloader.log file:

    Bytes Transferred: 1048576 DeltaDownload 10/05/2017 20:30:32 9196 (0x23EC)
    Received incoming request, dwError = 0 DeltaDownload 10/05/2017 20:30:32 4268 (0x10AC)
    Delta Download Listener thread started. DeltaDownload 10/05/2017 20:30:32 4268 (0x10AC)
    In the Service Thread: url:

    localhost:8005/Content/A6/83901562240B60472C388A8D2549924777CB58A6.cab DeltaDownload 10/05/2017 20:30:32 8196 (0x2004)
    Received a GET request for localhost:8005/Content/A6/83901562240B60472C388A8D2549924777CB58A6.cab DeltaDownload 10/05/2017 20:30:32 8196 (0x2004)
    Request Initialized with URL: localhost:8005/Content/A6/83901562240B60472C388A8D2549924777CB58A6.cab and AbsPath /Content/A6/83901562240B60472C388A8D2549924777CB58A6.cab DeltaDownload 10/05/2017 20:30:32 8196 (0x2004)
    FileName = windows10.0-kb4019472-x64.cab, ContentID = 9cad1a71-dd8b-42ac-a7b0-a26052f026ef.1 DeltaDownload 10/05/2017 20:30:32 8196 (0x2004)
    Request is from User Agent: Microsoft-Delivery-Optimization/10.0 DeltaDownload 10/05/2017 20:30:32 8196 (0x2004)
    Requesting for bytes 629145600-630194175 DeltaDownload 10/05/2017 20:30:32 8196 (0x2004)
    Bytes Transferred: 0 DeltaDownload 10/05/2017 20:30:37 8196 (0x2004)
    Bytes Transferred: 1048576 DeltaDownload 10/05/2017 20:30:42 8196 (0x2004)

    However, the speed is very slow. One client is already downloading the smaller express installation files data for almost 8 hours and it is not finished yet. Is this normal behaviour?

    The previous "full update" from April appeared immediately on the client when executing the Machine Policy Retrieval action.

    From that moment you see also the download progress in Software Center. It seems that now the express installation files are downloaded first in the background before the update appears in Software Center. And so far, the Express Installation Files feature is way much slower than the traditional old update method with the full cumulative CAB update in ConfigMgr.

    So my 3 questions:

    - Are there any settings which can control the bandwidth speed of the Express Installation Files in ConfigMgr?
    - Is it possible to monitor the download progress (% completed) of the Express Installation Files?
    - Anyone else noticing this slow download behaviour?

    Wednesday, May 10, 2017 6:43 PM

All replies

  • - Are there any settings which can control the bandwidth speed of the Express Installation Files in ConfigMgr?

    > If you want to control the bandwidth between ConfigMgr servers, configure the rate-limits in DP        properties.

    > If you want control the bandwidth to client, configure the client settings 


    - Is it possible to monitor the download progress (% completed) of the Express Installation Files?

    >  where do you place the monitoring process?
    - Anyone else noticing this slow download behaviour?

    > i haven't faced the issue


    Kannan.CS | http://kannancs.com

    Wednesday, May 10, 2017 7:07 PM
  • Refer the below thread,


    https://social.technet.microsoft.com/Forums/en-US/a8194e64-ae05-44ac-8546-9b801e4028bf/express-update-client-caching-beavhor?forum=ConfigMgrCompliance


    Kannan.CS | http://kannancs.com

    Wednesday, May 10, 2017 7:19 PM
  • Pretty sure the Microsoft-Windows-Bits-Client/Operational log is tracking the BITS download for the express update downloads but it just looks like it's going horribly slow for me.

    I'm seeing continuous log entries every 1 second saying the BITS job is starting/completed with error code 0x0 so as far as logging there this appears to be the normal behavior.

    Wednesday, May 10, 2017 8:08 PM
  • I see the same in my Microsoft-Windows-Bits-Client/Operational log.

    The files are downloaded with BITS but there is no bandwidth limitation specified for this in the client settings of the ConfigMgr client.

    At this point the clients are already 20 hours downloading from the PSF files but no one managed to install the cumulative update of May 2017.

    I see the downloaded chunks are very small (between 10K - 100K)

    Thursday, May 11, 2017 5:25 AM
  • I disabled the option to download the Express files and rebooted the server.
    When I delete the update from the deployment package the express files are still downloaded
    when I download the update again. I also did a complete "Synchronize Software Updates" cycle in ConfigMgr to sync with WSUS.

    So how can we completely disable the Express updates functionality in ConfigMgr so that the PSF are no longer downloaded?

    Friday, May 12, 2017 6:11 AM
  • As this is new feature and not only one user is reporting the slowness, I suggest that you can submit feedback on Microsoft Connect at:

    https://connect.microsoft.com/


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, May 12, 2017 6:38 AM
    Moderator
  • I have the same issue with speed.  The 2017-05 Cumulative Update for 1607 has taken over 4 hours download only 50% so far using express updates.  Machines not using express can download the entire patch in a couple of minutes...
    Friday, May 12, 2017 2:11 PM
  • Same problem here. I disabled the client settings to use "normal" updates. We have the same troubles with client peer cache. I think ConfigMgr-Team is aware of this problem and will fix. There is sooo much happening there at the moment.

    Tuesday, June 27, 2017 7:55 AM
  • Same issue for Me, even after disabling it still downloads express file, please let me know if You find any solution

    Vinod Kumar Devaragatla

    Thursday, July 13, 2017 9:50 AM
  • Same issue for me as well, express files still being downloaded after disabling them; is there a fix for this yet?
    • Edited by mkwx Wednesday, July 19, 2017 7:38 AM
    Wednesday, July 19, 2017 7:37 AM
  • We have exact the same problem with our newly setup SCCM CB on Server 2016.

    Since it is not yet a production environment, I'm going to uninstall the SUP and WSUS (since reported at here that just disabling is not working) and try again without the express updates.

    I will let you know...

    Wednesday, November 8, 2017 1:15 PM
  • Seems we got lucky that we were using a non production system.

    Reinstallation of WSUS + SUP resolved the issue.
    Friday, November 17, 2017 7:19 AM
  • I had same issue but in Next month patch cycle issue fixed,  we need to wait for next cycle after disabling this option

    Vinod Kumar Devaragatla

    Tuesday, November 21, 2017 8:13 AM