locked
Internet Explorer 11: cannot open download manager with Ctrl-J RRS feed

  • Question

  • I've just upgraded my Windows 8 x64 to Windows 8.1. I've discovered that I cannot open the download manager window anymore using Ctrl-J keyboard shortcut. Web Channels list is opened instead. In Windows 8 before the upgrade that shortcut worked just fine.

    I still can open the window using main IE menu. Hotkey hint written next to the menu item is still Ctrl-J.

    Is this a glitch in my system only? Does somebody experience the same issue?

    Friday, October 18, 2013 4:34 PM

All replies

  • Hi,

    Sorry for my dilatory reply. Based on my test, In IE 11, this feature is still accessable. Did you installed any program that had a conflict with IE hotkey? please check it.

    If problem persists, please try to reset IE for test to resolve this problem.



    Roger Lu
    TechNet Community Support

    Thursday, October 31, 2013 10:08 AM
  • Roger,

    I didn't install any software which could possibly intercept IE shortcuts. Anyways, Ctrl-J opens not an additional program, but an element of the native IE interface.

    Browser settings reset haven't helped a bit.

    Friday, November 1, 2013 1:50 PM
  • Hi,

    For the current situation, you may need to move IE and readd it in Windows Feature for test. Also perform a clean boot for test to check whether this problem caused by 3rd program or service. Refer to the link below for more details.

    http://support.microsoft.com/kb/929135

    Also can Create a new user account the verify whether the problem persists.


    Roger Lu
    TechNet Community Support

    Wednesday, November 6, 2013 8:53 AM
  • As far as I know older versions of IE (Version 8.0 etc) brings up "Favourites"  When you Press "Ctrl+J".

    Its is also on Mozilla and Chrome that brings up "Downloads" from Menu.

    Try some other shortcut...!

    Wednesday, November 6, 2013 9:09 AM
  • Roger.

    I'm a network administrator, so I know how to disable IE addons and Windows startup programs. :)

    There is no third party programs or services that could influence IE behavior.  In addition, I've disables all of IE addons and plugins. Ctrl-J still doesn't work properly.

    Anyway, this cannot explain why IE was working properly before I upgraded Windows 8 to Windows 8.1.

    Deepuaxn,

    I tried all of the possible hotkeys combinations, and still no luck.

    Thursday, November 7, 2013 6:15 AM
  • I've discovered that this issue is encountered in the Russian version of IE 11 only. At least two more network administrators confirmed that they have Ctrl-J shortcut remapped to "Web channels" after upgrading to Windows 8.1. This issue is never encountered in the English version of IE 11.

    Monday, November 11, 2013 4:06 AM
  • Yep, the same problem at the same (11, russian) version.
    Thursday, November 28, 2013 6:03 AM
  • it's 12.2017 and the problem is still there for the russian IE. that's a shame!

    just verified in en IE - no issues. ru IE ctrl+j opens up web channels

    Wednesday, December 20, 2017 9:37 AM