locked
Sony Handycam firewire connection incompatible with Vista Home Premium? RRS feed

  • Question

  • I've seen this thread repeatedly all over the internet, but no working solutions are presented anywhere.  I have now wasted 3 days trying to get this new computer (an Acer Aspire laptop) to recognize my camera.  This is my final attempt to resolve this issue before I return the computer and the installed operating system for a full refund.  This machine and OS are almost entirely usless to me for my purposes unless I can find an immediate solution.

    I have a Sony HandyCam DCR-HC40 which Vista will not detect, even though it is connected via 1394a port and is specifically listed as being a Vista Home Premium compatible device.  I have tried every imaginable sequence to get it to recognize the camera, to no avail.  The camera works perfectly on every other computer I have except this Vista machine.  I have tried installing 2 different kb hotfixes and Vista SP2 along with attempting 2 registry edits listed in kb, no luck.  I have also successfully connected 2 different external 1394a hard drives to the same port I'm trying to use with the camera.  So the port, camera, cable and other firewire devices are fine.  Again today I have tested the camera and cable on all of my other computers with no problems.  Acer support hasn't been able to resolve this issue either.

    Vista will detect the camera when it is connected via USB 2.0 and it works fine.  But the quality of the captured video is unusable for my purposes.  I absolutely must be able to use the 1394a connection for video capture.

    Bottom line:  This is my last hope.  If someone will kindly either tell me that Vista does not support my camera, or help me out with a solution within the next 5 days, I will keep the computer and Vista.  Otherwise, it's going back to the store and my money will go to Apple as I have very little time left to get a refund or to continue troubleshooting what appears to be a major and widely reported compatibility issue nobody is adequately dealing with at MS. 
    Sunday, July 19, 2009 10:32 PM

Answers

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    I noticed that you have done a lot of tests with no avail. However, there are still some methods we can try. I can understand your feelings at this moment, if the issue is narrowed to Windows Vista, we will try our best to help you in this forum. Moreover, if you have any concern about Windows Vista, please feel free to let us know.

     

    Based on my research, I found that connecting Sony cameras to a computer needs the specific drivers. Generally, most of drivers for Sony cameras and camcorders are already included in the Microsoft Windows Vista Operating System. But in some instances,  the camera or camcorder may not be recognized by the computer when connected. In this case, check to see if there is an updated driver available for your model. Please visit the following website to download the latest right version driver for your Operating System and install it.

     

    http://esupport.sony.com/US/perl/swu-list.pl?mdl=DCRHC40&

     

    Note: we provide this third party website for downloading drivers, there may be some changes without notice. Microsoft doesn't control and guarantee the security in this website. You may need to contact Sony to confirm as well.

     

    For references:

     

    Sony® Camcorder Compatibility with Microsoft® Windows Vista® Operating System

    http://esupport.sony.com/US/perl/news-item.pl?&news_id=128&mdl=DCRHC40

     

    Note: we provide this third party website for references, Microsoft doesn't control and guarantee the security in this website.

     

    Hope this helps. Thanks.
    Tuesday, July 21, 2009 9:14 AM
    Moderator

All replies

  • Sorry.  I meant to post this in the vista forum.  Will do so now.
    Sunday, July 19, 2009 10:54 PM
  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    I noticed that you have done a lot of tests with no avail. However, there are still some methods we can try. I can understand your feelings at this moment, if the issue is narrowed to Windows Vista, we will try our best to help you in this forum. Moreover, if you have any concern about Windows Vista, please feel free to let us know.

     

    Based on my research, I found that connecting Sony cameras to a computer needs the specific drivers. Generally, most of drivers for Sony cameras and camcorders are already included in the Microsoft Windows Vista Operating System. But in some instances,  the camera or camcorder may not be recognized by the computer when connected. In this case, check to see if there is an updated driver available for your model. Please visit the following website to download the latest right version driver for your Operating System and install it.

     

    http://esupport.sony.com/US/perl/swu-list.pl?mdl=DCRHC40&

     

    Note: we provide this third party website for downloading drivers, there may be some changes without notice. Microsoft doesn't control and guarantee the security in this website. You may need to contact Sony to confirm as well.

     

    For references:

     

    Sony® Camcorder Compatibility with Microsoft® Windows Vista® Operating System

    http://esupport.sony.com/US/perl/news-item.pl?&news_id=128&mdl=DCRHC40

     

    Note: we provide this third party website for references, Microsoft doesn't control and guarantee the security in this website.

     

    Hope this helps. Thanks.
    Tuesday, July 21, 2009 9:14 AM
    Moderator