locked
Windows 7 slow on running remotely programs that reside in large folders RRS feed

  • Question

  • Here is the setup:

    Windows XP Pro computer that shares a folder. This folder has Notepad.exe in it (just the standard Notepad.exe that comes with Windows and it was copied to this folder).

    Access this folder from Windows 7 computer and run Notepad.exe - is runs almost momentarily (after a security prompt). 

    Access this folder from another XP machine and run Notepad.exe - the same - it runs immediately. 

     

    Now put 2000 EMPTY txt files in this shared folder.

    Now if you run Notepad.exe from the Windows 7 machine it will take about 15 seconds to see the security prompt and another 20-30 seconds to see Notepad running.

    No change of speed when running from XP - it starts immediately.

     

    If the "server" computer is Windows 7 no such slowness is observed - you can start Notepad.exe with or without 2000 files in the folder and it starts FAST. 

     

    So the problem surfaces when Windows 7 machine accesses XP shared folder that has thousands of files in it. It doesn't matter if you run Notepad.exe from a command prompt, from Windows Explorer or from a shortcut - it is always slow if you have these conditions.

    I read many many forums but could not find a solution to this. Things that I attempted:

    1. Switched off "Indexing" in Windows 7

    2. run "netsh interface tcp set global autotuning=disabled

    3. Switched off firewalls on both computers

    4. Switched off "Remote Differential Compress" from "Windows Features" 

    Nothing from the above helped. 

     

    Any idea guys how to solve this issue.. probably a registry setting like "SLOW_DOWN_NETWORK_ACCESS_WHEN_WINDOW7_ACCESSES_LARGE_FOLDERS_SHARED_ON_XP_MACHINE = False" :))

     

    Thanks!

    Monday, November 7, 2011 10:29 AM

All replies

  • Hi,

     

    Have you tried to boot Windows XP into Safe Mode with networking to see what the result is?

     

    If this issue still exists, you can try to disable the SMB2 to see how it works:

    Note: please backup your registry first.

     

    1. Open registry on Windows 7.

    2. Locate HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation and double click DependOnService, remove MRxSmb20 line.  (this steps remove the dependency of the SMB V2.0)

    3. Locate HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\mrxsmb20 and double click Start, set value to 4 (this essentially disable the SMB V2.0 driver from starting up)

    4. Reboot the machine.

     

    Alex


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, November 9, 2011 3:31 AM
  • Hi Alex,

    thanks for the suggestions. Unfortunatelly both didn't work for me. I tried in Normal AND in Safe Mode with both SMB 2.0 enabled AND disabled (all permutations with computer reboots on every change). 

    Any other suggestions?

    Thanks!


    asivarna
    Wednesday, November 9, 2011 9:19 AM