locked
RSS Viewer Web Part is not displaying images RRS feed

  • Question

  • Does anybody have an idea why the RSS Web Part replaces the URL’s to images with the local host URL?

     

    In my web app “A” I use a RSS Viewer Web Part with the feed from web app “B”.

     

    The images displayed in the feed have following links, when the feed is viewed on App “B” e.g. http://B-App/image1.png

     

    When I view the feed with the RSS Web Part the URL is changed to http://A-App/Image1.png which does not exist, resulting in broken link.

     

     

    Many thanks for your help!

    Thursday, May 5, 2011 7:13 AM

Answers

  • If anybody is interested, just a quick update on this issue.

    A custom RSS viewer was developed to resolve this issue.

     

    What we did is: if any of the URL's came in as relative we attached the host name of the feed to it. As only the URL's coming from the host were relative.

    • Marked as answer by mafx Monday, August 8, 2011 12:29 PM
    Monday, August 8, 2011 12:29 PM

All replies

  • Hi,

    please check RSS Feed URL of that RSS viewer web part

    Did you make any changes using XSL editor ?

     


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Thursday, May 5, 2011 6:43 PM
  • Hi,

    when I view the feed with 3rd party FeedReader it displays it correctly I use the same feed URL for the web part. The URL is correct.

    I did not make any changes to the XSL.

    Friday, May 6, 2011 7:13 AM
  • If anybody is interested, just a quick update on this issue.

    A custom RSS viewer was developed to resolve this issue.

     

    What we did is: if any of the URL's came in as relative we attached the host name of the feed to it. As only the URL's coming from the host were relative.

    • Marked as answer by mafx Monday, August 8, 2011 12:29 PM
    Monday, August 8, 2011 12:29 PM