none
File Server Resource Manager Service error 8197 RRS feed

  • Question

  • Getting the following error from SRMSVC when a quote threshold is exceeded.
    File Server Resource Manager Service error: Unexpected error. 
    Operation:
       Running command line action.
       Quota threshold reached.
       Processing File Server Resource Manager event
    Context:
       Action type: Command Action
       Account: NT AUTHORITY\LocalSystem
       Executable path: %windir%\system32\dirquota.exe
       Arguments: quota modify /path:[Quota Path] /sourcetemplate:"3GB Home Share Extension"
       Working directory: [Quota Path]
       Quota path: G:\HomeDir\bob
       Threshold percent: 98
    Error-specific details:
       Error: AuthzInitializeContextFromSid, 0x80070005, Access is denied.
    The command is set to run as the Local System, and the SYSTEM account has full access to the G: drive and beyond.
    Let me know if there is anymore information I can provide to maybe help fix this. Thanks!
    Thursday, March 31, 2011 11:53 PM

Answers

  • Have a try on following steps:

    Download psexec from

    http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx

    Used following command to open command prompt with system account :

    psexec -i -d -s cmd.exe

    took the ownership of hidden folder SRM, quota.xml, reportsettings.xml and srmglobalsettings.xml.

    Gave the full rights to system account on the the above mentioned files & folders.

    Detailed steps:

    cd \

    cd "System Volume Information"

    takeown /r /F srm

    Do you want to replace the directory permissions with permissions granting you full control ("Y" for YES, "N" for NO or "C" to CANCEL)? y

    icacls srm /grant system:(F)

    cd srm

    takeown /f quota.xml

    icacls quota.xml /grant System:(F)

    takeown /f settings

    icacls settings /grant system:(F)

    cd settings

    takeown /f reportsettings.xml

    takeown /f srmglobalsettings.xml

    icacls reportsettings.xml /grant System:(F)

    icacls srmglobalsettings.xml /grant System:(F)


    Shaon Shan |TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tngfb@microsoft.com
    Wednesday, April 6, 2011 8:01 AM
    Moderator

All replies

  • Hi,

    Can you please have a look at this KB article? And if possible, you may apply for the hotfix.

    The File Server Resource Manager on a Windows Server 2003 R2-based computer does not send e-mail notifications to the SMTP server
    http://support.microsoft.com/kb/914678

    Event ID 8197 — FSRM Basic Functionality
    http://technet.microsoft.com/en-us/library/cc734434(WS.10).aspx

    Hope it helps.

    Scorpio


    TechNet Software Assurance Managed Newsgroup | MCTS: Windows Vista | Exchange Server 2007 MCITP: Enterprise Support Technician | Server & Enterprise Administrator | Microsoft Infrastructure Consultant | Solution Architect
    Monday, April 4, 2011 3:37 PM
  • Have a try on following steps:

    Download psexec from

    http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx

    Used following command to open command prompt with system account :

    psexec -i -d -s cmd.exe

    took the ownership of hidden folder SRM, quota.xml, reportsettings.xml and srmglobalsettings.xml.

    Gave the full rights to system account on the the above mentioned files & folders.

    Detailed steps:

    cd \

    cd "System Volume Information"

    takeown /r /F srm

    Do you want to replace the directory permissions with permissions granting you full control ("Y" for YES, "N" for NO or "C" to CANCEL)? y

    icacls srm /grant system:(F)

    cd srm

    takeown /f quota.xml

    icacls quota.xml /grant System:(F)

    takeown /f settings

    icacls settings /grant system:(F)

    cd settings

    takeown /f reportsettings.xml

    takeown /f srmglobalsettings.xml

    icacls reportsettings.xml /grant System:(F)

    icacls srmglobalsettings.xml /grant System:(F)


    Shaon Shan |TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tngfb@microsoft.com
    Wednesday, April 6, 2011 8:01 AM
    Moderator
  • Hi Shaon,

    I've tried your instruction, but I had a trouble.

    takeown /f quota.xml 

    When I tried the above command, it says 'there's no such file or folders'.

    It seems there is no 'quota.xml' under 'srm' folder.

     

    Do you have any idea for my trouble?

     

    Thanks.

    Wednesday, May 25, 2011 8:28 AM