none
Windows 8.1 can't communicate with the device or resource (primary dns server) RRS feed

  • Question

  • I am an American living in China so I must use a VPN to access websites restricted by the country's firewall.  If the VPN is not connected, then I cannot get an internet connection even though the Wifi signal indicator says the connection is full strength.  Before I installed the VPN on my laptop I could access non-restricted websites.  So to reiterate, right now I can only access the internet when the VPN is connected.  However, I would like to also have access to the internet when the VPN is disconnected - even if only to non-restricted websites.

    So when the VPN is disconnected I run the diagnostic and I get the messages "Windows can't communicate with the device or resource (primary DNS server)" and "Problem with wireless adaptor or access point".  I have tried the suggestions offered on similar community forum posts but have had no luck.

    Thanks,

    S Nam

    Saturday, July 25, 2015 9:54 AM

Answers

  • hello try this

    right click start - run- type ''ncpa.cpl''  that will take you to control panal/network & internet/network connections

    you should see 2 Ethernet connections your intel and Tap-windows adapter v9 (thats for your vpn), right click Ethernet scroll down click 4 (TCP/IPv4)" or "Internet Protocol (TCP/IP)", click properties

    now make sure OBTAIN AN IP ADDRESS AUTOMATICALLY  is selected for both options, click ok then you should be right, you can also do the same for the other Ethernet2 connection if you like.

    i am guessing your dns address is wrong stuck on your vpn address you can check that also first by

    right click start-command prompt( admin) then type ipconfig/all (in the black box ) it should say something similar to 192.168.1.1 if not it is because of the above issue.

    I am no tech guy just had similar problem so dont ask me any more ? as i wont be here again , please pass this on to where ever you have posted this problem to help out others in need .

    Monday, July 27, 2015 1:05 PM