locked
Sharepoint 2007 unable to use webpart so that users can select a view. (when webpart is put on another page) RRS feed

  • Question

  • I created a hyperlink list in sharepoint 2007, added a column for the hyperlink target type (external / internal / work / other /.../ / / ) 
    When on the page of of the list itself users can filter on the target type, as i made views for each target type. 
    Then i added it as webpart to a wiki page; and then the views are no longer working for the users. 
    I wonder what i do wrong ? 
    For the webpart i enabled a default view 
    I used summery toolbar 
    type Chrome type default 
    Under advanced i only enabled "allow editing in personal view" ---- for the target type i used list as the choice type and the users have contribute rights to the list.
    • Moved by Mike Walsh FIN Wednesday, August 3, 2011 4:16 PM problem with wikis so social computing. Otherwise is would have been admin not general (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Wednesday, August 3, 2011 3:44 PM

All replies

  • HI,

    Use full toolbar in the page where you have added it.

    I hope this will help you out.

    Thanks,

    Rahul Rashu

    Thursday, August 4, 2011 4:21 AM
  • Ok i tried that, but the behaviour doesnt change, other views are not seen they return zero results.

    Thursday, August 4, 2011 7:32 AM
  • Hi,

    So it is showing the views the documents are not being shown in the views?

    Can you check if the documents are published? Are you using the same account at both the places?

    Thanks,

    Rahul Rashu

    Friday, August 5, 2011 5:40 AM
  • The documents (or in this case hyperlinks, since it was based on a link list) were published (not checked out).

    i might  have found a cause, but i'm unsure about it, what do you think about the text below ?

    • On the webpart just above toolbar type, i had choosen a selected view to show a default view to start when opening the page (otherwise one would see all items).
      But this is something i'm not sure about, it doesnt behave like a default view, but that part seams to behave like an administrater filtered view.
      More like all views have to be based on that specific one, after that you cannt change it.
      My view was based on a colomn with multi value chooser type; so it only showed results if they included that administrative filter type also.
    • I'm not sure if that is how it should work,  i removed the selected view to point to one of my defined views.
    • Still i wanted however to show the page with a specific vieuw. So to acomplish that.
      I selected that specific filtered view on that the page it then reloaded and then i copied the URL from the webbrouwser.
      Next pages who had links to this page i changed those  links to this specific URL
      And that worked.

    But it seams a bit odd to do ?? is this realy the way to do such things ?

    Friday, August 5, 2011 12:56 PM