none
Long File Names? RRS feed

  • Question

  • Hi Folks:

       I'm using Windows 10 Pro.  I can't find the version number. 

       I'm having problems getting my Windows 10 system to accept long file names. 

       I've googled, and the sites suggest the following:

           Hit the Windows key, type gpedit.msc and press Enter.
           Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Filesystem > NTFS.
           Double click the Enable NTFS long paths option and enable it.

       When I follow these instructions I don't see anything like "Enable NTFS long paths".

       And...


       I'm not seeing what the site's I've Googled tell me to set.  

       How do I turn on long file names?

          Thanks
          Larry

    Sunday, April 9, 2017 2:46 AM

Answers

  • you are trying to exceed the default limit of 260chars (you have to allow for the full path/filename, not just the filename)

    Thanks Don:

       I understand that. 

       But I have long filenames turned on.  I believe the limit should be 65K characters. 

       I use this to create my backup thumb drives.  In this case the file was created by Boost.  I'd never give a file a name like that. 

         Larry

    The discussions (linked) on superuser suggest that WindowsExplorer didn't support this feature as of August2016, but that robocopy does support the feature. Your earlier example seems to be WindowsExplorer. Have you tried other tools? Maybe your system already *does* support the feature but it's the method/tool you're using that doesn't implement the feature?

    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Marked as answer by a_unique_name Tuesday, April 11, 2017 7:35 AM
    Monday, April 10, 2017 9:52 AM

All replies

  • Hi,

    1. to know Windows version and build: "winver" in "Run"
        
    2. check in registry if "LongPathsEnabled" = 1:
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
        


    Regards,
    Ashidacchi
    Sunday, April 9, 2017 5:45 AM
  • Thanks Ashidacchi:

       That registry entry has been set to 1 before I looked at it tonight. 

       Copying files between BitLocker encrypted drives fails with complaints about a filename being too long. 

       Is there something about either copy and paste or BitLocker that would cause a copy with a long filename to fail?

       I'm unable to <CTL-C> the version message in order to display the text, it just "Dings", so here's the window in order to avoid a typo when entering the number:

          Thanks
          Larry



    Sunday, April 9, 2017 10:49 AM
  • Since windows 10 v1607, the GPO has moved, see https://superuser.com/questions/1119883/windows-10-enable-ntfs-long-paths-policy-option-missing apply that, do a gpupdate and retry.
    Sunday, April 9, 2017 11:18 AM
  • Hi Larry,

    Thank you for the further information.

    According your screenshot, file name (*.html) does not seem to be too long, looks less than 256/260 characters.
    Is there some abbreviation about file name on the pictrure?  If not, it may cause from BitLocker.  

    Could you send the file as an attached file?
    my email address is ash (dot) m314 (at mark) gmail (dot) com.

    Regards,
    Hideki
    • Edited by Ashidacchi Sunday, April 9, 2017 11:37 AM
    Sunday, April 9, 2017 11:20 AM
  • Hi Ronald,

    I've ever read the article that you mentioned.
    And I cannot find the entry "Enable NTFS long paths" as questioner.
    Can you see it?

    Regards,
    Ashidacchi
    Sunday, April 9, 2017 11:25 AM
  • Hi Larry,

    Thank you for the further information.

    According your screenshot, file name (*.html) does not seem to be too long, looks less than 256/260 characters.
    Is there some abbreviation about file name on the pictrure?  If not, it may cause from BitLocker.  

    Could you send the file as an attached file?
    my email address is ash (dot) m314 (at mark) gmail (dot) com.

    Regards,
    Hideki

    Thanks Hideki:

       I'm composing the email right now. 

       It's part of an obsolete Boost release, which I don't need anyway.  This might be useful in an effort to resolve a problem though, so I'll keep it for now. 

       The source directory is:

          D:\utilities\code\boost_1.55.0_old\boost_1_55_0\boost_1_55_0\libs\geometry\doc\html\geometry\reference\spatial_indexes\boost__geometry__index__rtree

       The destination directory is:

          E:\backup\utilities\code\boost_1.55.0_old\boost_1_55_0\boost_1_55_0\libs\geometry\doc\html\geometry\reference\spatial_indexes\boost__geometry__index__rtree

        The file's name is:

        rtree_parameters_type_const____indexable_getter_const____value_equal_const____allocator_type_const___.html

       I have no idea if the name is abbreviated.

       I'll get that mail out, then watch the Chinese Formula One race. 

       I appreciate your attention.

          Thanks
          Larry


    Sunday, April 9, 2017 12:58 PM
  • you are trying to exceed the default limit of 260chars (you have to allow for the full path/filename, not just the filename)

    source:
    D:\utilities\code\boost_1.55.0_old\boost_1_55_0\boost_1_55_0\libs\geometry\doc\html\geometry\reference\spatial_indexes\boost__geometry__index__rtree [=149chars]
    \rtree_parameters_type_const____indexable_getter_const____value_equal_const____allocator_type_const___.html [=108chars]
    added together, 149+108-1=256
    dest:
    E:\backup\utilities\code\boost_1.55.0_old\boost_1_55_0\boost_1_55_0\libs\geometry\doc\html\geometry\reference\spatial_indexes\boost__geometry__index__rtree [=156chars]
    \rtree_parameters_type_const____indexable_getter_const____value_equal_const____allocator_type_const___.html [=108chars]
    added together, 156+108-1=263


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Sunday, April 9, 2017 10:02 PM
  • you are trying to exceed the default limit of 260chars (you have to allow for the full path/filename, not just the filename)

    Thanks Don:

       I understand that. 

       But I have long filenames turned on.  I believe the limit should be 65K characters. 

       I use this to create my backup thumb drives.  In this case the file was created by Boost.  I'd never give a file a name like that. 

         Larry

    Sunday, April 9, 2017 10:52 PM
  • Hi Larry,

    Oh, it is a thumb drive, isn't it ?!
    Please check what file system is using in the thumb drive.
    I guess it would be FAT32 that has a limit of file name of 255 bytes.

    Regards,
    Hideki
    Sunday, April 9, 2017 11:05 PM
  • Thanks Hideki:

       Nice try. :)

       No, everything's NTFS. 

       D: is my work SSD. 

       I copy selected files, mostly C++, from D: to a directory on my E: drive, a rotating hard drive. 

       This directory, which I update with the latest versions of code I write, also has business and personal files, like contracts and photographs.  This directory is the image I copy to my thumb drives. 

       The file's lost when copying from D: to E:. 

       This has been happening for many months.  Always the same file. 

       This particular file isn't critical, but I'd like to get long file names working for future needs. 

       Yesterday I decided to ask for help figuring out the problem. 

       I appreciate your suggestions, I wish it was as easy as having a FAT filesystem. 

          Thanks
          Larry



    Monday, April 10, 2017 12:09 AM
  • Hi Larry,

    This may be my last question.
    How do you copy file(s), by manual (e.g. copy & paste in File Explorer), by using software (e.g. you made or provided by third party), or other way?  

    Regards,
    Hideki
    Monday, April 10, 2017 1:23 AM
  • Hi Larry,

    This may be my last question.
    How do you copy file(s), by manual (e.g. copy & paste in File Explorer), by using software (e.g. you made or provided by third party), or other way? 

    Thanks again Hideki:

       I hope this isn't your last question, I appreciate your efforts.

       I'm using the mouse to select files, or more often directories, in File Explorer by clicking on "Copy" in a menu or <CTL C> and then pasting to a destination. 

       Long filename documentation mentions that it doesn't work with every application.  I'm hoping Microsoft developers are competent enough to use it in basic Windows functions. 

          Thanks
          Larry

    Monday, April 10, 2017 1:42 AM
  • Hi Larry,

    I will send you a sample batch file I used for testing, that make folders and copy file as you provided in your mail.
    Would you run it, after modifying it according to your environment (especially Drive).

    Regards,
    Hideki
    Monday, April 10, 2017 1:48 AM
  • Ashidacchi, yes, I can see it under its new name at the new location just as described in my link: 

    Local Computer Policy > Computer Configuration > Administrative Templates > System > Filesystem

    Enable Win32 Long Paths

    Monday, April 10, 2017 6:22 AM
  • Hi Ronald,
    Thanks a lot.  I could find and enable it.

    Hi Larry,
    Please enable it and check whether your copy-operation will  work fine. 
    If it's OK, our long path is over.


    Regards,
    Ashidacchi
    Monday, April 10, 2017 6:38 AM
  • you are trying to exceed the default limit of 260chars (you have to allow for the full path/filename, not just the filename)

    Thanks Don:

       I understand that. 

       But I have long filenames turned on.  I believe the limit should be 65K characters. 

       I use this to create my backup thumb drives.  In this case the file was created by Boost.  I'd never give a file a name like that. 

         Larry

    The discussions (linked) on superuser suggest that WindowsExplorer didn't support this feature as of August2016, but that robocopy does support the feature. Your earlier example seems to be WindowsExplorer. Have you tried other tools? Maybe your system already *does* support the feature but it's the method/tool you're using that doesn't implement the feature?

    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Marked as answer by a_unique_name Tuesday, April 11, 2017 7:35 AM
    Monday, April 10, 2017 9:52 AM
  • Thanks Don:

       That works.

       Properties for the two folders, selected from File Explorer, showed different sizes and file counts.

       Running dir /a/s showed both files had the same size and file counts.

       Robocopy is SLOW!  It turned a 1/2 hour job into a 1 1/2 hour job.

       Is there any reason File Explorer doesn't handle long file names?

       I appreciate everybody's suggestions.

          Larry

    Tuesday, April 11, 2017 7:35 AM
  •    Is there any reason File Explorer doesn't handle long file names?

    from the linked SU discussion:

    Andre: "I've asked Microsoft employee Gov Maharaj and the feature is not ready to be enabled for Windows Explorer. So you still have the issue with Explorer. You have to wait until Microsoft enables it for Explorer or use a 3rd party file management tool which is compatible with the long paths and has the setting set in its manifest file."


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Tuesday, April 11, 2017 9:11 PM
  • Hi Larry,

    I'd like to confirm and ask:
    Has your issue been resolved already?
    If so, how did you succeed, what did you do?
    ____________
    Hideki
    Wednesday, April 12, 2017 3:20 AM
  • Thanks Hideki:

       Yea, Don's suggestion to use Robocopy works. 

       It's painfully slow, about 1/3rd as fast as File Explorer. 

       I haven't experimented much, but with only the default "/mir" option it displayed the names of each of the several hundred thousand files in the command line window. 

       Their might be an option to copy the files silently, which might speed it up. 

       My immediate needs can be handled by File Explorer, there was only that single Boost file that had a problem.  But I have another project planned that will run into this same problem. 

       I'm curious about what's delaying long file names in File Explorer.  Any idea when they will be supported?

          Thanks again
          Larry

      

    Wednesday, April 12, 2017 10:21 AM
  • Thanks Larry:

    I can understand that, your resolution is using RoboCopy.
    And one question occurs on me.  I could copy long name (folder/file, you indicated before) both with File Explorer and batch file [Windows 10 64-bit, Creators Update].
    _______________
    Hideki Ashida
    Wednesday, April 12, 2017 10:36 AM
  • I would like to suggest you, try LongPathTool program to resolve this issue. This tool is very helpful to resolve the issue.

    Sunday, May 20, 2018 11:47 AM
  • Thanks Ashidacchi:

       That registry entry has been set to 1 before I looked at it tonight. 

       Copying files between BitLocker encrypted drives fails with complaints about a filename being too long. 

       Is there something about either copy and paste or BitLocker that would cause a copy with a long filename to fail?

       I'm unable to <CTL-C> the version message in order to display the text, it just "Dings", so here's the window in order to avoid a typo when entering the number:

          Thanks
          Larry



    I confirm.  This issues exists on bitlocker drives; as on latest Win 10 update.  I guess bitlocker needs to be updated to accept longer path names - either a hard limit / they use win32 api / something else

    Sunday, October 21, 2018 12:04 PM