none
Print Spooling very very slow to a network printer

    Question

  • OS - Windows 7 Profession x64

    Client PC attached to a Domain

    Printer: HP CM1312nfi

    Printer Port:  Networked Printer

    Printer Driver obtained from HP website (Full software)

    Problem Description:

    When printing a large image say 30MB .jpg to the printer, it's queuing up kilo bytes at a time

    vs. mega bytes at a time.  So printing takes 15-20 minutes.

    Same file on Vista machine takes 1 to 2 minutes to print.

    Tried to stop/start the print spooler - no luck

    Have latest patches for Win 7

    Tried with both user with "User" Privileges and user with "Administrator" privileges.

    User Access Control is OFF

    Any Ideas?

    Thanks.

    PS.  Reinstalled the driver twice already.

    Tuesday, July 27, 2010 10:03 PM

Answers

  • Hi,

     

    If the printer driver you installed is not the latest version, I would like to suggest you reinstall the latest version of the driver and the firmware from HP website.

     

    Note: The third-party products discussed here are manufactured by companies that are independent of Microsoft. We make no warranty, implied or otherwise, regarding these products' performance or reliability.

     

    After that, I also would like to suggest you perform the following troubleshooting suggestions:

     

    Clear Printer Spooler Files and Enable the Spooler Service

    =================================

    1. Click Start, type "Services.msc" (without the quotation marks) in the Start Search box and press Enter.

    2. Double-click "Printer Spooler" in the Services list.

    3. Click Stop and click OK.

    4. Click Start, type "%WINDIR%\system32\spool\printers" in the Start Search box and press Enter, delete all files in this folder.

    5. Click Start, type "Services.msc" (without the quotation marks) in the Start Search box and press Enter.

    6. Double-click "Printer Spooler" in the Services list.

    7. Click on Start. In the Startup Type list, make sure that "Automatic" is selected and click OK.

     

    Does it work?

     

    Regards,

     

    Arthur Li

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 28, 2010 5:34 AM
    Moderator

All replies

  • Hi,

     

    If the printer driver you installed is not the latest version, I would like to suggest you reinstall the latest version of the driver and the firmware from HP website.

     

    Note: The third-party products discussed here are manufactured by companies that are independent of Microsoft. We make no warranty, implied or otherwise, regarding these products' performance or reliability.

     

    After that, I also would like to suggest you perform the following troubleshooting suggestions:

     

    Clear Printer Spooler Files and Enable the Spooler Service

    =================================

    1. Click Start, type "Services.msc" (without the quotation marks) in the Start Search box and press Enter.

    2. Double-click "Printer Spooler" in the Services list.

    3. Click Stop and click OK.

    4. Click Start, type "%WINDIR%\system32\spool\printers" in the Start Search box and press Enter, delete all files in this folder.

    5. Click Start, type "Services.msc" (without the quotation marks) in the Start Search box and press Enter.

    6. Double-click "Printer Spooler" in the Services list.

    7. Click on Start. In the Startup Type list, make sure that "Automatic" is selected and click OK.

     

    Does it work?

     

    Regards,

     

    Arthur Li

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 28, 2010 5:34 AM
    Moderator
  • Hi,

     

    I would like to confirm what is the current situation? If there is anything that I can do for you, please do not hesitate to let me know, and I will be happy to help.

     

    Regards,

     

    Arthur Li

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 2, 2010 1:55 AM
    Moderator
  • Hi,

     

    It has been a while since my previous suggestions was posted and I'm writing to find out if you have had an opportunity to test my suggestions yet. If you need my further assistance, please do not hesitate to let me know, and I will be happy to help.

     

    I look forward to your reply.

     

    Regards,

     

    Arthur Li

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, August 4, 2010 1:26 AM
    Moderator
  • HI.. cant believe i have the same problem also..

    i have been working in this company for 3 years, 30 over PC i handle.

    lots of problem have been solved. but only this i feel really annoying.

    some computer suddenly start taking long time to print a job. it takes 

    about 1 min to 3 min to transfer files . things i have done are:

    -direct print instead of spooling.

    -off spool service and delete printer in system32

    -re install driver.

    -format PC (it was fine for 1-2month)

    -change network 

    i thought it was something to do with the OS update. but my office using xp win7 win8. only xp and 

    win7 have this problem. now im sharing my printer with them , issue ignored.


    • Edited by JasonChiew Thursday, December 19, 2013 9:42 AM
    Thursday, December 19, 2013 9:41 AM
  • HI JasonChiew

    We have same problem, mostley with color printer. Would be intresting to here if someone have found an solution on this.

     

    Monday, March 31, 2014 5:30 AM
  • Good Afternoon Arthur,

    I see that you haven't heard back from the original poster.

    I am having the exact same issue as the original poster and have tried all of your recommended steps, and applied the Windows hotfix and all Windows updates, but am still having the issue. Do you have any other suggestions?

    We only have this issue with Windows 7 machines. Our Windows XP machines have no delay when printing the same large packages.

    Problem Description:

    When printing a large image say 30MB .jpg to the printer, it's queuing up kilo bytes at a time

    vs. mega bytes at a time. So printing takes 15-20 minutes.

    Same file on XP machine takes 1 to 2 minutes to print.

    Any help would be greatly appreciated!

    Tuesday, April 22, 2014 3:53 PM
  • We have many XP machines all printing to the same printers.  Win7 machine is only one printing slow.  Do not use the spooler, printing directly to network.  It's not the firewall or anti-virus.  Netsh tcp settings adjustment helped, but still slow.  Opening a VM of XP inside the same win7 machine.. prints fast.  This is a big problem.  Maybe I will keep the rest of company on XP VM's instead of upgrading.
    Thursday, June 5, 2014 1:58 PM
  • One way I found around this was to add the printer as a local printer pointing to the port - as opposed to connecting to it mapping across the server. As soon as I did that, print speed was normal.
    • Proposed as answer by nondesolator Monday, February 16, 2015 1:29 PM
    Monday, July 14, 2014 11:43 AM
  • This is worked for me, thank you!
    Monday, February 16, 2015 1:29 PM
  • Hi Arthur Li,

    It worked for me, we are having several network printer installed on Terminal Server and all clients sending print to them. This solution solved our printers latenes.

    Thank you

    Monday, March 16, 2015 5:45 AM
  • One way I found around this was to add the printer as a local printer pointing to the port - as opposed to connecting to it mapping across the server. As soon as I did that, print speed was normal.

    This solution worked for me in a mixed environment of windows 10 and Windows 7. Thanks for the suggestion.
    Monday, January 4, 2016 6:12 PM
  • I have close to the same issue:

    workstations are win 7 x64

    print queue is on brand new server 2012 R2. when printing from old server 2003 all workstations printed fine. now that we have replaced the 2003 server with a 2012 R2 server the documents they are trying to print, (no matter small or large files), spool to the server fine. then it takes up to 2 or 3 minutes before the server finally sends the print job to the printer. Any type of file, browser page, outlook email, notepad, word. they all are taking 2 or 3 minutes to print to a network print queue on the 2012 R2 server.

    Thursday, January 14, 2016 2:35 PM
  • Hi , I had similar problem with printing word documents and this is what helped me : 

    https://h30434.www3.hp.com/t5/Inkjet-Printing/SOLVED-Print-Word-Documents-are-slow-very-slow/td-p/317060

    Monday, November 28, 2016 9:25 AM
  • I know this is years later, but still a problem.  Big note here, bypassing the problem is not a fix.  I too have been adding local printers ports to "get around" the problem, but still no solution!

    Thursday, March 23, 2017 12:47 PM
  • Solved?  You mean nice workaround?  Not a solution.  A solution would make networked printers work again.
    Thursday, March 23, 2017 12:48 PM
  • Thank you very much! This works for me! :)
    Friday, October 6, 2017 8:20 AM