locked
Have there recently been Vista autoupdates that would have affected the UAC. RRS feed

  • Question

  •  

    Hi,

    Firsly I am not a guru when it comes to Vista and the UAC, having said that I would like to keep it

    on as I suspect its a good thing.

     

    I run a Toshiba P100 OS Vista Home Premium. My Account is an Administrator Account (I have my doubts)

    The issue. Until recently I had no problem making changes within my Tomcat webapps directory.

    then yesterday when I tried to add a new directory I found that I was no longer able to do so, Even though the

    system prompted me to run as administrator, which I accepted.

     

    After some research I was able to disable the UAC which allowed me to full access as one would expect, and this

    got me out of trouble.

     

    Further checks reveled that even though I am the logged in as an administrator I have no administrator

    privelleges ie: Contol Panel >User Accounts>Modify Account Type .... I just observe a system click sound

    but no action / progress.

     

    I have read Answer Re: Real UAC Nightmare! / Huge UAC Problems! but I am a little unprepared to make these

    recomended changes without understanding the problem.

     

    Any help would be greatly appreciated. 

    Sunday, March 23, 2008 7:22 AM

Answers

  • Hi Hans,

    I'd like to suggest you boot into Safet mode and check whether you can modify your account type.

    1. Reboot the computer.
    2. When the Starting Windows screen shows, press F8.
    3. Select Safe Mode with Networking and press Enter.
    4. Log on as Administrator.
    5. Does this issue occur in Safe Mode?

    (NOTE: Safe Mode loads the minimum number of required basic device drivers and system services to start the system. Programs located in the Startup Program group are not started.  So this will be very helpful for us to narrow down the root cause.)
    --------------------
    Regards,
    Eric Zhang



    Wednesday, March 26, 2008 9:52 AM

All replies

  • Hi Hans,

    I'd like to suggest you boot into Safet mode and check whether you can modify your account type.

    1. Reboot the computer.
    2. When the Starting Windows screen shows, press F8.
    3. Select Safe Mode with Networking and press Enter.
    4. Log on as Administrator.
    5. Does this issue occur in Safe Mode?

    (NOTE: Safe Mode loads the minimum number of required basic device drivers and system services to start the system. Programs located in the Startup Program group are not started.  So this will be very helpful for us to narrow down the root cause.)
    --------------------
    Regards,
    Eric Zhang



    Wednesday, March 26, 2008 9:52 AM
  • Hi Eric,

     

    Firstly thanks for taking the time.

     

    I have followed your instructions, and when booting up in Safe Mode with Networking and logging on as Administrator the issue does no longer occur.

     

    When you refer to Startup Program group, are you refering to the AutoStart items?

     

    If the answer to the previous questions is no, where is the Startup Program group located on the system? this may seem a lame question,but my ver. of Vista is German complicating search at times. I have attemted to find the mentioned Startup Program group, with no success, knowing where on a system it would reside would enable me to narrow the search.

     

    Regards,

    Hans

    Saturday, March 29, 2008 12:39 AM
  • Hi Hans,

    Run "msconfig", in the prompt window, click "start up" tab which you will find startup program.

    --------------------
    Regards,
    Eric Zhang



    Monday, March 31, 2008 10:16 AM
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios.

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    In addition, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

    Thanks!
    --------------------
    Regards,
    Eric Zhang

    Thursday, April 3, 2008 9:58 AM
  •  

    Hi Eric,

     

    Sorry for the delay, got tied up on other issues.

     

    The problem still persists, as previously mentioned, after following your advise
    it was determined that when starting up in save mode the problem does not exist.

     

    And this is basically where it is at. The problem still exists.

     

    I have had a look through the startup tab in msconfig but to be honest could not relate any items

    that would cause problems with the UAC.

     

    As previously mentioned turning off the UAC via msconfig >tools has the same effect as starting in safe mode.

     

    regards,

     

    Hans

    Sunday, April 6, 2008 8:00 AM
  • Hi Hans.

    Please run "gpedit.msc" on your Vista computer, navigate to "Computer configuration" - "Windows Settings" - "Security settings" - “Local Policies" - "Security Options", check the UAC related setting.

    --------------------
    Regards,
    Eric Zhang



    Monday, April 7, 2008 10:20 AM
  • Hi Eric,

     

    I am unable to run gpedit.msc , I did a search for the file on my computer and did not return a result, it is as though it doesn´t exist. I also tried from the command prompt in system32, but nothing.

     

    bare in mind my OS in in German, but I tried to follow your instruction guessing the English equivilant :

    SystemSteuerung(ControlPanel)>Verwaltung(Administration)>SystemConfiguration(SystemConfiguration)

    this sequence has the same result as running msconfig and presents the following tabs: Algemein(General)-Start(Start)Dienste(Services)-Systemstart(Systemstart)-Tools(Tools) and within the tools tab there is the option to turn the UAC on/off. As mentioned, when I turn UAC off I again have full access to the directories.

     

    *()= translation German(English).

     

    regards

     

    Hans

    Wednesday, April 9, 2008 10:45 AM