locked
Username is Saved on OWA Page RRS feed

  • Question

  • Hi,

    When a user logs into OWA, the username is saved on the form after they logout. Is there any way to stop the OWA Login page from retaining the username of the user who previously logged on?

    Thanks

    Thursday, May 22, 2014 4:17 PM

Answers

  • Hi,

    When a user logs into OWA, the username is saved on the form after they logout. Is there any way to stop the OWA Login page from retaining the username of the user who previously logged on?

    Thanks

    Hi,
    The username will not be saved if the user choose to log on with the "public computer" option (not visible by default).

    I have managed to configure that to be the default setting... Might be something for you too. See this


    Martina Miskovic

    • Proposed as answer by Amit Tank Wednesday, May 28, 2014 12:27 PM
    • Marked as answer by Methodman85 Friday, May 30, 2014 2:12 AM
    Wednesday, May 28, 2014 4:43 AM

All replies

  • OWA doesn't do that, it must be Internet Explorer history that you need to clear out.

    How to Remove a Username From Internet Explorer

    It would ask you when you login on the OWA after clearing out history to save user id or not, say no there...


    Blog: http://exchangeshare.wordpress.com/

    Thursday, May 22, 2014 6:26 PM
  • Hi Amit,

    Are you absolutely sure on this?

    If I open up a new browser session on a system I have never accessed OWA from before.

    I'm presented with blank username and password fields.

    I then enter my login credentials and click sign in. I am not presented with any options to save anything.

    I sign out.

    The username field is populated with the account I just signed in with.

    If I close the browser and start it again, the user field is pre-populated with the same username I had just logged in with.

    Are you saying the behavior is different for you?

    Thursday, May 22, 2014 6:48 PM
  • No it's same but it should be because by default Internet Explorer has Autocomplete setting is enabled.

    Blog | Get your Exchange Powershell Tip of the Day from here http://exchangeshare.wordpress.com/</a>

    Thursday, May 22, 2014 11:35 PM
  • Firefox and Chrome do the same thing?

    It has to be something to do with the Forms page. This isn't autocomplete. It's PRE populated. Autocomplete should appear when I start typing shouldn't it?

    When I go to my Yahoo mail for instance, this does not happen. My UserID field remains blank after I sign out and return to the login page.

    Thursday, May 22, 2014 11:56 PM
  • It has to be a browser setting, as mine works perfectly fine.

    What if you try it on a different machine, maybe a work machine or another laptop? Or try on one of your colleague's machine at work.


    TheUCGuy.Net

    Friday, May 23, 2014 8:56 AM
  • It has to be a browser setting, as mine works perfectly fine.

    What if you try it on a different machine, maybe a work machine or another laptop? Or try on one of your colleague's machine at work.


    TheUCGuy.Net

    What is your OWA login set to? Are you using username only? Or domain\username?

    I've tried on many different systems. Domain systems and non domain external systems, and the result is the same.

    This did not happen with OWA 2010, I've only noticed it with OWA 2013.

    Amit says he sees the same behavior, so something must be different on your end.

    Friday, May 23, 2014 10:38 AM
  • Hi Methodman85,

    How about the problem now?

    I suggest login your OWA via other computer for test.

    If on other computer, the user name doesn't been saved, it seems the issue on the Explorer.

    Please delete the credentials on your computer. More details in the following article:

    Remove stored passwords, certificates, and other credentials

    http://windows.microsoft.com/en-HK/windows7/remove-stored-passwords-certificates-and-other-credentials

     

    Feel free to contact me if there is any problem.

     

    Thanks

    Mavis

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Mavis Huang
    TechNet Community Support


    • Edited by Mavis_Huang Wednesday, May 28, 2014 2:07 AM
    Wednesday, May 28, 2014 2:06 AM
  • Hi,

    When a user logs into OWA, the username is saved on the form after they logout. Is there any way to stop the OWA Login page from retaining the username of the user who previously logged on?

    Thanks

    Hi,
    The username will not be saved if the user choose to log on with the "public computer" option (not visible by default).

    I have managed to configure that to be the default setting... Might be something for you too. See this


    Martina Miskovic

    • Proposed as answer by Amit Tank Wednesday, May 28, 2014 12:27 PM
    • Marked as answer by Methodman85 Friday, May 30, 2014 2:12 AM
    Wednesday, May 28, 2014 4:43 AM
  • Hi Methodman85,

    Great information from Martina.

    I am just writing to see  if you have obtained the opportunity to test the solution.

    If anything is unclear with the previous information I've provided to you, please don't hesitate to let me know.

    I am glad to be of assistance.

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support


    Friday, May 30, 2014 1:50 AM
  • Hi,

    When a user logs into OWA, the username is saved on the form after they logout. Is there any way to stop the OWA Login page from retaining the username of the user who previously logged on?

    Thanks

    Hi,
    The username will not be saved if the user choose to log on with the "public computer" option (not visible by default).

    I have managed to configure that to be the default setting... Might be something for you too. See this


    Martina Miskovic

    This is absolutely correct. I don't see why people are convinced it is an IE/Browser issue. If "Public" is used, the username field is not saved.

    Now all I need to do is make public the default (which I have done) and hide the private option from the logon.aspx page.

    Friday, May 30, 2014 2:11 AM