locked
Problem with allowing websites using SteadyState 2.5 RRS feed

  • Question

  • Have everything up and running but for my user when I check "Prevent Internet Access (Accept websites below)" and then put the allowed websites in the line below the user can't go anywhere on the internet.  The page returned is "Internet Explorer can not display the webpage"  Also when this option is checked typing an address returns a funny result about half the time.  Typing msn.com resolves ashttp:///?%20msn.com  Now if I uncheck this "Prevent Internet Access" option then everything works normally including typing just msn.com and having it resolve tohttp://www.msn.com

    Can anyone give me some guideance as to what might be happening here?

    Thursday, April 15, 2010 2:34 PM

All replies

  • Rider,

        I get a bit confused with this one since I don't use IE's filtering mechanism with SteadyState, but IIRC, I think the Exceptions list shouldn't contain any "http" prefix. In other words, don't put http://www.msn.com, just put msn.com. Try that, but I am only 50% sure. Sean has a few threads he gives regarding this issue, try doing a search for allowed websites or similar terms, you should be  able to find it.


    Sorry I couldn't have been more helpful,

     

    Philip


    Complexity is the enemy of Security -- Steve Gibson
    Thursday, April 15, 2010 5:47 PM
  • Yes you are correct that the "http" portion shouldn't be there in fact SteadyState won't let you go on if they are so unfortunately that isn't it.  I've also tried putting inwww.msn.com and msn.com with no luck.  I've also searched this group several times and can't find anything that helps.  Does anyone have this working ?
    Thursday, April 15, 2010 6:40 PM
  • Web site restriction is done by setting the proxy server.  If another application changes the proxy server, or enables automatic proxy server detection, it will remove the proxy set by SteadyState. 

    Take a look at Control Panel > Internet Options, click the Connections tab, then click the LAN Settings button.  When web site restriction is enabled, the proxy server should be set to "NoInternetAccess".  If you've allowed any web addresses, you can click the Advanced button to see them.  The important thing here is that neither "Automatically detect settings" nor "use automatic configuration script" should be selected.

    If your network uses a firewall/proxy like ISA Server, note that the firewall client service that's installed on each computer on the network will automatically configure these proxy settings at startup, thereby overwriting or circumventing SteadyState's changes. 


    Sean Zhu - MSFT
    Friday, April 16, 2010 5:41 AM
  • I've got the same problem. I don't use any "http" prefix, and I don't use a Proxy.

    I've recreated the user but I've got the same problem

    Saturday, April 17, 2010 2:40 PM
  • Sean,

    I have a bit different issue with allowing Internet Access in Steady...

    1. Prevent Internet access (exept Web sites below) - checked.

    2. Home page - blanc.

    3. When add one website: xyz.com it works fine.

    When trying to add a second address after semicolon in form uvw.com

    I get: " The address enterd is not valid. Please type a different address that does not begin with either http:// or https:// ".

    Proxy disabled... Why this error is generated? I need to enable two addresses only.

    What to check?

    Thx.

    Michael.

     


    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis
    • Edited by pob579 Monday, April 19, 2010 3:23 PM typo
    Monday, April 19, 2010 1:47 PM
  • I've checked the settings and the proxy isn't set when I turn this option on from SteadyState.  As far as I can tell the proxy isn't being used at all and I know I'm not using one on the network.  Any other ideas?
    Monday, April 19, 2010 2:46 PM
  • I came across this problem and managed to come out a workaround. Please enjoy.

    My laptop client is running on Vista. I have already installed SteadyState2.5. I do not need proxy server to access Internet.

    My objective is to allow User1 to access http://www.google.com only. Below are the steps:

    1) Login using User1. At the Internet Explorer Internet Options, Check "Using Proxy Server". Proxy Server can be set to "CannotAccessInternet". 

    2) At the Exception page, put *.google.com into the textbox. This means that accessing www.google.com is using without proxy server.

    3) Login using Administrator. Configure User1 to lock down. Please remember to not enable Only Allow certain website to access. I believe this feature has bugs.

     

    Thanks.

    Wednesday, January 12, 2011 11:20 AM