locked
Backup App-V cache RRS feed

  • Question

  • Hi,

    Has anyone ever tried to backup and restore the App-V local cache?

    I have tried copying the cache (C:\ProgramData\Microsoft\Application Virtualization Client\SoftGrid Client) to a USB thumb drive, reinstalling the computer and then restoring the cache, so that users are able to use their machines again without waiting for the packages to deploy.

    The challenge is how to restore the shortcuts and the file type associations without the .sft file being in the SCCM cache. I seem to need the path to the .sft file for the overrideurl switch.

    SFTMIME ADD PACKAGE:READER /MANIFEST "manifest.xml" /overrideurl "C:\Windows\SysWOW64\CCM\Cache\CO1000B8.1.xxx\CO1000B8.sft"

    If I copy the .xml file and run these commands then I can get the file associations and the shortcut (with wrong icon)
    SFTMIME ADD PACKAGE:READER /MANIFEST "c:\data\AR_934_R1_manifest.xml"
    SFTMIME PUBLISH PACKAGE:READER /MANIFEST "c:\data\AR_934_R1_manifest.xml" /GLOBAL

    but get "checking for updates" when I start the application followed by error "0A-10000002"

    Does anyone know what SFTMIME commands that I could use to register the application using either the .xml or .osd file?
    Or what parts of the registry I could backup/restore to make the application work again?

     

    Monday, October 11, 2010 7:23 AM

Answers

  • Hello,

    Yeah, I would probably revisit SCCM and see what you can do to speed up the delivery process instead of trying to make the backup work.

    You obviously noted quite a few problems and thats probably due to the fact that the cache-file is not the same as enabling the application (it really only contains binary pieces...)

    /Znack

    Monday, October 11, 2010 1:48 PM

All replies

  • Hello,

    Yeah, I would probably revisit SCCM and see what you can do to speed up the delivery process instead of trying to make the backup work.

    You obviously noted quite a few problems and thats probably due to the fact that the cache-file is not the same as enabling the application (it really only contains binary pieces...)

    /Znack

    Monday, October 11, 2010 1:48 PM
  • The only way I could find to make this work was to download the .sft file to the SCCM cache and add the path to the .sft file to OverrideURL under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\SoftGrid\4.5\Client\Packages\{GUID}

    So it looks like the import needs to have the .sft available to make this work :-(   Its time to read up on branch distribution points

    Wednesday, October 13, 2010 8:06 AM