locked
Slow Mailbox Moves RRS feed

  • Question

  • Sorry for posting this in Exchange 2013, but the form doesn't give me an option for 2010.

    I've read the other posts here about modifying the RPC Client Access Server to help speed up move times on the same server. But I wonder what the impact of doing so would be. I have an Exchange 2010 DAG with two servers. I want to move mailboxes from one database to another that are mounted on the same server. If I change the RPC Client Access Server using Set-MailboxDatabase -RPCClientAccessServer "<Active CAS>" will that break or cause issues with normal Exchange operations?

    I want to move the mailboxes quickly, but I don't want to impact users. Can I do this safely?

    Monday, December 8, 2014 10:42 PM

Answers

  • You need to modify the Mailbox Replication Service limits to allow for more concurrent moves. What limits you set you need to decide for yourself based on disk performance. You need to modify the file where the limits are set on all your client access servers. I'd advise raising the limit, testing the difference, and adjusting up and down from there striking a balance of speed against impact to live users. Remember you'll need to control the increase in logs by running ad-hoc backups to truncate them. See this link: http://technet.microsoft.com/en-gb/library/ff963524%28v=exchg.141%29.aspx

    CRM Advisor

    • Proposed as answer by Peter Moys Saturday, December 13, 2014 11:10 PM
    • Marked as answer by mcrumlich Monday, December 15, 2014 2:48 PM
    Monday, December 8, 2014 10:59 PM

All replies

  • You need to modify the Mailbox Replication Service limits to allow for more concurrent moves. What limits you set you need to decide for yourself based on disk performance. You need to modify the file where the limits are set on all your client access servers. I'd advise raising the limit, testing the difference, and adjusting up and down from there striking a balance of speed against impact to live users. Remember you'll need to control the increase in logs by running ad-hoc backups to truncate them. See this link: http://technet.microsoft.com/en-gb/library/ff963524%28v=exchg.141%29.aspx

    CRM Advisor

    • Proposed as answer by Peter Moys Saturday, December 13, 2014 11:10 PM
    • Marked as answer by mcrumlich Monday, December 15, 2014 2:48 PM
    Monday, December 8, 2014 10:59 PM
  • I've already upped the Mailbox Replication Service limit to 5 from 2, for both the source and target. Even after the restart of the CAS replication service, I didn't notice a difference. =( I plan to run a backup tonight, I was hoping to get a larger number of moves done prior to the backup.

    Is there anything else I can do?

    Monday, December 8, 2014 11:04 PM
  • Specifically which attributes did you alter? You need to consider source and target DB as well as source and target for server. Consider the underlying storage as well. You may be at the limit of your disks.

    CRM Advisor

    Monday, December 8, 2014 11:11 PM
  • I modified MaxActiveMovesPerSourceMDB and MaxActiveMovesPerTargetMDB to 5, 0, 100. MaxActiveMovesPerSourceServer and MaxActiveMovesPerTargetServer were already at 50, 0, 1000 and 5, 0, 1000. I don't think my storage is being maxed, but I can verify that.
    Tuesday, December 9, 2014 12:06 AM
  • From the way you're describing the attributes, it sounds like you modified the wrong part of the file.  The attributes for MRS are right at the bottom if I remember correctly.  It looks like you altered the commented part with the valid ranges above that.  They should be single values.

    CRM Advisor

    Tuesday, December 9, 2014 7:36 AM
  • Yep. That's exactly what I did, wasn't paying attention. Let me modify the proper value and see if that makes any difference.
    Tuesday, December 9, 2014 3:43 PM
  • So it made some improvement, but not a huge amount. It takes about 10min to move a ~200mb mailbox. Still very slow. Are their any other options/methods to increase the speed? I checked my storage disks, they are not being taxed. RAM usage on the Exchange server is high, but that's normal. CPU is is not being taxed.
    Tuesday, December 9, 2014 4:47 PM
  • Not really...you would notice better speed with larger mailboxes.  I can't remember the last time I saw a mailbox so small. If they are all of a similar size, I'd recommend raising the number of concurrent moves further. It should take more or less the same amount of time to move a 200MB mailbox, but you'll be doing more of them at the same time.

    Let us know how you get on.


    CRM Advisor

    Tuesday, December 9, 2014 5:08 PM
  • I have moved tens of thousands of mailboxes in a WAN environment (200,000 mailbox configuration).

    The changes need to be installed on all of your CAS server role configurations and all of those servers have to have the MSExchangeMailboxReplication service restarted AFTER the new MSExchangeMailboxReplications.exe.config file is updated.

    MaxActiveMovesPerSourceMDB = "24"

    MaxActiveMovesPerTargetMDB = "16"

    MaxActiveMovesPerSourceServer = "330"

    MaxActiveMovesPerTargetServer = "220"

    MaxTotalMovesPerMRS = "330"

    Moved 10 to 20 thousand users overnight (10GB network backbone)

    Tuesday, December 9, 2014 5:14 PM
  • I run email archive software that links and moves messages once a user reaches the set threshold. It's still readable to the user through Outlook, but moves the message out of Exchange keeping the mailbox sizes small. I'll increase the concurrent moves and see if that helps. 
    Tuesday, December 9, 2014 5:16 PM