locked
Default proofing language won't stay as default RRS feed

  • Question

  • Hi all.

    I'm using Word 2010, and I'm having trouble with the default proofing language.  I need it set to UK English, and it works . . . most of the time.

    Here's what I've done so far:

    Options --> Proofing --> dictionary language set to UK English.

    Options --> Language --> editing language set to UK English.

    Here's the problem: some words are still being underlined in red as misspelled when they are not.  For example, "Programme" is being underlined even  though it is being used correctly. When I right click on it to select the proofing language, UK English and US English are both listed, but the US English option is checked off. It is infuriating.

    The document is a collection of several other documents that I have cut and pasted from.  It seems the pieces I have pasted in to this document refuse to change their default proofing language no matter how many times I change it for the document as a whole.  I'm guessing this is what's going on because in the parts of the document that I created first, the word "Programme" is left alone (correctly) because that part of the document seems to be using UK English as the proofing language. 

    In essence, I seem to have two different proofing languages going on in the same document. Is there anyway to fix this? This error is driving me nuts.

    Thanks for any help!


    Friday, October 18, 2013 3:10 PM

Answers

  • In the Language dialog box (Review tab | Language | Set Proofing Language), clear the "Detect language automatically" option; this prevents Word from changing the language at the insertion point.

    To fix the problem once it has occurred, select the text and manually apply the correct language (using that same dialog box).


    Stefan Blom, Microsoft Word MVP

    • Marked as answer by tysixtus Monday, October 21, 2013 3:57 PM
    Friday, October 18, 2013 9:50 PM

All replies

  • In the Language dialog box (Review tab | Language | Set Proofing Language), clear the "Detect language automatically" option; this prevents Word from changing the language at the insertion point.

    To fix the problem once it has occurred, select the text and manually apply the correct language (using that same dialog box).


    Stefan Blom, Microsoft Word MVP

    • Marked as answer by tysixtus Monday, October 21, 2013 3:57 PM
    Friday, October 18, 2013 9:50 PM
  • That did the trick.  Thanks!
    Monday, October 21, 2013 3:57 PM
  • This is not working for me in word 2010 for the PC.   Every time I open a new document, the proofing language is stuck as Swedish.  In fact, when I set styles to default (Times New Roman 12 instead of Calibri 11) they are lost as well when I open a new document.

    Does this have something to do with the way it's installed, or that I am using a network version of Word?

    Tuesday, June 16, 2015 12:09 PM
  • This is not working for me in word 2010 for the PC.   Every time I open a new document, the proofing language is stuck as Swedish.  In fact, when I set styles to default (Times New Roman 12 instead of Calibri 11) they are lost as well when I open a new document.

       

    Since you are losing all of your defaults, something is preventing you from saving the Normal template. As a workaround, do the following:

    From within Word, press Alt+F11 to display the Visual Basic Editor. Press Ctrl+G to activate the Immediate window. Type

    NormalTemplate.OpenAsDocument

    and press Enter. Normal opens in a separate window (you'll see the filename on the title bar). Change the defaults as desired. Save and close Normal. Restart Word.


    Stefan Blom, Microsoft Word MVP

    Tuesday, June 16, 2015 2:22 PM
  • This is not working for me in word 2010 for the PC.   Every time I open a new document, the proofing language is stuck as Swedish.  In fact, when I set styles to default (Times New Roman 12 instead of Calibri 11) they are lost as well when I open a new document.

    Does this have something to do with the way it's installed, or that I am using a network version of Word?

    Network version of Word? Is your normal.dotm template by chance on your network and changes blocked or the template rewritten on a regular basis by the network? The normal template should NOT be shared. Try, under File > Options > Advanced > File Locations (toward the end) to set your templates location to a folder on your computer.

    The proofing language is like a font attribute (Bold or Italic) in that it can be set in a single character. It is not, generally, an application or document setting.

    Proofing language can be set in Styles. This latter point can make it look like the changes are not sticking. You need to go through your styles and modify them to have the correct settings. Also, make sure that "detect language automatically" is not turned on.

    Mastering the Spelling Checker

    See also: Add-Ins in Microsoft Word


    Charles Kenyon Madison, WI



    Tuesday, June 16, 2015 3:59 PM
  • Thank Charles,

    accurate response to me. It is not enough to change Review > Language > Set Proofing Language.

    If the styles of the template (I was trying to change proofing language from EN-AU to EN-US) contain language setting (Modify style > Format dropwdown > Language...) in other language (in my case EN-AU) documents created from the template will have Proofing Language to the undesired language (EN-AU in my case).

    I was trying to figure out why the template has language setting to EN-US but the documents based on it had EN-AU. It turned our the styles used in template had EN-AU language.

    Change "Set Proofing Language" AND go through all styles in the template/document and change their language to the desired one (EN-US in my case). In the end I got the documents in EN-US as expected.

    I would mark this as an answer for me, thank you.

    Tuesday, April 11, 2017 7:18 PM
  • This just results in "Compile Error Sub or Function not defined" having pressed Enter after typing NormalTemplateOpenAsDocument...

    :(

    Clearing auto-detect language makes no difference either. Very unimpressed that such a simple function is complicated/impossible to select in such a mature programme.

    Wednesday, February 28, 2018 11:01 AM
  • This just results in "Compile Error Sub or Function not defined" having pressed Enter after typing NormalTemplateOpenAsDocument...

    To open the Normal template as a document using the code I suggested, you have to type the command exactly as I wrote it in my previous reply (and you have to do so in the Immediate window of the Visual Basic Editor):

    NormalTemplate.OpenAsDocument

    Specifically, you can't omit the period before "O" in "OpenAsDocument."

       

    Stefan Blom, Microsoft Word MVP

    Wednesday, February 28, 2018 11:18 AM

  • Clearing auto-detect language makes no difference either. Very unimpressed that such a simple function is complicated/impossible to select in such a mature programme.

    Clearing the "Detect language automatically" option only applies to FUTURE edits. If language formatting is incorrect in one ore more existing documents, those must be dealt with one by one. You can modify the Normal style but often you also have to select all the text (Ctrl+A) and manually re-apply the proper language via the Language dialog box. Be sure to exit the dialog box with OK (do NOT click Set As Default in those instances).

       

    Stefan Blom, Microsoft Word MVP

    • Proposed as answer by Charles Kenyon Thursday, February 21, 2019 1:59 PM
    Wednesday, February 28, 2018 11:20 AM
  • You, my good friend, are a hero.
    Monday, February 18, 2019 4:14 AM
  • THANK YOU SO MUCH
    Sunday, November 17, 2019 3:58 PM