none
how to turn off alert setup email notification RRS feed

  • Question

  • It's been a hassle to me for a while - every time I setup an alert for a group of users, each one will get an email notification as follow:

    ==============================================================================

    'XXX' has subscribed you for alert 'Alert Name here' on 'Home Site'.

    You will receive alerts in e-mail. The timing and criteria for the alerts depend on the settings entered when the alert was added.

    You can change this alert or any of your other alerts on the My Alerts on this Site page.

    ==============================================================================

    That email kind of freaks out some of the users and I have to spend time to explain.

    Is there any way to turn off that email notification, or send the confirmation email to someone else (e.g. myself)?


    -Bin
    Monday, December 27, 2010 4:01 PM

All replies

  • Go to Site Settings > Site Administration > User Alerts

    Select user from drop down for - Display alert for and click on update

    It will show you list and libraries on which user has subscribed alerts.

    Select the list / library and click on ""Delete selected Alert" which will delete email notification


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Monday, December 27, 2010 4:07 PM
  • Go to Site Settings > Site Administration > User Alerts


    Sorry. I didn't make myself clear. There are two email notifications here. You are turning off the alert email. However, I want to have the alert email, but to turn off the initial setup email that freaks out users.


    -Bin
    • Edited by Mike Walsh FIN Monday, December 27, 2010 4:38 PM No need to repeat the text of the alert message
    Monday, December 27, 2010 4:24 PM
  • It's hard to imagine that this message "freaks out" users. It's the same standard message that has been sent to users since the product came out many years ago.

    It's possible to change the text of the message. Search for a forum post with something like "edit the alert e-mail message text".


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    • Marked as answer by Bin_ Monday, December 27, 2010 7:38 PM
    • Unmarked as answer by Bin_ Tuesday, April 5, 2011 4:13 AM
    Monday, December 27, 2010 4:41 PM
  •  

    Mike, I wouldn't assume too quick that because it's been a standard message for some years, that means no-one has found it an issue, and most especially because SP primarily for all those years was a document management tool, not a business administration/process tool and now peeps are catching up with that fact so I find it totally natural that these kind of questions are only now coming out.

    I had the exact same requirement as Bin two weeks ago, where I was trying to set an alert for all of our active directory users, we had to put a messy explanation in our weekly newsletter to explain that they would get an initial alert... and then forever onwards, would just recieve one alert each time a new document was uploaded.

    Regretfully the alerts failed (on the uploaded documents) so we have to try it again this week, by resetting alerts for all users 'again', and I would 'kill' to be able to switch off the 'you have had an alert set up for you' type email, because it's confusing the users why they are getting it again and it also makes it very apparent that our 'live test' did not work so makes us look stupid!

    So, to repeat and endorse Bin's comment... Can you actually disable the initial 'you have been set up an alert by Susie leighton' email?.

    That would be a more useful response from a respected MVP ;-) 

     

     

    Thursday, January 27, 2011 11:07 PM
  • > ike, I wouldn't assume too quick that because it's been a standard message for some years, that means no-one has found it an issue

    I was objecting to the word "freaked out". While it has been an issue for a long time it has not been that level of an issue.

    > That would be a more useful response from a respected MVP ;-) 

    No longer (if ever I was) a "respected MVP". Dropped 1 Oct 2010.

    As for a better answer. I'm on holiday so my moderating for the next few weeks will be done sitting in a hotel lobby. I'll be concentrating on (as fast as possible) moderating rather than trying to answer questions.

    Mike


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Friday, January 28, 2011 9:22 AM
  • Well enjoy your hols! However, I'd suggest the Pool or Bar over the hotel lobby lol 

    I can't believe there aren't more Pro's out there that could answer this in your absence, this being an official Microsoft forum N all that.

    By the way, our alerts failed again so I have one last chance this Friday before we ditch SharePoint alerts to 'all users' and revert to manual cut and pasting users into an outlook email each week.... How naff is that!

    :-( 

     

     

     

     

    Monday, January 31, 2011 7:51 PM
  • Hi,

    It is possible to block the notification mail being sent to the user.

    But only and only if we are subscribing alerts programmatically, in that case

    let us consider 'samplealert' as SPAlert object, there is a pre defined method

    "sampleralert.Updates(false)", will not send the notification mail to the users.

    Hope this helps to some extent.

     

    Senthu

    Wednesday, March 2, 2011 12:02 PM
  • I am not sure if someone is following this thread. Since it is still marked as "Unanswered" I think I am trying to "help" by giving some information....if not confusing more.....

    there is a similar thread here; http://social.msdn.microsoft.com/Forums/sharepoint/en-US/ad2a3635-b8e1-454f-9f68-a6199a34402f/how-to-disable-alert-subscription-confirmation-email

    excerpts from this thread's discussion is; Initial successful Subscription email has something to do with "SubNew.aspx" page which is in "Layouts" folder in 14Hive. If you are good in analyzing the code, you may get some hints on "how to block that subscription email".


    Naveed.DG MCITP, MCTS -SharePoint 2010 Administrator "Vote As Helpful" If it helps!!

    Tuesday, June 3, 2014 12:07 PM
  • In the event anyone else is still searching for the answer to this question...

    My workaround was to change the name of the outgoing email server in Central Admin. You can't remove the server details, otherwise the alerts button becomes inactive. But, adding something like .old on the end of the email server name temporarily as you set up a ton of alerts, then changing it back, will prevent users from receiving all those emails.
    • Proposed as answer by rhare Wednesday, October 21, 2015 10:29 PM
    Wednesday, October 21, 2015 10:29 PM
  • Powershell example confirmed to work fine in SP2013

    Add-PSSnapin microsoft.sharepoint.powershell
    
    $SPsite = Get-SPSite "http://example.lan"
    $SPweb=$SPsite.Rootweb 
    $SPlist=$SPweb.lists["News"] 
    
    $SPuser = $SPweb.EnsureUser('domain\user') 
    
    $SPnewAlert = $SPuser.Alerts.Add() 
    $SPnewAlert.Title = "News Alert"
    $SPnewAlert.AlertType=[Microsoft.SharePoint.SPAlertType]::List 
    $SPnewAlert.List = $SPlist
    $SPnewAlert.DeliveryChannels = [Microsoft.SharePoint.SPAlertDeliveryChannels]::Email 
    $SPnewAlert.EventType = [Microsoft.SharePoint.SPEventType]::All
    $SPnewAlert.AlertFrequency = [Microsoft.SharePoint.SPAlertFrequency]::Immediate 
    # .Update(0) = add alert silently, .Update() = send email to user
    $SPnewAlert.Update(0) 
    
    $SPweb.Dispose() 
    $SPSite.Dispose() 

    Regards,

    Martin

     
    Thursday, December 17, 2015 5:52 PM
  • It's not the greatest solution, but this works...

    I go into Central Admin, and temporarily change the name of the Exchange Server to something that doesn't exist.
    We then had a list where we had to create quite a lot of alerts on behalf of users. Give it some time, like maybe 30 minutes, and then go back into CA and change the mail server back to the original FQDN.

    The alert 'setup' email will then fail to send as the mail server cannot be reached.

    If this sounds like the solution for you, test it in your own environment first. It did the trick for me.

    Using this to get around setting up ad-hoc alerts wouldn't be advised. But for bulk alert setups... it did for me!
    Also, our server doesn't have hundreds/thousands of users and emails being sent, so we're able to get around turning off emails without anyone really noticing.

    Thursday, February 11, 2016 10:33 PM
  • Thank You, it was really Helpful.
    Wednesday, August 3, 2016 11:03 PM
  • Does this work for subsite? I tried using Openweb instead of Rootweb but does not seem to work.
    Monday, November 13, 2017 10:18 PM