none
ATA Gateway 1.8 Update (1 1.8.6765) fails to install on Windows Server Core 2012 R2

    Question

  • Hi All,

    A week ago we had tried to install ATA Gateway 1.8 on our server core Domain Controllers but it had failed. This bug was apparently fixed in 1.8 update 1 (listed here)

    However now when we install it on core the installer fails without erroring. I have looked into the ATA deployment log which has the following in it:

    [6A6C:5944][2017-08-09T21:59:54]i000: 2017-08-09 20:59:54.1044 27244 5   Debug [\[]DeploymentModel[\]] [\[]DeploymentAction=Upgrade[\]]
    [6A6C:5944][2017-08-09T21:59:54]i000: 2017-08-09 20:59:54.4013 27244 5   Error [\[]GatewayBootstrapperApplication[\]] Failed to create deployment manager [\[]exception=System.ArgumentNullException: Value cannot be null.
    Parameter name: path1
       at System.IO.Path.Combine(String path1, String path2)
       at Microsoft.Tri.Gateway.Deployment.Bundle.UI.Application.GatewayUpgradeDeploymentConfiguration.GetMandatoryConfiguration(String installationPath)
       at Microsoft.Tri.Gateway.Deployment.Bundle.UI.Application.GatewayUpgradeDeploymentConfiguration..ctor(Engine engine, String installationPath)
       at Microsoft.Tri.Gateway.Deployment.Bundle.UI.Application.GatewayDeploymentModel.CreateDeploymentConfiguration(Engine engine)
       at Microsoft.Tri.Deployment.Bundle.UI.Application.DeploymentModel..ctor(BootstrapperApplication bootstrapperApplication, ProductComponent productComponent, String productFullShortName, String productFullLongName, String productFullLongDisplayName)
       at Microsoft.Tri.Gateway.Deployment.Bundle.UI.Application.GatewayDeploymentModel..ctor(BootstrapperApplication bootstrapperApplication)
       at Microsoft.Tri.Gateway.Deployment.Bundle.UI.Application.GatewayBootstrapperApplication.CreateDeploymentModel()
       at Microsoft.Tri.Deployment.Bundle.UI.Application.BootstrapperApplication`1.Run()[\]]
    [6A6C:4910][2017-08-09T21:59:54]i500: Shutting down, exit code: 0x643

    Can anyone help me with how to resolve this error?


    • Edited by Thomas Higgins Thursday, August 10, 2017 10:00 AM cleaning up post
    Thursday, August 10, 2017 9:58 AM

All replies

  • I think you are hitting this:

    https://social.technet.microsoft.com/Forums/en-US/83e627dd-6537-4638-a1f1-b236b80334ef/cannot-install-ata-gateway-on-server-2016-core?forum=mata

    try to go over the same resolution steps of clearing the partially deployed bundle, then reinstall 1.8 Update1.

    (No need to remove .net 4.7 this time, as 1.8 Update 1 will know how to handle it this time)

    Thursday, August 10, 2017 10:32 AM
  • I am not hitting that. I mentioned in my post that I am installing 1.8 Update 1.

    There is no ATA currently installed on the Server Core DCs. It is patched with the latest patches.

    In our testing with 1.8 without update 1, the steps in your link worked as a workaround. When installing 1.8 with update 1, they don't.

    Thursday, August 10, 2017 10:53 AM
  • Look towards the end of the thread, there  is the same Argument null error, only there it was in UI, in 1.8.1 it;s only in the log.

    This is the outcome of your previous attempt to install 1.8.

    Thursday, August 10, 2017 11:16 AM