none
KB2706783 (SC2012 - DPM Update Rollup 2) Installation Fails RRS feed

  • Question

  • I'm trying to install Update Rollup 2 on my DPM server. The advice provided by the installer regarding manually performing the DPM database backup does not seem to be the cause, as I have the same problem if I run the installer with the option to skip the database backup. I do believe I've located the section of the log file that contains the error. Any advice?

    ================================

    MSI (s) (04:44) [13:57:35:213]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI8D90.tmp, Entrypoint: PreserveRegistrySettings
    MSI (s) (04:F8) [13:57:35:213]: Generating random cookie.
    MSI (s) (04:F8) [13:57:35:213]: Created Custom Action Server with PID 5980 (0x175C).
    MSI (s) (04:3C) [13:57:35:244]: Running as a service.
    MSI (s) (04:3C) [13:57:35:260]: Hello, I'm your 64bit Impersonated custom action server.
    CustomAction _PreserveRegistrySettings.97DDF5B3_3770_4C3E_8673_52BD081E1EFD returned actual error code 1157 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (04:44) [13:57:35:260]: Closing MSIHANDLE (1) of type 790542 for thread 7284
    MSI (s) (04:74) [13:57:35:260]: Note: 1: 1723 2: _PreserveRegistrySettings.97DDF5B3_3770_4C3E_8673_52BD081E1EFD 3: PreserveRegistrySettings 4: C:\Windows\Installer\MSI8D90.tmp
    MSI (s) (04:74) [13:57:35:260]: Transforming table Error.

    MSI (s) (04:74) [13:57:35:260]: Transforming table Error.

    MSI (s) (04:74) [13:57:35:260]: Note: 1: 2262 2: Error 3: -2147287038
    MSI (c) (38:18) [13:57:35:260]: Font created.  Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

    MSI (s) (04:74) [13:57:42:717]: Transforming table Error.

    MSI (s) (04:74) [13:57:42:717]: Transforming table Error.

    MSI (s) (04:74) [13:57:42:717]: Note: 1: 2262 2: Error 3: -2147287038
    MSI (s) (04:74) [13:57:42:717]: Product: Microsoft System Center 2012 - Data Protection Manager -- Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.  Action _PreserveRegistrySettings.97DDF5B3_3770_4C3E_8673_52BD081E1EFD, entry: PreserveRegistrySettings, library: C:\Windows\Installer\MSI8D90.tmp

    Action ended 13:57:42: _PreserveRegistrySettings.97DDF5B3_3770_4C3E_8673_52BD081E1EFD. Return value 3.

    ================================

    Monday, September 24, 2012 8:49 PM

All replies

  • Hi

    Did you come right or are you still experiencing the problem with Rollup 2?

    Thursday, October 11, 2012 3:49 PM
  • Nope, still not working. I honestly gave up and am crossing my fingers that SP1 will work when it's released. If you have any advice in the meantime I'd really appreciate it.
    Thursday, October 11, 2012 4:06 PM
  • If you try re-download the file and run with elevated rights does it help?

    Running it with the option to backup the database, is this possible in your environment?

    Thursday, October 11, 2012 4:28 PM
  • Yes, sadly, I've done all of that multiple times with no change in the outcome.
    Thursday, October 11, 2012 5:19 PM
  • If your Database is not in the default location, you can try this approach which worked for me.

    Make sure you backup your DPM Database before continuing to do this procedure and any DPM update.

    I was able to get pass this issue with my installation by performing a combination of the procedures outlined in this article http://support.microsoft.com/kb/972727:

    My environment utilizes a remote dedicated SQL Instance.

    My test lab DPM server Registry setting:

    Looking at Option 1 Registry’s setting value ‘DatabasePath’ that is pointing to the local DPM server itself and then checking the path location – is valid but empty because my SQL components are installed on a remote SQL server from the RTM installation.

    To install UR2 in my test lab I performed the following:

    1. Close any local opened DPM consoles

    2. Downloaded the UR2 to a local folder and expanded

    3. Locate the Registry Entry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Setup\ DatabasePath <value>

    4. Export this ‘Setup’ section out before updating

    5. Update this registry setting to reflect the location of your Database file

    6. Save it, verify it and close the Registry editor

    7. Open an Administrative command prompt to the folder that your expanded UR2 too

    8. Run the command line in Option 2 of the above URL substituting with your environments information: <DataProtectionManager-KBID.exe> SKIPDBBACKUP=1 /l*v <<var>logfile location</var>>

    9. You should see a success screen displayed.

    10. Re-open the Registry and verify the setting in #3 above has changed back to its default value

    11. If the value did not change back, repopulate it

    12. Open the DPM Console

    Paul

    Saturday, October 13, 2012 7:13 PM
  • Thanks for the advice, but I still get the same error.

    I'm seeing the same behavior on the recently released UR3 as well. I'm going to open a PSS ticket at this point.

    Wednesday, October 17, 2012 6:34 PM
  • hi everyone
    i have the same problem to install DPM Update Rollup 2, did you find à solution?
    Monday, November 2, 2015 4:38 PM