none
DPM 2010 agent installation on Domain Controller RRS feed

  • Question

  • Hello all, recently I tried to install the agent from my DPM 2010 server onto a Win2K8 Domain controller which failed (used a Domain Admin's credientials for the install, and on trusted domain). I remember in DPM 2007 you needed to install the agent through command line. Can someone post up the correct steps to get a DPM 2010 agent installed to a DC?

    • Moved by MarcReynolds Friday, October 8, 2010 12:03 PM (From:Data Protection Manager)
    Thursday, October 7, 2010 1:32 AM

Answers

  • Hi John!

    Try to install the agent manually by doing this:

    1. Share the RA catalouge under the %systemdrive%:\Program Files\Microsoft DPM\DPM\ProtectionAgents
    2. From the DC, run from START \\DPMSERVERNAME\RA
    3. Right click the DPMAgentInstaller_x86 or DPMAgentInstaller_x64 depending in the version on the operating system and choose run as administrator
    4. After the installation is finished open a command prompt in an elevated mode
    5. Go to %systemdrive%\Program Files\Microsoft Data Protection Manager\DPM\bin
    6. Run the SetDpmServer.exe executable with the switch -DpmServerName <DpmServerName>
    7. On the DPM server attatch the agent in the console using the installation wizard or the PowerShell command Attach-ProductionServer.ps1

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    • Marked as answer by Parag Agrawal Friday, October 8, 2010 10:28 AM
    Thursday, October 7, 2010 12:10 PM
    Moderator

All replies

  • Hi,

    You can manually install the DPM agent on any system that has a firewall on that is preventing installing from the DPM console using the following procedures.

    Installing Protection Agents Manually: http://technet.microsoft.com/en-us/library/ff399459.aspx

    If the PS happens to be a RODC, use:

    Installing Protection Agents on a Read-Only Domain Controller: http://technet.microsoft.com/en-us/library/ff634246.aspx

     


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, October 7, 2010 3:03 AM
    Moderator
  • Hi John!

    Try to install the agent manually by doing this:

    1. Share the RA catalouge under the %systemdrive%:\Program Files\Microsoft DPM\DPM\ProtectionAgents
    2. From the DC, run from START \\DPMSERVERNAME\RA
    3. Right click the DPMAgentInstaller_x86 or DPMAgentInstaller_x64 depending in the version on the operating system and choose run as administrator
    4. After the installation is finished open a command prompt in an elevated mode
    5. Go to %systemdrive%\Program Files\Microsoft Data Protection Manager\DPM\bin
    6. Run the SetDpmServer.exe executable with the switch -DpmServerName <DpmServerName>
    7. On the DPM server attatch the agent in the console using the installation wizard or the PowerShell command Attach-ProductionServer.ps1

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    • Marked as answer by Parag Agrawal Friday, October 8, 2010 10:28 AM
    Thursday, October 7, 2010 12:10 PM
    Moderator
  • Thanks I will try the manual agent install to get this working and will report back.
    Thursday, October 7, 2010 10:05 PM
  • Any Luck?


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Friday, October 8, 2010 8:46 AM
    Moderator
  • Same issue here.

    Pushing a DPM 2010 agent to a Windows 2008 DC fails with the error:

    ============
    You cannot install the protection agent on SV-MGMT-03.xxxxxx.nl because access to the computer has been denied.
    ============

    The DPM 2010 agent software is installed but DPM doesn't add the server. With an attach i can add the server but DPM 2010 cannot communicate with it.

    ===============
    Protection agent version: 3.0.7696.0
    Error: Data Protection Manager Error ID: 270
     The agent operation failed on sv-mgmt-03.xxxxx.nl because DPM could not communicate with the DPM protection agent. The computer may be protected by another DPM server, or the protection agent may have been uninstalled on the protected computer.
    If sv-mgmt-03.xxxxxxx.nl is a workgroup server, the password for the DPM user account could have been changed or may have expired.
    Recommended action: Check the following to troubleshoot this issue:
    1) If the agent is not installed on sv-mgmt-03.xxxxxxxxx.nl, run DpmAgentInstaller.exe with this DPM computer as a parameter. For details, see the DPM Deployment Guide.
    2) To attach the computer correctly to this DPM server, run the SetDpmServer tool on the protected computer.
    3) If the computer is protected by another DPM server, or if the protection agent has been uninstalled, remove the protected data sources on this computer from active protection. Then, remove the entry of this computer from the Agents tab in the Management task area.
    4) If sv-mgmt-03.xxxxxxxxx.nl is a workgroup server, run SetDpmServer with the -UpdatePassword flag on the protected computer and Update-NonDomainServerInfo.ps1 on the DPM server to update the password.
    5) If the DPM server and the protected computer are not in the same domain, ensure that there is a two-way trust setup between the two domains.
     If the computer is protected by another DPM server, or if the protection agent has been uninstalled, you can remove the record of the computer from this DPM server.
    ==============

    Anyone a solution for this?

    Monday, October 25, 2010 9:39 AM
  • I am also looking for the answer to problem.  Have you come up with anything?

    Thanks.....


    Ron
    Thursday, November 25, 2010 12:39 AM
  • On the domain controller where you've done a manual install and the DPM server is throwing a 270 error trying to communicate with it check the following.

    Ensure that Authenticate Users is in the Builtin -> Users group. That group should have Authenticated Users, Domain Users, and INTERACTIVE as members.

    /Steve


    Steve L [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, December 29, 2010 5:55 PM
    Moderator
  • Unbelivable! 

     

    Thanks a lot Steve, that did the trick. Had been struggeling with installing DPM Agent 2010 on W2K8 R2 DC's for two days now and followed all other tips (which was all the same) didnt work. But as soon as I added "Authenticated Users" to the "Builtin\Users" Security Group the agent status went from "Error" to "OK".

     

    Thanks!

     

    /Thomas P.


    TP
    Monday, January 9, 2012 9:36 AM
  • Steve you save my day. Been troubleshooting the DPM agent on DC's for a while, but your post just solved my problem
    Thursday, January 16, 2014 8:22 AM
  • it work, thanks Steve

    El Khiyati

    Thursday, March 1, 2018 10:02 AM